diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-19 23:45:14 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-20 16:07:50 -0800 |
commit | 52394379815d84febff28f0de0fb6ab291351122 (patch) | |
tree | 4958828acff42ade10ea6cf106fd434fe929871c | |
parent | fa6e382bc649bf06a26e176fb8de3ebe84b1be76 (diff) | |
download | meta-openembedded-52394379815d84febff28f0de0fb6ab291351122.tar.gz |
liblightmodbus: Fix packaging errors when using multilib
Fixes
ERROR: liblightmodbus-2.0.2-r0 do_package: QA Issue: liblightmodbus: Files/directories were installed but not shipped in any package:
/usr/lib
/usr/lib/liblightmodbus.a
Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/liblightmodbus/liblightmodbus/0001-cmake-Use-GNUInstallDirs-instead-of-hardcoding-lib-p.patch b/meta-oe/recipes-extended/liblightmodbus/liblightmodbus/0001-cmake-Use-GNUInstallDirs-instead-of-hardcoding-lib-p.patch new file mode 100644 index 000000000..321b41289 --- /dev/null +++ b/meta-oe/recipes-extended/liblightmodbus/liblightmodbus/0001-cmake-Use-GNUInstallDirs-instead-of-hardcoding-lib-p.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 066c49158a71ea77598c9e1ae16bba63d6ac6bb5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 19 Dec 2019 23:41:35 -0800 | ||
4 | Subject: [PATCH] cmake: Use GNUInstallDirs instead of hardcoding lib path | ||
5 | |||
6 | Upstream-Status: Submitted [https://github.com/Jacajack/liblightmodbus/pull/12] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | CMakeLists.txt | 6 +++--- | ||
10 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
11 | |||
12 | diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
13 | index ce6cc88..bee83aa 100644 | ||
14 | --- a/CMakeLists.txt | ||
15 | +++ b/CMakeLists.txt | ||
16 | @@ -242,14 +242,14 @@ if ( DEFINED AVR ) | ||
17 | ) | ||
18 | endif( ) | ||
19 | |||
20 | - | ||
21 | +include(GNUInstallDirs) | ||
22 | #Installation | ||
23 | install( | ||
24 | TARGETS lightmodbus | ||
25 | - ARCHIVE DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/" | ||
26 | + ARCHIVE DESTINATION "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/" | ||
27 | ) | ||
28 | |||
29 | #Install headers | ||
30 | install( | ||
31 | DIRECTORY "${CMAKE_SOURCE_DIR}/include/" DESTINATION "${CMAKE_INSTALL_PREFIX}/include/" FILES_MATCHING PATTERN "*.h" | ||
32 | -) | ||
33 | \ No newline at end of file | ||
34 | +) | ||
35 | -- | ||
36 | 2.24.1 | ||
37 | |||
diff --git a/meta-oe/recipes-extended/liblightmodbus/liblightmodbus_2.0.2.bb b/meta-oe/recipes-extended/liblightmodbus/liblightmodbus_2.0.2.bb index 1e35f08c0..7fc599798 100644 --- a/meta-oe/recipes-extended/liblightmodbus/liblightmodbus_2.0.2.bb +++ b/meta-oe/recipes-extended/liblightmodbus/liblightmodbus_2.0.2.bb | |||
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d" | |||
7 | 7 | ||
8 | inherit cmake pkgconfig | 8 | inherit cmake pkgconfig |
9 | 9 | ||
10 | SRC_URI = "git://github.com/Jacajack/liblightmodbus.git;protocol=https" | 10 | SRC_URI = "git://github.com/Jacajack/liblightmodbus.git;protocol=https \ |
11 | file://0001-cmake-Use-GNUInstallDirs-instead-of-hardcoding-lib-p.patch \ | ||
12 | " | ||
11 | SRCREV = "59d2b405f95701e5b04326589786dbb43ce49e81" | 13 | SRCREV = "59d2b405f95701e5b04326589786dbb43ce49e81" |
12 | 14 | ||
13 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |