summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2020-01-07 15:29:22 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-09 14:05:37 -0800
commit4f3c9ca9b03d7a37514cc318e13166ddc191f61e (patch)
tree719f8d07ff1e8b65ee4029c9b21f90a16ebc8246
parentca3d2a2dfa3c1ecd0a3e05a2a0171bb5c313623b (diff)
downloadmeta-openembedded-4f3c9ca9b03d7a37514cc318e13166ddc191f61e.tar.gz
python3-jsonrpcserver: allow to use as non-root
This version has some file system permission issues, all the files are readable by the owner only (in the archive from pypi.org). Given all files in the target file system will ultimately be owned by root, this means that this package can only be used by root. Fix the permissions, and hopefully the next version will have the archive fixed. The version has been hard-coded on purpose here so as to remind us to double-check if the _append() is still needed after a version upgrade. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
index 7d464b16c..ceae6abd8 100644
--- a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.0.bb
@@ -21,3 +21,7 @@ RDEPENDS_${PN} += "\
21" 21"
22 22
23BBCLASSEXTEND = "native nativesdk" 23BBCLASSEXTEND = "native nativesdk"
24
25do_install_append() {
26 chmod 0644 ${D}${PYTHON_SITEPACKAGES_DIR}/jsonrpcserver-4.1.0-py3.7.egg-info/*
27}