diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-09-26 10:03:59 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-11-19 13:13:23 -0800 |
commit | 44f8de24e25c78867631de1bf2a10a2eb731188f (patch) | |
tree | 7595cd9c59f2cfe3d9c717264a224a6558c2eb89 | |
parent | d2d705ed2fdaec8362f1fd886d4c27ca58929f5c (diff) | |
download | meta-openembedded-44f8de24e25c78867631de1bf2a10a2eb731188f.tar.gz |
python3-pint: Upgrade to 0.24.3
- Switch to fetching from pypi
- Use automake format for pytests
- Fix ptests, by adding missing runtime deps
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pint/run-ptest | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pint_0.24.3.bb (renamed from meta-python/recipes-devtools/python/python3-pint_0.24.1.bb) | 17 |
2 files changed, 11 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint/run-ptest b/meta-python/recipes-devtools/python/python3-pint/run-ptest index 5cec71169..8d2017d39 100644 --- a/meta-python/recipes-devtools/python/python3-pint/run-ptest +++ b/meta-python/recipes-devtools/python/python3-pint/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | ||
3 | pytest | 3 | pytest --automake |
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.24.1.bb b/meta-python/recipes-devtools/python/python3-pint_0.24.3.bb index 8959a72ff..23e9fdb0e 100644 --- a/meta-python/recipes-devtools/python/python3-pint_0.24.1.bb +++ b/meta-python/recipes-devtools/python/python3-pint_0.24.3.bb | |||
@@ -6,14 +6,11 @@ SECTION = "devel/python" | |||
6 | LICENSE = "BSD-3-Clause" | 6 | LICENSE = "BSD-3-Clause" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
8 | 8 | ||
9 | PYPI_PACKAGE := "Pint" | 9 | PYPI_PACKAGE = "pint" |
10 | 10 | ||
11 | inherit ptest python_setuptools_build_meta | 11 | inherit pypi ptest python_setuptools_build_meta |
12 | 12 | ||
13 | SRCREV = "4c2caccfc6cdac1f80a9bfa15ebea1ca49836881" | 13 | SRC_URI[sha256sum] = "d54771093e8b94c4e0a35ac638c2444ddf3ef685652bab7675ffecfa0c5c5cdf" |
14 | SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master" | ||
15 | S = "${WORKDIR}/git" | ||
16 | #SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4" | ||
17 | 14 | ||
18 | DEPENDS += "python3-setuptools-scm-native" | 15 | DEPENDS += "python3-setuptools-scm-native" |
19 | 16 | ||
@@ -27,12 +24,18 @@ RDEPENDS:${PN} += " \ | |||
27 | python3-setuptools \ | 24 | python3-setuptools \ |
28 | python3-packaging \ | 25 | python3-packaging \ |
29 | " | 26 | " |
30 | 27 | # python3-misc for timeit.py | |
31 | RDEPENDS:${PN}-ptest += " \ | 28 | RDEPENDS:${PN}-ptest += " \ |
32 | python3-appdirs \ | 29 | python3-appdirs \ |
30 | python3-attrs \ | ||
33 | python3-flexcache \ | 31 | python3-flexcache \ |
34 | python3-flexparser \ | 32 | python3-flexparser \ |
33 | python3-misc \ | ||
35 | python3-pytest \ | 34 | python3-pytest \ |
35 | python3-pytest-benchmark \ | ||
36 | python3-pytest-subtests \ | ||
37 | python3-statistics \ | ||
38 | python3-unittest-automake-output \ | ||
36 | " | 39 | " |
37 | 40 | ||
38 | do_install_ptest() { | 41 | do_install_ptest() { |