summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-10-10 11:48:12 +0300
committerKhem Raj <raj.khem@gmail.com>2024-11-19 13:13:25 -0800
commit4441545a5dc75120bb4e839d71c6f8fc500e917f (patch)
tree4df5be54dbe50bfe3d1c3f05543473033e03d816
parent3aaba78e66f384f53ba31946d331ff16dadac4b3 (diff)
downloadmeta-openembedded-4441545a5dc75120bb4e839d71c6f8fc500e917f.tar.gz
python3-alembic: switch to PEP-517 build backend
- The project has a proper pyproject.toml which declares the setuptools.build.meta PEP-517 backend. - The PyPi package name (defaults to PN without the python3- prefix), so there is no need to set PYPI_PACKAGE as alembic, it is by default. WARNING: python3-alembic-1.13.3-r0 do_check_backend: QA Issue: inherits setuptools3 but has pyproject.toml with setuptools.build_meta, use the correct class [pep517-backend] Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 207266f4c08f7de1bbe70f6d9105f97533df2b5d) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.13.2.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.13.2.bb b/meta-python/recipes-devtools/python/python3-alembic_1.13.2.bb
index 6f8fb8c33..5a276539d 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.13.2.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.13.2.bb
@@ -2,12 +2,10 @@ DESCRIPTION = "A database migration tool for SQLAlchemy"
2LICENSE = "MIT" 2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=00f8f5c8aab58c3e1cd61525a6675174" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=00f8f5c8aab58c3e1cd61525a6675174"
4 4
5inherit pypi setuptools3 5inherit pypi python_setuptools_build_meta
6 6
7SRC_URI[sha256sum] = "1ff0ae32975f4fd96028c39ed9bb3c867fe3af956bd7bb37343b54c9fe7445ef" 7SRC_URI[sha256sum] = "1ff0ae32975f4fd96028c39ed9bb3c867fe3af956bd7bb37343b54c9fe7445ef"
8 8
9PYPI_PACKAGE = "alembic"
10
11RDEPENDS:${PN} += "\ 9RDEPENDS:${PN} += "\
12 python3-dateutil \ 10 python3-dateutil \
13 python3-editor \ 11 python3-editor \