diff options
author | Markus Volk <f_l_k@t-online.de> | 2023-02-22 11:33:03 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-02-22 08:49:19 -0800 |
commit | 434127fe02221685bd9d59cd195bc45371cd9344 (patch) | |
tree | 73b5003088046b2a81de9b5369042161aad56ea3 | |
parent | 976076f6989962136351a40d0bebcccccf66bcc7 (diff) | |
download | meta-openembedded-434127fe02221685bd9d59cd195bc45371cd9344.tar.gz |
gparted: update 1.4.0 -> 1.5.0
- Remove unneeded patches
- Keep buildable without polkit after gettext migration
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-gnome/recipes-extended/gparted/files/0001-Do-not-use-NULL-where-boolean-is-expected.patch | 33 | ||||
-rw-r--r-- | meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch | 30 | ||||
-rw-r--r-- | meta-gnome/recipes-extended/gparted/gparted_1.5.0.bb (renamed from meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb) | 11 |
3 files changed, 6 insertions, 68 deletions
diff --git a/meta-gnome/recipes-extended/gparted/files/0001-Do-not-use-NULL-where-boolean-is-expected.patch b/meta-gnome/recipes-extended/gparted/files/0001-Do-not-use-NULL-where-boolean-is-expected.patch deleted file mode 100644 index 1b0d24024..000000000 --- a/meta-gnome/recipes-extended/gparted/files/0001-Do-not-use-NULL-where-boolean-is-expected.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | From 9af84e1c08a2159c10baf13244e2c8a7d7e837e9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 27 Jan 2022 23:02:20 -0800 | ||
4 | Subject: [PATCH] Do not use NULL where boolean is expected | ||
5 | |||
6 | Fixes | ||
7 | src/GParted_Core.cc:73:57: error: static_cast from 'nullptr_t' to 'PedPartitionFlag' (aka '_PedPartitionFlag') is not allowed | ||
8 | | for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( NULL ) ) ; | ||
9 | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | ||
10 | | 1 error generated. | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | src/GParted_Core.cc | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/src/GParted_Core.cc b/src/GParted_Core.cc | ||
19 | index f7ac970..3290c66 100644 | ||
20 | --- a/src/GParted_Core.cc | ||
21 | +++ b/src/GParted_Core.cc | ||
22 | @@ -70,7 +70,7 @@ GParted_Core::GParted_Core() | ||
23 | ped_exception_set_handler( ped_exception_handler ) ; | ||
24 | |||
25 | //get valid flags ... | ||
26 | - for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( NULL ) ) ; | ||
27 | + for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( false ) ) ; | ||
28 | flag ; | ||
29 | flag = ped_partition_flag_next( flag ) ) | ||
30 | flags .push_back( flag ) ; | ||
31 | -- | ||
32 | 2.35.0 | ||
33 | |||
diff --git a/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch b/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch deleted file mode 100644 index aae200e27..000000000 --- a/meta-gnome/recipes-extended/gparted/files/0001-use-posix-basename.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | Subject: [PATCH] BCache_Info.cc: use posix basename | ||
2 | |||
3 | gnu 'basename' is undeclared for cplusplus if using musl. Use posix basename instead. | ||
4 | |||
5 | fdebug-prefix-map=TOPDIR/build/tmp/work/cortexa57-yoe-linux-musl/gparted/1.4.0-r0/ | ||
6 | recipe-sysroot-native=-fvisibility-inlines-hidden -c -o Dialog_Disklabel.o ../../ | ||
7 | gparted-1.4.0/src/Dialog_Disklabel.cc ../../gparted-1.4.0/src/BCache_Info.cc:52:33: | ||
8 | |||
9 | error: use of undeclared identifier 'basename'; did you mean 'g_basename'? | ||
10 | return "/dev/" + Glib::ustring(basename(buf)); | ||
11 | ^~~~~~~~ | ||
12 | g_basename | ||
13 | |||
14 | Signed-off-by: Markus Volk <f_l_k@t-online.de> | ||
15 | |||
16 | Upstream-Status: Submitted | ||
17 | |||
18 | https://gitlab.gnome.org/GNOME/gparted/-/merge_requests/99 | ||
19 | |||
20 | --- a/src/BCache_Info.cc 2022-03-02 22:04:17.000000000 +0100 | ||
21 | +++ b/src/BCache_Info.cc 2022-04-09 15:02:56.932218665 +0200 | ||
22 | @@ -17,7 +17,7 @@ | ||
23 | |||
24 | #include "BCache_Info.h" | ||
25 | |||
26 | -#include <string.h> // GNU version of basename() | ||
27 | +#include <libgen.h> // POSIX version of basename() | ||
28 | #include <unistd.h> | ||
29 | #include <glibmm/ustring.h> | ||
30 | #include <glibmm/fileutils.h> | ||
diff --git a/meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb b/meta-gnome/recipes-extended/gparted/gparted_1.5.0.bb index dde5a02ab..fdfb1ef47 100644 --- a/meta-gnome/recipes-extended/gparted/gparted_1.4.0.bb +++ b/meta-gnome/recipes-extended/gparted/gparted_1.5.0.bb | |||
@@ -3,17 +3,15 @@ HOMEPAGE = "http://gparted.org/index.php" | |||
3 | LICENSE = "GPL-2.0-only" | 3 | LICENSE = "GPL-2.0-only" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
5 | 5 | ||
6 | inherit autotools pkgconfig python3native gnome-help gtk-icon-cache features_check | 6 | inherit autotools pkgconfig python3native gettext gnome-help gtk-icon-cache features_check |
7 | 7 | ||
8 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" | 8 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
9 | 9 | ||
10 | SRC_URI = " \ | 10 | SRC_URI = " \ |
11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ | 11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
12 | file://0001-Install-polkit-action-unconditionally-executable-pke.patch \ | 12 | ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', 'file://0001-Install-polkit-action-unconditionally-executable-pke.patch', '', d)} \ |
13 | file://0001-Do-not-use-NULL-where-boolean-is-expected.patch \ | ||
14 | file://0001-use-posix-basename.patch \ | ||
15 | " | 13 | " |
16 | SRC_URI[sha256sum] = "e5293a792e53fdbeba29c4a834113cd9603d0d639330da931a468bf3687887be" | 14 | SRC_URI[sha256sum] = "3c95ea26a944083ff1d9b17639b1e2ad9758df225dc751ff407b2a6aa092a8de" |
17 | 15 | ||
18 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/gparted/files/gparted/" | 16 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/gparted/files/gparted/" |
19 | UPSTREAM_CHECK_REGEX = "gparted-(?P<pver>\d+\.(\d+)+(\.\d+)+)" | 17 | UPSTREAM_CHECK_REGEX = "gparted-(?P<pver>\d+\.(\d+)+(\.\d+)+)" |
@@ -27,6 +25,9 @@ DEPENDS += " \ | |||
27 | parted \ | 25 | parted \ |
28 | " | 26 | " |
29 | 27 | ||
28 | PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}" | ||
29 | PACKAGECONFIG[polkit] = ",,polkit" | ||
30 | |||
30 | FILES:${PN} += " \ | 31 | FILES:${PN} += " \ |
31 | ${datadir}/appdata \ | 32 | ${datadir}/appdata \ |
32 | ${datadir}/icons \ | 33 | ${datadir}/icons \ |