summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-08-28 10:43:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:12:38 +0200
commit3c9163b5d6feea24fae679109a908968920fb899 (patch)
treecf4166b199d14e03f47f36c2ae53f4387d4de4dc
parenta08f493101fb8f74547c256e4bef39f0d8f13618 (diff)
downloadmeta-openembedded-3c9163b5d6feea24fae679109a908968920fb899.tar.gz
ca-certificates: remove
This is now in OE-Core as of ad2851cf0abc2ab35e0f60c96d3142c29a07c8fc. ca-certificates-cross is no longer used (effectively replaced by a native BBCLASSEXTEND in the main recipe). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates-20130119.inc15
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates-cross_20130119.bb12
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates/0001-update-ca-certificates-remove-c-rehash.patch45
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates/0002-update-ca-certificates-use-SYSROOT.patch56
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates_20130119.bb30
5 files changed, 0 insertions, 158 deletions
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates-20130119.inc b/meta-oe/recipes-support/ca-certificates/ca-certificates-20130119.inc
deleted file mode 100644
index ac993bc3c..000000000
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates-20130119.inc
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "Common CA certificates"
2HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
3SECTION = "misc"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=6135800ff6d893c7904d7aad90972eb5"
6PR = "r1"
7
8SRC_URI = "${DEBIAN_MIRROR}/main/c/ca-certificates/ca-certificates_${PV}.tar.gz \
9 file://0001-update-ca-certificates-remove-c-rehash.patch \
10 file://0002-update-ca-certificates-use-SYSROOT.patch"
11
12SRC_URI[md5sum] = "1fbbec2028a33cf865b79c204aa2e626"
13SRC_URI[sha256sum] = "fb51ec9a2c551838cc1646a0b3c9e6bea5c1bb20ff5d71c542451fac4b191c22"
14
15inherit allarch
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates-cross_20130119.bb b/meta-oe/recipes-support/ca-certificates/ca-certificates-cross_20130119.bb
deleted file mode 100644
index 171d6a07c..000000000
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates-cross_20130119.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1require ca-certificates-${PV}.inc
2
3do_install() {
4 install -d ${D}${bindir_crossscripts}
5 install -m755 ${S}/sbin/update-ca-certificates ${D}${bindir_crossscripts}
6}
7
8SYSROOT_PREPROCESS_FUNCS += "ca_certificates_sysroot_preprocess"
9
10ca_certificates_sysroot_preprocess() {
11 sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
12}
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates/0001-update-ca-certificates-remove-c-rehash.patch b/meta-oe/recipes-support/ca-certificates/ca-certificates/0001-update-ca-certificates-remove-c-rehash.patch
deleted file mode 100644
index ccb0efcc6..000000000
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates/0001-update-ca-certificates-remove-c-rehash.patch
+++ /dev/null
@@ -1,45 +0,0 @@
1From 111e905fe931da1a3800accfc675cc01c8ee080c Mon Sep 17 00:00:00 2001
2From: Ulf Samuelsson <ulf@emagii.com>
3Date: Tue, 28 Feb 2012 06:42:58 +0100
4Subject: [PATCH] update-ca-certificates: remove c rehash
5
6Updated earlier patch to apply clean on 2012-02-12
7Signed-off-by: Ulf Samuelsson <ulf@emagii.com>
8---
9 sbin/update-ca-certificates | 20 ++++++++++----------
10 1 files changed, 10 insertions(+), 10 deletions(-)
11
12diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
13index 5375950..c567e3d 100755
14--- a/sbin/update-ca-certificates
15+++ b/sbin/update-ca-certificates
16@@ -132,16 +132,16 @@ rm -f "$CERTBUNDLE"
17 ADDED_CNT=$(wc -l < "$ADDED")
18 REMOVED_CNT=$(wc -l < "$REMOVED")
19
20-if [ "$ADDED_CNT" -gt 0 ] || [ "$REMOVED_CNT" -gt 0 ]
21-then
22- # only run if set of files has changed
23- if [ "$verbose" = 0 ]
24- then
25- c_rehash . > /dev/null
26- else
27- c_rehash .
28- fi
29-fi
30+#if [ "$ADDED_CNT" -gt 0 ] || [ "$REMOVED_CNT" -gt 0 ]
31+#then
32+# # only run if set of files has changed
33+# if [ "$verbose" = 0 ]
34+# then
35+# c_rehash . > /dev/null
36+# else
37+# c_rehash .
38+# fi
39+#fi
40
41 chmod 0644 "$TEMPBUNDLE"
42 mv -f "$TEMPBUNDLE" "$CERTBUNDLE"
43--
441.7.4.1
45
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates/0002-update-ca-certificates-use-SYSROOT.patch b/meta-oe/recipes-support/ca-certificates/ca-certificates/0002-update-ca-certificates-use-SYSROOT.patch
deleted file mode 100644
index 689fdd90b..000000000
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates/0002-update-ca-certificates-use-SYSROOT.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1Upstream-Status: Pending
2
3From 724cb153ca0f607fb38b3a8db3ebb2742601cd81 Mon Sep 17 00:00:00 2001
4From: Andreas Oberritter <obi@opendreambox.org>
5Date: Tue, 19 Mar 2013 17:14:33 +0100
6Subject: [PATCH 2/2] update-ca-certificates: use $SYSROOT
7
8Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
9---
10 sbin/update-ca-certificates | 14 +++++++-------
11 1 file changed, 7 insertions(+), 7 deletions(-)
12
13diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
14index c567e3d..923b68a 100755
15--- a/sbin/update-ca-certificates
16+++ b/sbin/update-ca-certificates
17@@ -37,11 +37,11 @@ do
18 shift
19 done
20
21-CERTSCONF=/etc/ca-certificates.conf
22-CERTSDIR=/usr/share/ca-certificates
23-LOCALCERTSDIR=/usr/local/share/ca-certificates
24+CERTSCONF=$SYSROOT/etc/ca-certificates.conf
25+CERTSDIR=$SYSROOT/usr/share/ca-certificates
26+LOCALCERTSDIR=$SYSROOT/usr/local/share/ca-certificates
27 CERTBUNDLE=ca-certificates.crt
28-ETCCERTSDIR=/etc/ssl/certs
29+ETCCERTSDIR=$SYSROOT/etc/ssl/certs
30
31 cleanup() {
32 rm -f "$TEMPBUNDLE"
33@@ -64,9 +64,9 @@ add() {
34 PEM="$ETCCERTSDIR/$(basename "$CERT" .crt | sed -e 's/ /_/g' \
35 -e 's/[()]/=/g' \
36 -e 's/,/_/g').pem"
37- if ! test -e "$PEM" || [ "$(readlink "$PEM")" != "$CERT" ]
38+ if ! test -e "$PEM" || [ "$(readlink "$PEM")" != "${CERT##$SYSROOT}" ]
39 then
40- ln -sf "$CERT" "$PEM"
41+ ln -sf "${CERT##$SYSROOT}" "$PEM"
42 echo +$PEM >> "$ADDED"
43 fi
44 cat "$CERT" >> "$TEMPBUNDLE"
45@@ -148,7 +148,7 @@ mv -f "$TEMPBUNDLE" "$CERTBUNDLE"
46
47 echo "$ADDED_CNT added, $REMOVED_CNT removed; done."
48
49-HOOKSDIR=/etc/ca-certificates/update.d
50+HOOKSDIR=$SYSROOT/etc/ca-certificates/update.d
51 echo -n "Running hooks in $HOOKSDIR...."
52 VERBOSE_ARG=
53 [ "$verbose" = 0 ] || VERBOSE_ARG=--verbose
54--
551.7.10.4
56
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates_20130119.bb b/meta-oe/recipes-support/ca-certificates/ca-certificates_20130119.bb
deleted file mode 100644
index 504190fd5..000000000
--- a/meta-oe/recipes-support/ca-certificates/ca-certificates_20130119.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1DEPENDS = "ca-certificates-cross"
2
3require ca-certificates-${PV}.inc
4
5inherit autotools
6
7do_install_prepend() {
8 mkdir -p ${D}/usr/share/ca-certificates
9 mkdir -p ${D}/usr/sbin
10 mkdir -p ${D}/etc/ssl/certs
11 mkdir -p ${D}/etc/ca-certificates/update.d
12}
13
14do_install_append() {
15 cd ${D}/usr/share/ca-certificates
16 echo "# Lines starting with # will be ignored" > ${D}/etc/ca-certificates.conf
17 echo "# Lines starting with ! will remove certificate on next update" >> ${D}/etc/ca-certificates.conf
18 echo "#" >> ${D}/etc/ca-certificates.conf
19 for crt in $(find . -type f -name '*.crt' -print)
20 do
21 crt=$(echo $crt | sed -e 's/\.\///')
22 echo $crt >> ${D}/etc/ca-certificates.conf
23 done
24}
25
26pkg_postinst_${PN} () {
27SYSROOT="$D" update-ca-certificates
28}
29
30CONFFILES_${PN} = "/etc/ca-certificates.conf"