summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2019-12-09 09:35:55 +0100
committerKhem Raj <raj.khem@gmail.com>2019-12-10 16:21:07 -0800
commit3b2293dedebae65cd3af0fb203dbae9de1a21c15 (patch)
tree1b918ce510f508c64c228f927920a118cfe560dc
parent88cb338ca92ce3cab21f43d910fa5934a8e50581 (diff)
downloadmeta-openembedded-3b2293dedebae65cd3af0fb203dbae9de1a21c15.tar.gz
gnome-shell: initial add 3.34.1
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.1.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.1.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.1.bb
new file mode 100644
index 000000000..d0b3af83d
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_3.34.1.bb
@@ -0,0 +1,64 @@
1SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase gsettings gettext gobject-introspection features_check upstream-version-is-even bash-completion
8
9REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
10
11DEPENDS = " \
12 libxml2-native \
13 sassc-native \
14 gtk+3 \
15 mutter \
16 evolution-data-server \
17 gcr \
18 gjs \
19 gnome-autoar \
20 polkit \
21 libcroco \
22 startup-notification \
23 ibus \
24 gsettings-desktop-schemas \
25"
26
27GTKDOC_MESON_OPTION = "gtk_doc"
28
29# gobject-introspection is mandatory and cannot be configured
30REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
31UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
32
33SRC_URI[archive.md5sum] = "2e00c22673d069d6b919b2ca1b225d89"
34SRC_URI[archive.sha256sum] = "ccd86559b9c897c219d2d2ebfdb8413efa4c1bee846427c750cb8a301b3f6d1e"
35
36PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
37PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
38PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
39PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
40
41EXTRA_OEMESON = " \
42 -Dman=false \
43"
44
45do_install_append() {
46 # fix shebangs
47 for tool in `find ${D}${bindir} -name '*-tool'`; do
48 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
49 done
50}
51
52FILES_${PN} += " \
53 ${datadir}/dbus-1 \
54 ${datadir}/gnome-control-center \
55 ${datadir}/xdg-desktop-portal \
56 ${systemd_user_unitdir} \
57"
58
59RDEPENDS_${PN} += "gsettings-desktop-schemas gdm-base librsvg-gtk"
60
61PACKAGES =+ "${PN}-tools"
62FILES_${PN}-tools = "${bindir}/*-tool"
63RDEPENDS_${PN}-tools = "python3-core"
64