diff options
author | Chong Lu <Chong.Lu@windriver.com> | 2014-04-18 18:16:31 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-04-21 13:31:47 +0200 |
commit | 38d45f7446d845b9c19367d7b17c4625537a1101 (patch) | |
tree | 8168904f80498a5526d512fa5c2fee607ccd3c01 | |
parent | 9dfa0411e01bd23df4994627fa0280c407a1aac9 (diff) | |
download | meta-openembedded-38d45f7446d845b9c19367d7b17c4625537a1101.tar.gz |
vim: don't check acl header if acl support disabled
Vim/vim-tiny always check 'sys/acl.h' existence even acl support
has been disabled from configure line. This works in mostly time
but except for acl works in an odd mode - while acl was mirrored
from sstate_cache, it will install 'sys/acl.h' to sysroot dir and
and then clean the header file with sysroot_cleansstate().
If build vim/vim-tiny and acl in parallel, below errors will occur:
* os_unix.c:2668:23: fatal error: sys/acl.h: No such file or directory
This change only workaround the failure and get build running, we
still need to fix it from acl side.
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/vim/files/disable_acl_header_check.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim_7.4.258.bb | 4 |
2 files changed, 30 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch new file mode 100644 index 000000000..8f824e78b --- /dev/null +++ b/meta-oe/recipes-support/vim/files/disable_acl_header_check.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Upstream-Status: pending | ||
2 | |||
3 | Don't check 'sys/acl.h' if acl support disabled for vim/vim-tiny. | ||
4 | |||
5 | Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> | ||
6 | ================================================ | ||
7 | diff --git a/src/configure.in b/src/configure.in | ||
8 | index fb965e5..d734064 100644 | ||
9 | --- a/src/configure.in | ||
10 | +++ b/src/configure.in | ||
11 | @@ -2511,7 +2511,7 @@ AC_CHECK_HEADERS(stdarg.h stdint.h stdlib.h string.h \ | ||
12 | sys/systeminfo.h locale.h sys/stream.h termios.h \ | ||
13 | libc.h sys/statfs.h poll.h sys/poll.h pwd.h \ | ||
14 | utime.h sys/param.h libintl.h libgen.h \ | ||
15 | - util/debug.h util/msg18n.h frame.h sys/acl.h \ | ||
16 | + util/debug.h util/msg18n.h frame.h \ | ||
17 | sys/access.h sys/sysinfo.h wchar.h wctype.h) | ||
18 | |||
19 | dnl sys/ptem.h depends on sys/stream.h on Solaris | ||
20 | @@ -3112,6 +3112,7 @@ AC_ARG_ENABLE(acl, | ||
21 | , [enable_acl="yes"]) | ||
22 | if test "$enable_acl" = "yes"; then | ||
23 | AC_MSG_RESULT(no) | ||
24 | +AC_CHECK_HEADERS(sys/acl.h) | ||
25 | AC_CHECK_LIB(posix1e, acl_get_file, [LIBS="$LIBS -lposix1e"], | ||
26 | AC_CHECK_LIB(acl, acl_get_file, [LIBS="$LIBS -lacl" | ||
27 | AC_CHECK_LIB(attr, fgetxattr, LIBS="$LIBS -lattr",,)],,),) | ||
diff --git a/meta-oe/recipes-support/vim/vim_7.4.258.bb b/meta-oe/recipes-support/vim/vim_7.4.258.bb index 023e8fc6c..9c6e231ad 100644 --- a/meta-oe/recipes-support/vim/vim_7.4.258.bb +++ b/meta-oe/recipes-support/vim/vim_7.4.258.bb | |||
@@ -6,7 +6,9 @@ RSUGGESTS_${PN} = "diffutils" | |||
6 | LICENSE = "vim" | 6 | LICENSE = "vim" |
7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" | 7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=b779e18be6ed77facc770691c967b8f8" |
8 | 8 | ||
9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim" | 9 | SRC_URI = "hg://vim.googlecode.com/hg/;protocol=https;module=vim \ |
10 | file://disable_acl_header_check.patch;patchdir=.. \ | ||
11 | " | ||
10 | SRCREV = "v7-4-258" | 12 | SRCREV = "v7-4-258" |
11 | 13 | ||
12 | S = "${WORKDIR}/${PN}/src" | 14 | S = "${WORKDIR}/${PN}/src" |