diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-06-16 22:12:36 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-06-16 22:25:54 -0700 |
commit | 36fcb1a8d1fcabcfd8bbd6772c6f2837799b8ec3 (patch) | |
tree | 15bfc71250d1d8eeef7c9f2a39232e7e33a3b622 | |
parent | 70c2f87bff1fcd45dc124a10b4c03bc92ab943ab (diff) | |
download | meta-openembedded-36fcb1a8d1fcabcfd8bbd6772c6f2837799b8ec3.tar.gz |
stressapptest: Fix build with libc++
when using libc++ instead of libstdc++, __gnu_cxx namespace
is not available
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-benchmark/stressapptest/stressapptest/libcplusplus-compat.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb | 4 |
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/stressapptest/stressapptest/libcplusplus-compat.patch b/meta-oe/recipes-benchmark/stressapptest/stressapptest/libcplusplus-compat.patch new file mode 100644 index 000000000..f5e7da359 --- /dev/null +++ b/meta-oe/recipes-benchmark/stressapptest/stressapptest/libcplusplus-compat.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | Fix compile on sytems using libc++ instead of libstdc++ | ||
2 | |||
3 | libc++ does not really implement __gnu_cxx namespace and it | ||
4 | compiles fine without this namespace, therefore detect libc++ | ||
5 | and if it is used them exclude this namespace | ||
6 | |||
7 | See https://github.com/stressapptest/stressapptest/issues/47 | ||
8 | |||
9 | Fixes | ||
10 | |||
11 | ./sattypes.h:33:17: error: expected namespace name | ||
12 | using namespace __gnu_cxx; //NOLINT | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | |||
17 | --- stressapptest-1.0.9.orig/src/sattypes.h | ||
18 | +++ stressapptest-1.0.9/src/sattypes.h | ||
19 | @@ -30,7 +30,9 @@ | ||
20 | #include "stressapptest_config_android.h" // NOLINT | ||
21 | #else | ||
22 | #include "stressapptest_config.h" // NOLINT | ||
23 | +#ifndef _LIBCPP_VERSION | ||
24 | using namespace __gnu_cxx; //NOLINT | ||
25 | +#endif // _LIBCPP_VERSION | ||
26 | #endif // __ANDROID__ | ||
27 | using namespace std; | ||
28 | |||
diff --git a/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb b/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb index 3e5748a3a..679201c52 100644 --- a/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb +++ b/meta-oe/recipes-benchmark/stressapptest/stressapptest_1.0.9.bb | |||
@@ -9,7 +9,9 @@ SECTION = "benchmark" | |||
9 | LICENSE = "Apache-2.0" | 9 | LICENSE = "Apache-2.0" |
10 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ea9d559f985fb4834317d8ed6b9e58" | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ea9d559f985fb4834317d8ed6b9e58" |
11 | 11 | ||
12 | SRC_URI = "https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz" | 12 | SRC_URI = "https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz \ |
13 | file://libcplusplus-compat.patch \ | ||
14 | " | ||
13 | 15 | ||
14 | SRC_URI[md5sum] = "d3a526c174c049dd7a1068dc74a62be2" | 16 | SRC_URI[md5sum] = "d3a526c174c049dd7a1068dc74a62be2" |
15 | SRC_URI[sha256sum] = "2ba470587ad4f6ae92057d427c3a2a2756e5f10bd25cd91e62eaef55a40b30a1" | 17 | SRC_URI[sha256sum] = "2ba470587ad4f6ae92057d427c3a2a2756e5f10bd25cd91e62eaef55a40b30a1" |