summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2022-01-14 14:22:15 +0100
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commit3670d61546bfce46f27ce52def370a69eb499f42 (patch)
treeaba75337d6ff4b43bd81aaf83f749f2fb8229d1a
parenta7fd038743aec62af4212547abaff17ad0d2e11a (diff)
downloadmeta-openembedded-3670d61546bfce46f27ce52def370a69eb499f42.tar.gz
nodejs: A little clean up
* The destination file name does not need to be specified to install if it matches the source file name (and -D is not used). * Mode 0755 does not need to be specified to install as it is the default. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
index 318cb961f..72fbecb8f 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_16.11.1.bb
@@ -151,7 +151,7 @@ do_configure () {
151 151
152do_compile () { 152do_compile () {
153 export LD="${CXX}" 153 export LD="${CXX}"
154 install -Dm 0755 ${B}/v8-qemu-wrapper.sh ${B}/out/Release/v8-qemu-wrapper.sh 154 install -D ${B}/v8-qemu-wrapper.sh ${B}/out/Release/v8-qemu-wrapper.sh
155 oe_runmake BUILDTYPE=Release 155 oe_runmake BUILDTYPE=Release
156} 156}
157 157
@@ -159,20 +159,22 @@ do_install () {
159 oe_runmake install DESTDIR=${D} 159 oe_runmake install DESTDIR=${D}
160} 160}
161 161
162BINARIES = " \
163 bytecode_builtins_list_generator \
164 ${@bb.utils.contains('PACKAGECONFIG', 'icu', 'gen-regexp-special-case', '', d)} \
165 mkcodecache \
166 node_mksnapshot \
167 torque \
168"
169
162do_install:append:class-native() { 170do_install:append:class-native() {
163 # Install the native binaries to provide it within sysroot for the target compilation 171 # Install the native binaries to provide it within sysroot for the target compilation
164 install -d ${D}${bindir} 172 install -d ${D}${bindir}
165 install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque 173 (cd ${S}/out/Release && install ${BINARIES} ${D}${bindir})
166 install -m 0755 ${S}/out/Release/bytecode_builtins_list_generator ${D}${bindir}/bytecode_builtins_list_generator
167 if ${@bb.utils.contains('PACKAGECONFIG','icu','true','false',d)}; then
168 install -m 0755 ${S}/out/Release/gen-regexp-special-case ${D}${bindir}/gen-regexp-special-case
169 fi
170 install -m 0755 ${S}/out/Release/mkcodecache ${D}${bindir}/mkcodecache
171 install -m 0755 ${S}/out/Release/node_mksnapshot ${D}${bindir}/node_mksnapshot
172} 174}
173 175
174PACKAGES =+ "${PN}-npm" 176PACKAGES =+ "${PN}-npm"
175FILES:${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx" 177FILES:${PN}-npm = "${nonarch_libdir}/node_modules ${bindir}/npm ${bindir}/npx"
176RDEPENDS:${PN}-npm = "bash python3-core python3-shell python3-datetime \ 178RDEPENDS:${PN}-npm = "bash python3-core python3-shell python3-datetime \
177 python3-misc python3-multiprocessing" 179 python3-misc python3-multiprocessing"
178 180