diff options
author | Derek Straka <derek@asterius.io> | 2016-06-18 10:05:17 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-07-07 09:51:27 -0400 |
commit | 3647a2ca4ca129708a8e143ed0cf1f712b4a15a0 (patch) | |
tree | f58ef3235915b827da6f6d20bd0d71e6709a1fcf | |
parent | 1cb7275961fd4bca3a6cb70e064ad6e6e1ff04d6 (diff) | |
download | meta-openembedded-3647a2ca4ca129708a8e143ed0cf1f712b4a15a0.tar.gz |
crda: fix errors about unused variables and remove from the blacklist
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-connectivity/crda/crda/fix-gcc-6-unused-variables.patch | 11 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/crda/crda_3.18.bb | 4 |
2 files changed, 12 insertions, 3 deletions
diff --git a/meta-networking/recipes-connectivity/crda/crda/fix-gcc-6-unused-variables.patch b/meta-networking/recipes-connectivity/crda/crda/fix-gcc-6-unused-variables.patch new file mode 100644 index 000000000..747804d34 --- /dev/null +++ b/meta-networking/recipes-connectivity/crda/crda/fix-gcc-6-unused-variables.patch | |||
@@ -0,0 +1,11 @@ | |||
1 | --- crda-3.18/utils/key2pub.py.orig 2016-06-18 09:54:23.671326113 -0400 | ||
2 | +++ crda-3.18/utils/key2pub.py 2016-06-18 09:54:34.387326300 -0400 | ||
3 | @@ -115,7 +115,7 @@ | ||
4 | .n = _n, .len_n = sizeof(_n), \ | ||
5 | } | ||
6 | |||
7 | -static const struct key_params keys[] = { | ||
8 | +static const struct key_params keys[] __attribute__((unused))= { | ||
9 | ''') | ||
10 | for n in xrange(n + 1): | ||
11 | output.write(' KEYS(e_%d, n_%d),\n' % (n, n)) | ||
diff --git a/meta-networking/recipes-connectivity/crda/crda_3.18.bb b/meta-networking/recipes-connectivity/crda/crda_3.18.bb index be490cb34..7e13d7ba7 100644 --- a/meta-networking/recipes-connectivity/crda/crda_3.18.bb +++ b/meta-networking/recipes-connectivity/crda/crda_3.18.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = "https://www.kernel.org/pub/software/network/crda/${BP}.tar.xz;name=cr | |||
11 | https://www.kernel.org/pub/software/network/wireless-regdb/wireless-regdb-2014.11.18.tar.xz;name=bin \ | 11 | https://www.kernel.org/pub/software/network/wireless-regdb/wireless-regdb-2014.11.18.tar.xz;name=bin \ |
12 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ | 12 | file://do-not-run-ldconfig-if-destdir-is-set.patch \ |
13 | file://fix-linking-of-libraries-used-by-reglib.patch \ | 13 | file://fix-linking-of-libraries-used-by-reglib.patch \ |
14 | file://fix-gcc-6-unused-variables.patch \ | ||
14 | " | 15 | " |
15 | SRC_URI[crda.md5sum] = "0431fef3067bf503dfb464069f06163a" | 16 | SRC_URI[crda.md5sum] = "0431fef3067bf503dfb464069f06163a" |
16 | SRC_URI[crda.sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" | 17 | SRC_URI[crda.sha256sum] = "43fcb9679f8b75ed87ad10944a506292def13e4afb194afa7aa921b01e8ecdbf" |
@@ -39,6 +40,3 @@ RDEPENDS_${PN} = "udev" | |||
39 | FILES_${PN} += "${libdir}crda/regulatory.bin \ | 40 | FILES_${PN} += "${libdir}crda/regulatory.bin \ |
40 | ${base_libdir}/udev/rules.d/85-regulatory.rules \ | 41 | ${base_libdir}/udev/rules.d/85-regulatory.rules \ |
41 | " | 42 | " |
42 | |||
43 | # http://errors.yoctoproject.org/Errors/Details/68635/ | ||
44 | PNBLACKLIST[crda] ?= "BROKEN: fails to build with gcc-6" | ||