diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2022-01-20 15:47:02 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-21 08:23:59 -0800 |
commit | 334932fffc2c9a98d1d32047c1de049c5a20c55e (patch) | |
tree | ae73044a5e52eca076a075128f6cfe52fb0962c0 | |
parent | 20cf58d25e0bdedb94c0c03e1a4eeeccee79731b (diff) | |
download | meta-openembedded-334932fffc2c9a98d1d32047c1de049c5a20c55e.tar.gz |
python3-lxml: check the return value
Check the return value in subprocess to guarantee the subprocess
execute successfully or not as after [1] introduced to limit the
netowork, there some difference during do_compile phase as below.
Before the change
# python
Python 3.8.10 (default, Nov 26 2021, 20:14:08)
[GCC 9.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import subprocess
>>> cmd = "pkg-config --modversion libxml-2.0"
>>> p = subprocess.Popen(cmd, shell=True,stdout=subprocess.PIPE, stderr=subprocess.PIPE)
>>> stdout_data, errors = p.communicate()
>>> print(stdout_data)
b'2.9.12\n'
>>> print(errors)
b''
>>>
After the change
# python
Python 3.8.10 (default, Nov 26 2021, 20:14:08)
[GCC 9.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import subprocess
>>> cmd = "pkg-config --modversion libxml-2.0"
>>> p = subprocess.Popen(cmd, shell=True,stdout=subprocess.PIPE, stderr=subprocess.PIPE)
>>> stdout_data, errors = p.communicate()
>>> print(stdout_data)
b'2.9.12\n'
>>> print(errors)
b'do_ypcall: clnt_call: RPC: Unable to send; errno = Network is unreachable\n'
>>>
[1] https://git.openembedded.org/bitbake/commit/?id=0746b6a2a32fec4c18bf1a52b1454ca4c04bf543
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch | 46 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb | 3 |
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch b/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch new file mode 100644 index 000000000..7d9121846 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-lxml/0001-setupinfo.py-check-the-return-value.patch | |||
@@ -0,0 +1,46 @@ | |||
1 | From 057872fa40e061100d61117cee5c3413ef2e40fc Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Thu, 20 Jan 2022 15:18:20 +0800 | ||
4 | Subject: [PATCH] setupinfo.py: check the return value | ||
5 | |||
6 | Use the return value altogether to check the subprocess execute | ||
7 | successfully or not as in some case it will print some noise | ||
8 | message though run successfully as below. | ||
9 | |||
10 | # python | ||
11 | Python 3.8.10 (default, Nov 26 2021, 20:14:08) | ||
12 | [GCC 9.3.0] on linux | ||
13 | Type "help", "copyright", "credits" or "license" for more information. | ||
14 | >>> import subprocess | ||
15 | >>> cmd = "pkg-config --modversion libxml-2.0" | ||
16 | >>> p = subprocess.Popen(cmd, shell=True,stdout=subprocess.PIPE, stderr=subprocess.PIPE) | ||
17 | >>> stdout_data, errors = p.communicate() | ||
18 | >>> print(stdout_data) | ||
19 | b'2.9.12\n' | ||
20 | >>> print(errors) | ||
21 | b'do_ypcall: clnt_call: RPC: Unable to send; errno = Network is unreachable\n' | ||
22 | >>> | ||
23 | |||
24 | Upstream-Status: Submitted [https://github.com/lxml/lxml/pull/336] | ||
25 | |||
26 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
27 | --- | ||
28 | setupinfo.py | 2 +- | ||
29 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
30 | |||
31 | diff --git a/setupinfo.py b/setupinfo.py | ||
32 | index 8c2a36fb..c1247c6d 100644 | ||
33 | --- a/setupinfo.py | ||
34 | +++ b/setupinfo.py | ||
35 | @@ -365,7 +365,7 @@ def run_command(cmd, *args): | ||
36 | stdout=subprocess.PIPE, stderr=subprocess.PIPE) | ||
37 | stdout_data, errors = p.communicate() | ||
38 | |||
39 | - if errors: | ||
40 | + if p.returncode != 0 and errors: | ||
41 | return '' | ||
42 | return decode_input(stdout_data).strip() | ||
43 | |||
44 | -- | ||
45 | 2.17.1 | ||
46 | |||
diff --git a/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb b/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb index cb33fcc3c..43f071281 100644 --- a/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb +++ b/meta-python/recipes-devtools/python/python3-lxml_4.7.1.bb | |||
@@ -20,6 +20,9 @@ DEPENDS += "libxml2 libxslt" | |||
20 | 20 | ||
21 | SRC_URI[sha256sum] = "a1613838aa6b89af4ba10a0f3a972836128801ed008078f8c1244e65958f1b24" | 21 | SRC_URI[sha256sum] = "a1613838aa6b89af4ba10a0f3a972836128801ed008078f8c1244e65958f1b24" |
22 | 22 | ||
23 | SRC_URI += " \ | ||
24 | file://0001-setupinfo.py-check-the-return-value.patch \ | ||
25 | " | ||
23 | inherit pkgconfig pypi setuptools3 | 26 | inherit pkgconfig pypi setuptools3 |
24 | 27 | ||
25 | # {standard input}: Assembler messages: | 28 | # {standard input}: Assembler messages: |