diff options
author | Ross Burton <ross.burton@intel.com> | 2018-07-03 10:20:18 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-04 06:09:58 -0700 |
commit | 317605fd577bbf6f3fa71638a5dc6ae3e27f0055 (patch) | |
tree | 97a4a2d73c708ee1bb7e1c5c1e66b3e7c3a86f54 | |
parent | 8b0f77d8388e505f7a46cd10d7b7fcab698e3a7b (diff) | |
download | meta-openembedded-317605fd577bbf6f3fa71638a5dc6ae3e27f0055.tar.gz |
p7zip: simplify recipe
The plugin-based 7z binary is mostly useless because it can't find the
libraries. Simply just install 7za, and install a compatibility symlink for 7z.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/p7zip/p7zip_16.02.bb | 23 |
1 files changed, 3 insertions, 20 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb index d986da904..13479a90f 100644 --- a/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb +++ b/meta-oe/recipes-extended/p7zip/p7zip_16.02.bb | |||
@@ -17,26 +17,9 @@ SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6 | |||
17 | S = "${WORKDIR}/${BPN}_${PV}" | 17 | S = "${WORKDIR}/${BPN}_${PV}" |
18 | 18 | ||
19 | do_install() { | 19 | do_install() { |
20 | install -d ${D}${bindir} | 20 | install -d ${D}${bindir} |
21 | install -m 0755 ${S}/bin/* ${D}${bindir} | 21 | install -m 0755 ${S}/bin/* ${D}${bindir} |
22 | } | 22 | ln -s 7za ${D}${bindir}/7z |
23 | |||
24 | # all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx | ||
25 | EXTRA_OEMAKE_class-native = "all3" | ||
26 | |||
27 | do_install_class-native() { | ||
28 | install -d ${D}${bindir} | ||
29 | install -d ${D}${bindir}/Codecs | ||
30 | install -m 0755 ${S}/bin/7* ${D}${bindir} | ||
31 | install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs | ||
32 | |||
33 | # Create a shell script wrapper to execute next to 7z.so | ||
34 | mv ${D}${bindir}/7z ${D}${bindir}/7z.bin | ||
35 | cat > ${D}${bindir}/7z << 'EOF' | ||
36 | #!/bin/sh | ||
37 | exec "$(dirname "$0")"/7z.bin "$@" | ||
38 | EOF | ||
39 | chmod 0755 ${D}${bindir}/7z | ||
40 | } | 23 | } |
41 | 24 | ||
42 | BBCLASSEXTEND = "native" | 25 | BBCLASSEXTEND = "native" |