diff options
author | leimaohui <leimaohui@fujitsu.com> | 2022-01-19 00:40:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-19 09:01:04 -0800 |
commit | 30ebf27c4cf2fa471909800a0bbeb582bb5594d1 (patch) | |
tree | c72d64453b15066f0e28c996f6e1bf7d87fdf1b0 | |
parent | 0d6d9d0cd9e33602988ae2305237a7dfd3f9173d (diff) | |
download | meta-openembedded-30ebf27c4cf2fa471909800a0bbeb582bb5594d1.tar.gz |
xrdp: Fixed build error with openssl 3.0 and upgraded from 0.9.17 to 0.9.18.
- Fixed build error with openssl 3.0 according to the suggestion of upsream.
Please reference to https://github.com/neutrinolabs/xrdp/issues/2121.
- Upgraded from 0.9.17 to 0.9.18.
- git repository of xrdp has recursive sources, so, reference to Fedora, modified SRC_URI to a tarball download URL of github.
Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/xrdp/xrdp_0.9.18.bb (renamed from meta-oe/recipes-support/xrdp/xrdp_0.9.17.bb) | 24 |
1 files changed, 9 insertions, 15 deletions
diff --git a/meta-oe/recipes-support/xrdp/xrdp_0.9.17.bb b/meta-oe/recipes-support/xrdp/xrdp_0.9.18.bb index bc93c12db..7ec6ae15f 100644 --- a/meta-oe/recipes-support/xrdp/xrdp_0.9.17.bb +++ b/meta-oe/recipes-support/xrdp/xrdp_0.9.18.bb | |||
@@ -6,19 +6,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=72cfbe4e7bd33a0a1de9630c91195c21 \ | |||
6 | 6 | ||
7 | inherit features_check autotools pkgconfig useradd systemd | 7 | inherit features_check autotools pkgconfig useradd systemd |
8 | 8 | ||
9 | DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native" | 9 | DEPENDS = "openssl virtual/libx11 libxfixes libxrandr libpam nasm-native imlib2 pixman libsm" |
10 | 10 | ||
11 | REQUIRED_DISTRO_FEATURES = "x11 pam" | 11 | REQUIRED_DISTRO_FEATURES = "x11 pam" |
12 | 12 | ||
13 | SRC_URI = "git://github.com/neutrinolabs/xrdp.git;branch=devel;protocol=https \ | 13 | SRC_URI = "https://github.com/neutrinolabs/${BPN}/releases/download/v${PV}/${BPN}-${PV}.tar.gz \ |
14 | file://xrdp.sysconfig \ | 14 | file://xrdp.sysconfig \ |
15 | file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \ | 15 | file://0001-Added-req_distinguished_name-in-etc-xrdp-openssl.con.patch \ |
16 | file://0001-Fix-the-compile-error.patch \ | 16 | file://0001-Fix-the-compile-error.patch \ |
17 | file://0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch \ | 17 | file://0001-arch-Define-NO_NEED_ALIGN-on-ppc64.patch \ |
18 | " | 18 | " |
19 | SRCREV = "58088324956d94fd2eb5e7694a318cccec6990f1" | ||
20 | 19 | ||
21 | S = "${WORKDIR}/git" | 20 | SRC_URI[sha256sum] = "c5eea0af055fac90c632e44fb667f1a25c55de2e34b37127e4cb0aabaef90a0f" |
21 | |||
22 | CFLAGS += " -Wno-deprecated-declarations" | ||
22 | 23 | ||
23 | PACKAGECONFIG ??= "" | 24 | PACKAGECONFIG ??= "" |
24 | PACKAGECONFIG[fuse] = " --enable-fuse, --disable-fuse, fuse" | 25 | PACKAGECONFIG[fuse] = " --enable-fuse, --disable-fuse, fuse" |
@@ -36,7 +37,9 @@ FILES:${PN}-dev += "${libdir}/xrdp/libcommon.so \ | |||
36 | ${libdir}/xrdp/libscp.so \ | 37 | ${libdir}/xrdp/libscp.so \ |
37 | ${libdir}/xrdp/libxrdpapi.so " | 38 | ${libdir}/xrdp/libxrdpapi.so " |
38 | 39 | ||
39 | EXTRA_OECONF = "--enable-pam-config=suse" | 40 | EXTRA_OECONF = "--enable-pam-config=suse --enable-fuse \ |
41 | --enable-pixman --enable-painter --enable-vsock \ | ||
42 | --enable-ipv6 --with-imlib2 --with-socketdir=${localstatedir}/run/${PN}" | ||
40 | 43 | ||
41 | do_configure:prepend() { | 44 | do_configure:prepend() { |
42 | cd ${S} | 45 | cd ${S} |
@@ -48,12 +51,7 @@ do_compile:prepend() { | |||
48 | sed -i 's/(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am/(MAKE) $(AM_MAKEFLAGS) install-exec-am/g' ${S}/keygen/Makefile.in | 51 | sed -i 's/(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am/(MAKE) $(AM_MAKEFLAGS) install-exec-am/g' ${S}/keygen/Makefile.in |
49 | } | 52 | } |
50 | 53 | ||
51 | |||
52 | do_install:append() { | 54 | do_install:append() { |
53 | install -d ${D}${sysconfdir} | ||
54 | install -d ${D}${sysconfdir}/xrdp | ||
55 | install -d ${D}${sysconfdir}/xrdp/pam.d | ||
56 | install -d ${D}${sysconfdir}/sysconfig/xrdp | ||
57 | 55 | ||
58 | # deal with systemd unit files | 56 | # deal with systemd unit files |
59 | install -d ${D}${systemd_unitdir}/system | 57 | install -d ${D}${systemd_unitdir}/system |
@@ -63,11 +61,8 @@ do_install:append() { | |||
63 | sed -i -e 's,@sysconfdir@,${sysconfdir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service | 61 | sed -i -e 's,@sysconfdir@,${sysconfdir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service |
64 | sed -i -e 's,@sbindir@,${sbindir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service | 62 | sed -i -e 's,@sbindir@,${sbindir},g' ${D}${systemd_unitdir}/system/xrdp.service ${D}${systemd_unitdir}/system/xrdp-sesman.service |
65 | 63 | ||
64 | install -d ${D}${sysconfdir}/sysconfig/xrdp | ||
66 | install -m 0644 ${S}/instfiles/*.ini ${D}${sysconfdir}/xrdp/ | 65 | install -m 0644 ${S}/instfiles/*.ini ${D}${sysconfdir}/xrdp/ |
67 | install -m 0644 ${S}/sesman/sesman.ini.in ${D}${sysconfdir}/xrdp/ | ||
68 | install -m 0644 ${S}/sesman/startwm.sh ${D}${sysconfdir}/xrdp/ | ||
69 | install -m 0644 ${S}/xrdp/xrdp.ini.in ${D}${sysconfdir}/xrdp/ | ||
70 | install -m 0644 ${S}/xrdp/xrdp_keyboard.ini ${D}${sysconfdir}/xrdp/ | ||
71 | install -m 0644 ${S}/keygen/openssl.conf ${D}${sysconfdir}/xrdp/ | 66 | install -m 0644 ${S}/keygen/openssl.conf ${D}${sysconfdir}/xrdp/ |
72 | install -m 0644 ${WORKDIR}/xrdp.sysconfig ${D}${sysconfdir}/sysconfig/xrdp/ | 67 | install -m 0644 ${WORKDIR}/xrdp.sysconfig ${D}${sysconfdir}/sysconfig/xrdp/ |
73 | chown xrdp:xrdp ${D}${sysconfdir}/xrdp | 68 | chown xrdp:xrdp ${D}${sysconfdir}/xrdp |
@@ -92,4 +87,3 @@ pkg_postinst:${PN}() { | |||
92 | fi | 87 | fi |
93 | fi | 88 | fi |
94 | } | 89 | } |
95 | PNBLACKLIST[xrdp] ?= "Needs porting to openssl 3.x" | ||