diff options
author | Khem Raj <raj.khem@gmail.com> | 2023-03-24 18:34:55 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-03-24 18:36:19 -0700 |
commit | 2ffb159dd0ed10ac2cb34ef7cb63ab609d22a137 (patch) | |
tree | 49dd430dd055e91e2ec99019e1d4ccbf38447621 | |
parent | ed326630a9b14ed98a46a511df5a2e2c24512451 (diff) | |
download | meta-openembedded-2ffb159dd0ed10ac2cb34ef7cb63ab609d22a137.tar.gz |
xfstests: Fix build with musl
Musl does not implement FTW_ACTIONRETVAL which is a GNU extention
therefore add that to configure check before enabling nftw
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-filesystems/recipes-utils/xfstests/xfstests/0001-m4-Check-for-FTW_ACTIONRETVAL-along-with-nftw.patch | 34 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb | 1 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests/0001-m4-Check-for-FTW_ACTIONRETVAL-along-with-nftw.patch b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-m4-Check-for-FTW_ACTIONRETVAL-along-with-nftw.patch new file mode 100644 index 000000000..fd34989fd --- /dev/null +++ b/meta-filesystems/recipes-utils/xfstests/xfstests/0001-m4-Check-for-FTW_ACTIONRETVAL-along-with-nftw.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 2a4fed8331f996421e65db446559991a854e2ad3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 24 Mar 2023 18:23:01 -0700 | ||
4 | Subject: [PATCH] m4: Check for FTW_ACTIONRETVAL along with nftw | ||
5 | |||
6 | FTW_ACTIONRETVAL is glibc specific extention which is used to implement | ||
7 | xfsfind but it may not be available on other C library implementations on Linux | ||
8 | e.g. musl. Therefore ensure that these defines are available before declaring | ||
9 | nftw() to be usable | ||
10 | |||
11 | Upstream-Status: Submitted [https://lore.kernel.org/fstests/20230325012858.587801-1-raj.khem@gmail.com/T/#u] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | Cc: Darrick J. Wong <djwong@kernel.org> | ||
14 | Cc: Zorro Lang <zlang@redhat.com> | ||
15 | --- | ||
16 | m4/package_libcdev.m4 | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/m4/package_libcdev.m4 b/m4/package_libcdev.m4 | ||
20 | index b41c087b..7f731044 100644 | ||
21 | --- a/m4/package_libcdev.m4 | ||
22 | +++ b/m4/package_libcdev.m4 | ||
23 | @@ -132,7 +132,7 @@ AC_DEFUN([AC_HAVE_NFTW], | ||
24 | #include <stddef.h> | ||
25 | #include <ftw.h> | ||
26 | ]], [[ | ||
27 | - nftw("/", (int (*)(const char *, const struct stat *, int, struct FTW *))1, 0, 0); | ||
28 | + nftw("/", (int (*)(const char *, const struct stat *, int, struct FTW *))1, 0, FTW_ACTIONRETVAL); | ||
29 | ]])],[have_nftw=yes | ||
30 | AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)]) | ||
31 | AC_SUBST(have_nftw) | ||
32 | -- | ||
33 | 2.40.0 | ||
34 | |||
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb index 9baa31f71..fdfe04574 100644 --- a/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb +++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2023.03.05.bb | |||
@@ -8,6 +8,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;na | |||
8 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ | 8 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ |
9 | file://0001-Add-a-return-type-to-aio_rw.patch \ | 9 | file://0001-Add-a-return-type-to-aio_rw.patch \ |
10 | file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ | 10 | file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ |
11 | file://0001-m4-Check-for-FTW_ACTIONRETVAL-along-with-nftw.patch \ | ||
11 | " | 12 | " |
12 | 13 | ||
13 | SRCREV_xfstests = "f7765774a1b5cb98c2f21a892e82b3421f40e791" | 14 | SRCREV_xfstests = "f7765774a1b5cb98c2f21a892e82b3421f40e791" |