diff options
author | Kai Kang <kai.kang@windriver.com> | 2015-08-24 23:31:55 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-09-11 10:59:02 -0400 |
commit | 28233847aa0f0a12f01da4782ab5b3ffefab51cd (patch) | |
tree | 565c8f368bbd31d803eabfdf1cba748a1de211d2 | |
parent | 51507b8106918a94b1c98139cba8f4f3f09c3784 (diff) | |
download | meta-openembedded-28233847aa0f0a12f01da4782ab5b3ffefab51cd.tar.gz |
atftp: build with gcc 5.2
atftp fails to build with gcc 5.2:
git/tftp_def.h:54:14: warning: inline function 'Strncpy' declared but never defined
git/argz.c:44:8: error: redefinition of 'argz_next'
GCC 5 defaults to -std=gnu11 instead of -std=gnu89. The semantics of
inline function changes. Pass '-std=gnu89' to gcc to compile atftp.
Ref:
https://gcc.gnu.org/gcc-5/porting_to.html
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-daemons/atftp/atftp_git.bb | 2 |
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/atftp/atftp_git.bb b/meta-networking/recipes-daemons/atftp/atftp_git.bb index b53f63774..0ece58f7d 100644 --- a/meta-networking/recipes-daemons/atftp/atftp_git.bb +++ b/meta-networking/recipes-daemons/atftp/atftp_git.bb | |||
@@ -32,6 +32,8 @@ USERADD_PACKAGES = "${PN}d" | |||
32 | USERADD_PARAM_${PN}d = "--system --no-create-home --shell /bin/false \ | 32 | USERADD_PARAM_${PN}d = "--system --no-create-home --shell /bin/false \ |
33 | --user-group nobody" | 33 | --user-group nobody" |
34 | 34 | ||
35 | EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -std=gnu89'" | ||
36 | |||
35 | do_install_append() { | 37 | do_install_append() { |
36 | install -d ${D}${sysconfdir}/init.d | 38 | install -d ${D}${sysconfdir}/init.d |
37 | install -m 0755 ${WORKDIR}/atftpd.init ${D}${sysconfdir}/init.d/atftpd | 39 | install -m 0755 ${WORKDIR}/atftpd.init ${D}${sysconfdir}/init.d/atftpd |