diff options
author | Markus Volk <f_l_k@t-online.de> | 2023-08-23 19:25:28 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-08-26 17:32:44 -0700 |
commit | 20de3804fa3946db7c4d5c79f1683d63309a13ca (patch) | |
tree | fc70e115161d72bb00a019e0d52ee8014b6b93cc | |
parent | 34e9187534e881d5676d09f12ccb6ecf01b56338 (diff) | |
download | meta-openembedded-20de3804fa3946db7c4d5c79f1683d63309a13ca.tar.gz |
libosinfo: add recipe
libosinfo
=========
libosinfo is a GObject based library API for managing information about
operating systems, hypervisors and the (virtual) hardware devices they can
support. It includes a database containing device metadata and provides APIs
to match/identify optimal devices for deploying an operating system on a
hypervisor. Via the magic of GObject Introspection, the API is available in all
common programming languages with demos for javascript (GJS/Seed) and python
(PyGObject). Vala bindings are also provided.
libosinfo is a required dependency for gnome-boxes
Signed-off-by: Markus Volk <f_l_k@t-online.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/libosinfo/libosinfo/0001-meson.build-allow-crosscompiling-gir.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb | 32 |
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libosinfo/libosinfo/0001-meson.build-allow-crosscompiling-gir.patch b/meta-oe/recipes-support/libosinfo/libosinfo/0001-meson.build-allow-crosscompiling-gir.patch new file mode 100644 index 000000000..778a1f6e1 --- /dev/null +++ b/meta-oe/recipes-support/libosinfo/libosinfo/0001-meson.build-allow-crosscompiling-gir.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 123b5a4c5e09f4262d4545a0bc5edb01a19b6b76 Mon Sep 17 00:00:00 2001 | ||
2 | From: Markus Volk <f_l_k@t-online.de> | ||
3 | Date: Mon, 21 Aug 2023 10:06:55 +0200 | ||
4 | Subject: [PATCH] meson.build: allow crosscompiling gir | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Markus Volk <f_l_k@t-online.de> | ||
9 | --- | ||
10 | meson.build | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/meson.build b/meson.build | ||
14 | index 39b739e..46f2252 100644 | ||
15 | --- a/meson.build | ||
16 | +++ b/meson.build | ||
17 | @@ -29,7 +29,7 @@ libosinfo_pkgconfdir = join_paths(libosinfo_libdir, 'pkgconfig') | ||
18 | |||
19 | # gobject introspection | ||
20 | gir = find_program('g-ir-scanner', required: get_option('enable-introspection')) | ||
21 | -enable_introspection = gir.found() and not meson.is_cross_build() | ||
22 | +enable_introspection = gir.found() | ||
23 | |||
24 | # vala | ||
25 | vapi_opt = get_option('enable-vala') | ||
26 | -- | ||
27 | 2.41.0 | ||
28 | |||
diff --git a/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb b/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb new file mode 100644 index 000000000..b02bc1281 --- /dev/null +++ b/meta-oe/recipes-support/libosinfo/libosinfo_1.10.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "API for managing information about operating systems, hypervisors and the (virtual) hardware devices." | ||
2 | HOMEPAGE = "https://libosinfo.org" | ||
3 | |||
4 | LICENSE = "LGPL-2.1-only & GPL-2.0-only" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=2b0e9926530c269f5ae95560370195af" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" | ||
7 | |||
8 | SRC_URI = " \ | ||
9 | git://gitlab.com/libosinfo/libosinfo.git;branch=main;protocol=https \ | ||
10 | file://0001-meson.build-allow-crosscompiling-gir.patch \ | ||
11 | " | ||
12 | |||
13 | SRCREV = "f503ff7a9e13963bcf396776bce0b209a819ba9b" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | inherit meson pkgconfig gtk-doc gobject-introspection vala | ||
18 | |||
19 | DEPENDS = "glib-2.0 libsoup libxslt" | ||
20 | |||
21 | GIR_MESON_OPTION = "enable-introspection" | ||
22 | GIR_MESON_ENABLE_FLAG = 'enabled' | ||
23 | GIR_MESON_DISABLE_FLAG = 'disabled' | ||
24 | GTKDOC_MESON_OPTION = "enable-gtk-doc" | ||
25 | |||
26 | EXTRA_OEMESON = " \ | ||
27 | -Dwith-pci-ids-path=${datadir}/pci.ids \ | ||
28 | -Dwith-usb-ids-path=${datadir}/usb.ids \ | ||
29 | -Denable-vala=enabled \ | ||
30 | " | ||
31 | |||
32 | RDEPENDS:${PN} = "pciutils-ids usbids" | ||