diff options
author | Roy Li <rongqing.li@windriver.com> | 2015-05-18 16:28:36 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2015-06-05 18:25:43 -0400 |
commit | 15a2927106219bc11eb54bee7cd789f7f19b598e (patch) | |
tree | dba22965ff677f4999a8c0dcf88ab8ff0cd73a07 | |
parent | 8e2571aab634a9b6e988e1248637e40da2c25ea6 (diff) | |
download | meta-openembedded-15a2927106219bc11eb54bee7cd789f7f19b598e.tar.gz |
autofs: fix a building failure
Signed-off-by: Roy Li <rongqing.li@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix-the-YACC-rule-to-fix-a-building-failure.patch | 62 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb | 1 |
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix-the-YACC-rule-to-fix-a-building-failure.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix-the-YACC-rule-to-fix-a-building-failure.patch new file mode 100644 index 000000000..9b641838f --- /dev/null +++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix-the-YACC-rule-to-fix-a-building-failure.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | [PATCH] fix the YACC rule to fix a building failure | ||
2 | |||
3 | Upstream-Statu: Pending | ||
4 | |||
5 | The original rule will create the header file twice, one is that the header | ||
6 | file as the object file is created, other time is when create the C source file. | ||
7 | since YACC always has "-d" parameter. | ||
8 | |||
9 | This lead to a race when compile amd_tok.o, the header file maybe rewritten. | ||
10 | |---------------------- | ||
11 | |amd_tok.l:359:10: error: 'RBRACKET' undeclared (first use in this function) | ||
12 | | ")" { return RBRACKET; } | ||
13 | | ^ | ||
14 | |../Makefile.rules:64: recipe for target 'amd_tok.o' failed | ||
15 | |---------------------- | ||
16 | Signed-off-by: Roy Li <rongqing.li@windriver.com> | ||
17 | --- | ||
18 | lib/Makefile | 6 ++++-- | ||
19 | modules/Makefile | 3 ++- | ||
20 | 2 files changed, 6 insertions(+), 3 deletions(-) | ||
21 | |||
22 | diff --git a/lib/Makefile b/lib/Makefile | ||
23 | index 4798a4b..c40cf86 100644 | ||
24 | --- a/lib/Makefile | ||
25 | +++ b/lib/Makefile | ||
26 | @@ -57,7 +57,8 @@ mount_xdr.o: mount_xdr.c | ||
27 | master_tok.c: master_tok.l | ||
28 | $(LEX) -o$@ -Pmaster_ $? | ||
29 | |||
30 | -master_parse.tab.c master_parse.tab.h: master_parse.y | ||
31 | +master_parse.tab.h: master_parse.tab.c | ||
32 | +master_parse.tab.c: master_parse.y | ||
33 | $(YACC) -v -d -p master_ -b master_parse $? | ||
34 | |||
35 | master_tok.o: master_tok.c master_parse.tab.h | ||
36 | @@ -67,7 +68,8 @@ master_parse.tab.o: master_parse.tab.c master_parse.tab.h | ||
37 | nss_tok.c: nss_tok.l | ||
38 | $(LEX) -o$@ -Pnss_ $? | ||
39 | |||
40 | -nss_parse.tab.c nss_parse.tab.h: nss_parse.y | ||
41 | +nss_parse.tab.h: nss_parse.tab.c | ||
42 | +nss_parse.tab.c: nss_parse.y | ||
43 | $(YACC) -v -d -p nss_ -b nss_parse $? | ||
44 | |||
45 | nss_tok.o: nss_tok.c nss_parse.tab.h | ||
46 | diff --git a/modules/Makefile b/modules/Makefile | ||
47 | index 237b70b..71415d0 100644 | ||
48 | --- a/modules/Makefile | ||
49 | +++ b/modules/Makefile | ||
50 | @@ -103,7 +103,8 @@ amd_tok.c: amd_tok.l | ||
51 | |||
52 | amd_tok.o: amd_tok.c amd_parse.tab.h | ||
53 | |||
54 | -amd_parse.tab.c amd_parse.tab.h: amd_parse.y | ||
55 | +amd_parse.tab.h: amd_parse.tab.c | ||
56 | +amd_parse.tab.c: amd_parse.y | ||
57 | $(YACC) -v -d -p amd_ -b amd_parse $? | ||
58 | |||
59 | amd_parse.tab.o: amd_parse.tab.c amd_parse.tab.h | ||
60 | -- | ||
61 | 1.9.1 | ||
62 | |||
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb index 13af2fe45..9540f923b 100644 --- a/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb +++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb | |||
@@ -20,6 +20,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \ | |||
20 | file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \ | 20 | file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \ |
21 | file://force-STRIP-to-emtpy.patch \ | 21 | file://force-STRIP-to-emtpy.patch \ |
22 | file://remove-bashism.patch \ | 22 | file://remove-bashism.patch \ |
23 | file://fix-the-YACC-rule-to-fix-a-building-failure.patch \ | ||
23 | " | 24 | " |
24 | 25 | ||
25 | SRC_URI[md5sum] = "b7724a9a55923f3c06933a8dfd1e79d3" | 26 | SRC_URI[md5sum] = "b7724a9a55923f3c06933a8dfd1e79d3" |