diff options
author | Daniela Plascencia <daniela.plascencia@linux.intel.com> | 2017-06-20 12:20:05 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-22 16:03:01 +0200 |
commit | 12e8df00c0282938363f2400b520f64d31222f51 (patch) | |
tree | e6228a7a74e9cd9b0d8ee4e781cd97ed7368b7cc | |
parent | 488533cf2c5bde7244d5c65ee5b13684896eb7ad (diff) | |
download | meta-openembedded-12e8df00c0282938363f2400b520f64d31222f51.tar.gz |
python-astroid: adds Python3 support
Extend the recipe for Python3 support.
Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 28 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-astroid.inc b/meta-python/recipes-devtools/python/python-astroid.inc new file mode 100644 index 000000000..a5bb10695 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-astroid.inc | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "An abstract syntax tree for Python with inference support." | ||
2 | HOMEPAGE = "https://pypi.python.org/pypi/astroid" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "LGPL" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
6 | |||
7 | SRC_URI[md5sum] = "6f65e4ea8290ec032320460905afb828" | ||
8 | SRC_URI[sha256sum] = "492c2a2044adbf6a84a671b7522e9295ad2f6a7c781b899014308db25312dd35" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | RDEPENDS_${PN}_class-target += "\ | ||
13 | ${PYTHON_PN}-distutils \ | ||
14 | ${PYTHON_PN}-lazy-object-proxy \ | ||
15 | ${PYTHON_PN}-six \ | ||
16 | ${PYTHON_PN}-subprocess \ | ||
17 | ${PYTHON_PN}-wrapt \ | ||
18 | ${PYTHON_PN}-re \ | ||
19 | ${PYTHON_PN}-setuptools \ | ||
20 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb b/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb index 9731e0bba..f7a0a5e73 100644 --- a/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb +++ b/meta-python/recipes-devtools/python/python-astroid_1.5.3.bb | |||
@@ -1,17 +1,7 @@ | |||
1 | SUMMARY = "An abstract syntax tree for Python with inference support." | 1 | inherit setuptools |
2 | HOMEPAGE = "https://pypi.python.org/pypi/astroid" | 2 | require python-astroid.inc |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "LGPL" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
6 | 3 | ||
7 | SRC_URI[md5sum] = "6f65e4ea8290ec032320460905afb828" | 4 | RDEPENDS_${PN}_class-target += "${PYTHON_PN}-enum34 \ |
8 | SRC_URI[sha256sum] = "492c2a2044adbf6a84a671b7522e9295ad2f6a7c781b899014308db25312dd35" | 5 | ${PYTHON_PN}-importlib \ |
9 | 6 | ${PYTHON_PN}-singledispatch \ | |
10 | inherit setuptools pypi | 7 | " |
11 | |||
12 | RDEPENDS_${PN}_class-target += "\ | ||
13 | ${PYTHON_PN}-distutils \ | ||
14 | ${PYTHON_PN}-lazy-object-proxy \ | ||
15 | ${PYTHON_PN}-six \ | ||
16 | ${PYTHON_PN}-wrapt \ | ||
17 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-astroid_1.5.3.bb b/meta-python/recipes-devtools/python/python3-astroid_1.5.3.bb new file mode 100644 index 000000000..6e32c288f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-astroid_1.5.3.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-astroid.inc | ||