diff options
author | Alper Ak <alperyasinak1@gmail.com> | 2023-11-11 14:17:39 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-11-11 09:26:41 -0800 |
commit | 105be9b3d92a4b863527418d9f20ce268d952282 (patch) | |
tree | ad0f806c076b317047c80826c77727306658ae2b | |
parent | e45b54e859366e8ce67eda2be3a7bafbee04a4c5 (diff) | |
download | meta-openembedded-105be9b3d92a4b863527418d9f20ce268d952282.tar.gz |
unionfs-fuse: upgrade 2.2 --> 3.4
- DEPENDS fuse --> fuse3 because CMake throwing "No package 'fuse3' found" error.
- Updated patch because CMakeLists.txt path has been changed.
- Bash added to RDEPENDS, accordingly this error --> ERROR: unionfs-fuse-3.4-r0 do_package_qa: QA Issue: /usr/sbin/mount.unionfs contained in package unionfs-fuse requires /bin/bash, but no providers found in RDEPENDS:unionfs-fuse? [file-rdeps]
Changelog:
3.4
- default to fuse2 api on macos when compiling
3.3
- fixed fortified compilation
- disabled logging to file since it had some unresolved locking issues
- add support for direct_io
3.2
- various nfs fixes
- various race condition fixes
3.1
- just fixes version mess (in manual file, cmake, etc.)
3.0
- libfuse3 support (and use is as new default)
- add branch-preserving logic
- make it compile under MacOS again
- minor fixes
Signed-off-by: Alper Ak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch | 33 | ||||
-rw-r--r-- | meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb (renamed from meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb) | 5 |
2 files changed, 18 insertions, 20 deletions
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch index bf363ca1b..13e782fa7 100644 --- a/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch +++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/files/0001-support-cross-compiling.patch | |||
@@ -1,32 +1,29 @@ | |||
1 | From 449cec34c123b86b792627553c6ec7471d2ee7ed Mon Sep 17 00:00:00 2001 | 1 | From 6e794a36564a2639a07d8720260e33d7c9435aa4 Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Alper Ak <alperyasinak1@gmail.com> |
3 | Date: Fri, 30 Jun 2017 14:46:51 +0800 | 3 | Date: Fri, 10 Nov 2023 20:50:48 +0300 |
4 | Subject: [PATCH] support cross compiling | 4 | Subject: [PATCH] support cross compiling |
5 | 5 | ||
6 | Do not override OE CMAKE variables | 6 | Do not override OE CMAKE variables |
7 | 7 | ||
8 | Upstream-Status: Pending | ||
9 | |||
10 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
9 | Signed-off-by: Alper Ak <alperyasinak1@gmail.com> | ||
11 | --- | 10 | --- |
12 | CMakeLists.txt | 4 ++-- | 11 | src/CMakeLists.txt | 4 ++-- |
13 | 1 file changed, 2 insertions(+), 2 deletions(-) | 12 | 1 file changed, 2 insertions(+), 2 deletions(-) |
14 | 13 | ||
15 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 14 | diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt |
16 | --- a/CMakeLists.txt | 15 | index f549496..ab71fb2 100644 |
17 | +++ b/CMakeLists.txt | 16 | --- a/src/CMakeLists.txt |
18 | @@ -10,9 +10,9 @@ IF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE) | 17 | +++ b/src/CMakeLists.txt |
19 | ENDIF(NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE) | 18 | @@ -4,9 +4,9 @@ set(UNIONFS_SRCS unionfs.c opts.c debug.c findbranch.c readdir.c |
19 | fuse_ops.c) | ||
20 | set(UNIONFSCTL_SRCS unionfsctl.c) | ||
20 | 21 | ||
21 | # Select flags. | 22 | -SET(CMAKE_C_FLAGS "-pipe -W -Wall -D_FORTIFY_SOURCE=2") |
22 | -SET(CMAKE_C_FLAGS "-pipe -W -Wall -DFORTIFY_SOURCE=2") | 23 | +SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -D_FORTIFY_SOURCE=2") |
23 | +SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pipe -W -Wall -DFORTIFY_SOURCE=2") | ||
24 | SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g") | 24 | SET(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g") |
25 | -SET(CMAKE_C_FLAGS_RELEASE "-O2") | 25 | -SET(CMAKE_C_FLAGS_RELEASE "-O2") |
26 | +SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2") | 26 | +SET(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O2") |
27 | SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG") | 27 | SET(CMAKE_C_FLAGS_DEBUG "-O0 -g -DDEBUG") |
28 | 28 | ||
29 | if (UNIX AND APPLE) | 29 | add_executable(unionfs ${UNIONFS_SRCS} ${HASHTABLE_SRCS}) |
30 | -- | ||
31 | 2.8.1 | ||
32 | |||
diff --git a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb index 03ae418a4..e8fda0536 100644 --- a/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_2.2.bb +++ b/meta-filesystems/recipes-filesystems/unionfs-fuse/unionfs-fuse_3.4.bb | |||
@@ -9,9 +9,10 @@ LIC_FILES_CHKSUM = "file://src/unionfs.c;beginline=3;endline=8;md5=30fa8de70fd8a | |||
9 | SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master;protocol=https \ | 9 | SRC_URI = "git://github.com/rpodgorny/${BPN}.git;branch=master;protocol=https \ |
10 | file://0001-support-cross-compiling.patch \ | 10 | file://0001-support-cross-compiling.patch \ |
11 | " | 11 | " |
12 | SRCREV = "b0e3805d3d84d44ddf3e4e5238ae0332145d8157" | 12 | SRCREV = "773f1853b043eeb64b7459f903a2c65bd096f9d9" |
13 | 13 | ||
14 | DEPENDS = "fuse" | 14 | DEPENDS = "fuse3" |
15 | RDEPENDS:${PN} = "bash" | ||
15 | 16 | ||
16 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
17 | 18 | ||