summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <git@andred.net>2019-11-10 22:05:08 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-13 07:17:03 -0800
commit0d4a59268cc696171534f6ddfbedc91a2b3abf1a (patch)
tree30b9530f2e09c15f5dde76ac8239b7e8ac0d39ea
parent0c6cdbe3dbe95ae1f4654c13583020ae55a6c0af (diff)
downloadmeta-openembedded-0d4a59268cc696171534f6ddfbedc91a2b3abf1a.tar.gz
nodejs: allow use of system gyp
Now that there is a gyp (python2) recipe in meta-python, allow its use instead of the bundled one for when meta-python is enabled. At the same time, unconditionally inherit pythonnative as in either case gyp actually uses python, and the build machine's python and installed modules should never be used. Signed-off-by: André Draszik <git@andred.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
index 4342693b3..e384b6286 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_10.17.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
6DEPENDS = "openssl" 6DEPENDS = "openssl"
7DEPENDS_append_class-target = " nodejs-native" 7DEPENDS_append_class-target = " nodejs-native"
8 8
9inherit pkgconfig 9inherit pkgconfig pythonnative
10 10
11COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*" 11COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
12COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*" 12COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
@@ -52,6 +52,7 @@ ARCHFLAGS ?= ""
52 52
53PACKAGECONFIG ??= "ares icu libuv zlib" 53PACKAGECONFIG ??= "ares icu libuv zlib"
54PACKAGECONFIG[ares] = "--shared-cares,,c-ares" 54PACKAGECONFIG[ares] = "--shared-cares,,c-ares"
55PACKAGECONFIG[gyp] = ",,gyp-py2-native"
55PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu" 56PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
56PACKAGECONFIG[libuv] = "--shared-libuv,,libuv" 57PACKAGECONFIG[libuv] = "--shared-libuv,,libuv"
57PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2" 58PACKAGECONFIG[nghttp2] = "--shared-nghttp2,,nghttp2"
@@ -77,6 +78,8 @@ python do_unpack() {
77 shutil.rmtree(d.getVar('S') + '/deps/openssl', True) 78 shutil.rmtree(d.getVar('S') + '/deps/openssl', True)
78 if 'ares' in d.getVar('PACKAGECONFIG'): 79 if 'ares' in d.getVar('PACKAGECONFIG'):
79 shutil.rmtree(d.getVar('S') + '/deps/cares', True) 80 shutil.rmtree(d.getVar('S') + '/deps/cares', True)
81 if 'gyp' in d.getVar('PACKAGECONFIG'):
82 shutil.rmtree(d.getVar('S') + '/tools/gyp', True)
80 if 'libuv' in d.getVar('PACKAGECONFIG'): 83 if 'libuv' in d.getVar('PACKAGECONFIG'):
81 shutil.rmtree(d.getVar('S') + '/deps/uv', True) 84 shutil.rmtree(d.getVar('S') + '/deps/uv', True)
82 if 'nghttp2' in d.getVar('PACKAGECONFIG'): 85 if 'nghttp2' in d.getVar('PACKAGECONFIG'):