summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2021-12-27 12:38:09 -0800
committerKhem Raj <raj.khem@gmail.com>2021-12-27 14:18:49 -0800
commit0b75181350a02088da6f389807b5d8c6d2a195c2 (patch)
tree60b6f2da13b52ed37ea405305ac113e172e2c097
parent2b733d2a70305904d4b04addfd4cefc2d696b761 (diff)
downloadmeta-openembedded-0b75181350a02088da6f389807b5d8c6d2a195c2.tar.gz
strongswan: add tpm PACKAGECONFIG
migrate meta-tpm strongswan tweaks to meta-networking Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
index 124b5a7999..2b63d95665 100644
--- a/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
+++ b/meta-networking/recipes-support/strongswan/strongswan_5.9.4.bb
@@ -6,6 +6,7 @@ SECTION = "net"
6LICENSE = "GPLv2" 6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8DEPENDS = "gmp openssl flex-native flex bison-native" 8DEPENDS = "gmp openssl flex-native flex bison-native"
9DEPENDS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', ' tpm2-tss', '', d)}"
9 10
10SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \ 11SRC_URI = "http://download.strongswan.org/strongswan-${PV}.tar.bz2 \
11 file://fix-funtion-parameter.patch \ 12 file://fix-funtion-parameter.patch \
@@ -25,6 +26,7 @@ EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-syst
25 26
26PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl curve25519\ 27PACKAGECONFIG ?= "curl gmp openssl sqlite3 swanctl curve25519\
27 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-charon', 'charon', d)} \ 28 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd-charon', 'charon', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'tpm2', 'tpm2', '', d)} \
28" 30"
29PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni" 31PACKAGECONFIG[aesni] = "--enable-aesni,--disable-aesni,,${PN}-plugin-aesni"
30PACKAGECONFIG[bfd] = "--enable-bfd-backtraces,--disable-bfd-backtraces,binutils" 32PACKAGECONFIG[bfd] = "--enable-bfd-backtraces,--disable-bfd-backtraces,binutils"
@@ -46,6 +48,9 @@ PACKAGECONFIG[curve25519] = "--enable-curve25519,--disable-curve25519,, ${PN}-pl
46# requires swanctl 48# requires swanctl
47PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd," 49PACKAGECONFIG[systemd-charon] = "--enable-systemd,--disable-systemd,systemd,"
48 50
51# tpm needs meta-tpm layer
52PACKAGECONFIG[tpm2] = "--enable-tpm,--disable-tpm,,${PN}-plugin-tpm"
53
49inherit autotools systemd pkgconfig 54inherit autotools systemd pkgconfig
50 55
51RRECOMMENDS:${PN} = "kernel-module-ah4 \ 56RRECOMMENDS:${PN} = "kernel-module-ah4 \