diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-06-05 20:31:51 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-06-08 13:58:03 -0700 |
commit | 083ad98b0517c3ef0b5bf017fda2c5c302653e63 (patch) | |
tree | 0a90a562b33c5037b68e5689d46b4de3c01588c7 | |
parent | 25cda4f46bd178421dfe8088ff5f6815de3bda31 (diff) | |
download | meta-openembedded-083ad98b0517c3ef0b5bf017fda2c5c302653e63.tar.gz |
python3-jsonpatch: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python-jsonpatch.inc | 12 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb | 13 |
2 files changed, 11 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch.inc b/meta-python/recipes-devtools/python/python-jsonpatch.inc deleted file mode 100644 index e23f96b61..000000000 --- a/meta-python/recipes-devtools/python/python-jsonpatch.inc +++ /dev/null | |||
@@ -1,12 +0,0 @@ | |||
1 | SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x" | ||
2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-patch" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3" | ||
5 | |||
6 | inherit pypi | ||
7 | |||
8 | SRC_URI[md5sum] = "fcc546892414bef2f7f89f0e2a618a9e" | ||
9 | SRC_URI[sha256sum] = "ddc0f7628b8bfdd62e3cbfbc24ca6671b0b6265b50d186c2cf3659dc0f78fd6a" | ||
10 | |||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-stringold" | ||
12 | |||
diff --git a/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb b/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb index 73efceeed..8ec21ff11 100644 --- a/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb +++ b/meta-python/recipes-devtools/python/python3-jsonpatch_1.25.bb | |||
@@ -1,2 +1,11 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x" |
2 | require python-jsonpatch.inc | 2 | HOMEPAGE = "https://github.com/stefankoegl/python-json-patch" |
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3" | ||
5 | |||
6 | inherit pypi setuptools3 | ||
7 | |||
8 | SRC_URI[md5sum] = "fcc546892414bef2f7f89f0e2a618a9e" | ||
9 | SRC_URI[sha256sum] = "ddc0f7628b8bfdd62e3cbfbc24ca6671b0b6265b50d186c2cf3659dc0f78fd6a" | ||
10 | |||
11 | RDEPENDS_${PN} += "${PYTHON_PN}-json ${PYTHON_PN}-jsonpointer ${PYTHON_PN}-netclient ${PYTHON_PN}-stringold" | ||