diff options
author | William A. Kennington III via Openembedded-devel <openembedded-devel@lists.openembedded.org> | 2019-03-26 19:30:00 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-03-28 09:48:30 -0700 |
commit | 07ee1b38f6e92f66de71286f43939f68ae79ecec (patch) | |
tree | 673426fa12f18b7ce84dc1924b88de5cab88f9b3 | |
parent | 478c35bc015c4bff9a805a6cafbf2f2cf38284f8 (diff) | |
download | meta-openembedded-07ee1b38f6e92f66de71286f43939f68ae79ecec.tar.gz |
function2: Add package
function2 is an improved, drop in replacement for std::function.
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/function2/function2_4.0.0.bb | 21 |
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/function2/function2_4.0.0.bb b/meta-oe/recipes-support/function2/function2_4.0.0.bb new file mode 100644 index 000000000..556a25aa1 --- /dev/null +++ b/meta-oe/recipes-support/function2/function2_4.0.0.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "Improved drop-in replacement for std::function" | ||
2 | DESCRIPTION = "Provides improved implementations of std::function." | ||
3 | HOMEPAGE = "https://naios.github.io/function2" | ||
4 | LICENSE = "BSL-1.0" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" | ||
6 | SRCREV = "d2acdb6c3c7612a6133cd03464ef941161258f4e" | ||
7 | PV .= "+git${SRCPV}" | ||
8 | |||
9 | SRC_URI += "gitsm://github.com/Naios/function2" | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | inherit cmake | ||
14 | inherit ptest | ||
15 | |||
16 | # Installs some data to incorrect top-level /usr directory | ||
17 | do_install_append() { | ||
18 | mkdir -p ${D}/${datadir}/function2 | ||
19 | mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/ | ||
20 | mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/ | ||
21 | } | ||