diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-08-27 12:12:03 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-31 10:18:33 +0200 |
commit | 059b3b24747e96c2220e13f3078b3fd93e96e468 (patch) | |
tree | a84160d6dbd1e8f883ce9b0d51a705fb3bbbf333 | |
parent | 3f37748ee8d9c166e7252da9319f30bbba3baafe (diff) | |
download | meta-openembedded-059b3b24747e96c2220e13f3078b3fd93e96e468.tar.gz |
glade: Fix format string warnings with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch | 62 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/glade/glade3_3.8.5.bb | 10 |
2 files changed, 67 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch b/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch new file mode 100644 index 000000000..03cb762ce --- /dev/null +++ b/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From fcf29abe59607b5791f9de18ddb86b9ae3c9b7cc Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 26 Aug 2017 23:50:05 -0700 | ||
4 | Subject: [PATCH] Add G_GNUC_PRINTF on functions with format strings | ||
5 | |||
6 | This allows compilation with clang without errors, even when | ||
7 | -Wformat-nonliteral is active (as long as there are no real cases of | ||
8 | non literal formatting). | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | gladeui/glade-command.c | 4 ++-- | ||
13 | gladeui/glade-utils.c | 4 ++-- | ||
14 | 2 files changed, 4 insertions(+), 4 deletions(-) | ||
15 | |||
16 | diff --git a/gladeui/glade-command.c b/gladeui/glade-command.c | ||
17 | index 9819766..4ac40ee 100644 | ||
18 | --- a/gladeui/glade-command.c | ||
19 | +++ b/gladeui/glade-command.c | ||
20 | @@ -266,7 +266,7 @@ glade_command_collapse (GladeCommand *command, | ||
21 | * | ||
22 | * Marks the begining of a group. | ||
23 | */ | ||
24 | -void | ||
25 | +G_GNUC_PRINTF(1, 2) void | ||
26 | glade_command_push_group (const gchar *fmt, ...) | ||
27 | { | ||
28 | va_list args; | ||
29 | @@ -655,7 +655,7 @@ glade_command_set_properties_list (GladeProject *project, GList *props) | ||
30 | |||
31 | multiple = g_list_length (me->sdata) > 1; | ||
32 | if (multiple) | ||
33 | - glade_command_push_group (cmd->description); | ||
34 | + glade_command_push_group ("%s", cmd->description); | ||
35 | |||
36 | |||
37 | glade_command_check_group (GLADE_COMMAND (me)); | ||
38 | diff --git a/gladeui/glade-utils.c b/gladeui/glade-utils.c | ||
39 | index ae52501..c51ae59 100644 | ||
40 | --- a/gladeui/glade-utils.c | ||
41 | +++ b/gladeui/glade-utils.c | ||
42 | @@ -197,7 +197,7 @@ glade_utils_get_pspec_from_funcname (const gchar *funcname) | ||
43 | * selected "OK", True if the @type was GLADE_UI_YES_OR_NO and | ||
44 | * the user selected "YES"; False otherwise. | ||
45 | */ | ||
46 | -gint | ||
47 | +G_GNUC_PRINTF(4, 5) gint | ||
48 | glade_util_ui_message (GtkWidget *parent, | ||
49 | GladeUIMessageType type, | ||
50 | GtkWidget *widget, | ||
51 | @@ -320,7 +320,7 @@ remove_message_timeout (FlashInfo * fi) | ||
52 | * | ||
53 | * Flash a temporary message on the statusbar. | ||
54 | */ | ||
55 | -void | ||
56 | +G_GNUC_PRINTF(3, 4) void | ||
57 | glade_util_flash_message (GtkWidget *statusbar, guint context_id, gchar *format, ...) | ||
58 | { | ||
59 | va_list args; | ||
60 | -- | ||
61 | 2.14.1 | ||
62 | |||
diff --git a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb index fd655366f..c4f600095 100644 --- a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb +++ b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb | |||
@@ -8,11 +8,11 @@ DEPENDS = "gtk+ gnome-doc-utils gnome-common libxml2 intltool-native" | |||
8 | 8 | ||
9 | inherit autotools pkgconfig pythonnative gtk-icon-cache | 9 | inherit autotools pkgconfig pythonnative gtk-icon-cache |
10 | 10 | ||
11 | SRC_URI = " \ | 11 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-${PV}.tar.xz \ |
12 | http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-${PV}.tar.xz \ | 12 | file://0001-gnome-doc-utils.make-sysrooted-pkg-config.patch \ |
13 | file://0001-gnome-doc-utils.make-sysrooted-pkg-config.patch \ | 13 | file://0002-fix-gcc-6-build.patch \ |
14 | file://0002-fix-gcc-6-build.patch \ | 14 | file://0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch \ |
15 | " | 15 | " |
16 | SRC_URI[md5sum] = "4e4b4f5ee34a03e017e4cef97d796c1f" | 16 | SRC_URI[md5sum] = "4e4b4f5ee34a03e017e4cef97d796c1f" |
17 | SRC_URI[sha256sum] = "58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735" | 17 | SRC_URI[sha256sum] = "58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735" |
18 | 18 | ||