summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-01-30 12:14:10 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-02-01 13:48:27 +0000
commit99aa19ff53922b61dee0c8b63ee7f664f90e9a91 (patch)
tree551690686c0f9bd61fd3185d8d4cf101482d1a0d
parent6f536298c1afcaaff2771c7d0f242259d6b9fc1f (diff)
downloadmeta-openembedded-99aa19ff53922b61dee0c8b63ee7f664f90e9a91.tar.gz
recipes: use oe.utils.conditional instead of deprecated base_conditional
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-initramfs/recipes-devtools/klibc/klibc-utils.inc2
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.7.0.bb2
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb2
-rw-r--r--meta-oe/recipes-devtools/php/php.inc2
-rw-r--r--meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb4
-rw-r--r--meta-oe/recipes-kernel/linux/linux.inc2
-rw-r--r--meta-oe/recipes-support/mongodb/mongodb_git.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.3.bb4
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc4
-rw-r--r--meta-webserver/recipes-httpd/nginx/nginx.inc2
10 files changed, 13 insertions, 13 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc
index 9014f5267..7df33d64e 100644
--- a/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc
+++ b/meta-initramfs/recipes-devtools/klibc/klibc-utils.inc
@@ -48,7 +48,7 @@ do_install() {
48 ln -s gzip ${D}${base_bindir}/zcat 48 ln -s gzip ${D}${base_bindir}/zcat
49} 49}
50 50
51EXTRA_KLIBC_DEPS = "${@base_conditional('KLIBC_UTILS_VARIANT', 'shared', '${THIS_LIBKLIBC}', '', d)}" 51EXTRA_KLIBC_DEPS = "${@oe.utils.conditional('KLIBC_UTILS_VARIANT', 'shared', '${THIS_LIBKLIBC}', '', d)}"
52 52
53PACKAGES_DYNAMIC += "^${KLIBC_UTILS_PKGNAME}-.*" 53PACKAGES_DYNAMIC += "^${KLIBC_UTILS_PKGNAME}-.*"
54 54
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
index f33c1384b..686998e5e 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.7.0.bb
@@ -119,7 +119,7 @@ EXTRA_OECONF += "--enable-fhs \
119 --disable-rpath-install \ 119 --disable-rpath-install \
120 --with-shared-modules=${SAMBA4_MODULES} \ 120 --with-shared-modules=${SAMBA4_MODULES} \
121 --bundled-libraries=${SAMBA4_LIBS} \ 121 --bundled-libraries=${SAMBA4_LIBS} \
122 ${@base_conditional('TARGET_ARCH', 'x86_64', '', '--disable-glusterfs', d)} \ 122 ${@oe.utils.conditional('TARGET_ARCH', 'x86_64', '', '--disable-glusterfs', d)} \
123 --with-cluster-support \ 123 --with-cluster-support \
124 --with-profiling-data \ 124 --with-profiling-data \
125 --with-libiconv=${STAGING_DIR_HOST}${prefix} \ 125 --with-libiconv=${STAGING_DIR_HOST}${prefix} \
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index 3c0587469..29cd6b3bf 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -60,7 +60,7 @@ EXTRA_OECONF = "--enable-shared \
60 --with-defaults \ 60 --with-defaults \
61 --with-install-prefix=${D} \ 61 --with-install-prefix=${D} \
62 --with-persistent-directory=${localstatedir}/lib/net-snmp \ 62 --with-persistent-directory=${localstatedir}/lib/net-snmp \
63 ${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)} \ 63 ${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)} \
64" 64"
65 65
66# net-snmp needs to have mib-modules=smux enabled to enable quagga to support snmp 66# net-snmp needs to have mib-modules=smux enabled to enable quagga to support snmp
diff --git a/meta-oe/recipes-devtools/php/php.inc b/meta-oe/recipes-devtools/php/php.inc
index e466cdaf6..8394c4f64 100644
--- a/meta-oe/recipes-devtools/php/php.inc
+++ b/meta-oe/recipes-devtools/php/php.inc
@@ -60,7 +60,7 @@ EXTRA_OECONF = "--enable-mbstring \
60 --with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \ 60 --with-mcrypt=${STAGING_DIR_TARGET}${exec_prefix} \
61 --with-bz2=${STAGING_DIR_TARGET}${exec_prefix} \ 61 --with-bz2=${STAGING_DIR_TARGET}${exec_prefix} \
62 --with-config-file-path=${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION} \ 62 --with-config-file-path=${sysconfdir}/php/apache2-php${PHP_MAJOR_VERSION} \
63 ${@base_conditional('SITEINFO_ENDIANNESS', 'le', 'ac_cv_c_bigendian_php=no', 'ac_cv_c_bigendian_php=yes', d)} \ 63 ${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'ac_cv_c_bigendian_php=no', 'ac_cv_c_bigendian_php=yes', d)} \
64 ${@bb.utils.contains('PACKAGECONFIG', 'pam', '', 'ac_cv_lib_pam_pam_start=no', d)} \ 64 ${@bb.utils.contains('PACKAGECONFIG', 'pam', '', 'ac_cv_lib_pam_pam_start=no', d)} \
65 ${COMMON_EXTRA_OECONF} \ 65 ${COMMON_EXTRA_OECONF} \
66" 66"
diff --git a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
index cbf04734e..0f798d233 100644
--- a/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
+++ b/meta-oe/recipes-extended/konkretcmpi/konkretcmpi_0.9.2.bb
@@ -20,8 +20,8 @@ S = "${WORKDIR}/git"
20inherit cmake 20inherit cmake
21 21
22EXTRA_OECMAKE = "-DWITH_PYTHON=ON \ 22EXTRA_OECMAKE = "-DWITH_PYTHON=ON \
23 ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ 23 ${@oe.utils.conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
24 ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \ 24 ${@oe.utils.conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
25 " 25 "
26 26
27LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 27LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
diff --git a/meta-oe/recipes-kernel/linux/linux.inc b/meta-oe/recipes-kernel/linux/linux.inc
index e20012771..9f14370cd 100644
--- a/meta-oe/recipes-kernel/linux/linux.inc
+++ b/meta-oe/recipes-kernel/linux/linux.inc
@@ -16,7 +16,7 @@ CMDLINE_DEBUG ?= "loglevel=3"
16 16
17# Kernel bootlogo is distro-specific (default is OE logo). 17# Kernel bootlogo is distro-specific (default is OE logo).
18# Logo resolution (qvga, vga, ...) is machine-specific. 18# Logo resolution (qvga, vga, ...) is machine-specific.
19LOGO_SIZE ?= '${@base_conditional("MACHINE_GUI_CLASS", "bigscreen", "vga", "qvga", d)}' 19LOGO_SIZE ?= '${@oe.utils.conditional("MACHINE_GUI_CLASS", "bigscreen", "vga", "qvga", d)}'
20# To use this, add file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 or similar 20# To use this, add file://${LOGO_SIZE}/logo_linux_clut224.ppm.bz2 or similar
21# to your kernel recipe, and then structure your logos for each resolution 21# to your kernel recipe, and then structure your logos for each resolution
22# accordingly. 22# accordingly.
diff --git a/meta-oe/recipes-support/mongodb/mongodb_git.bb b/meta-oe/recipes-support/mongodb/mongodb_git.bb
index 0ff7d0b59..8acbf071b 100644
--- a/meta-oe/recipes-support/mongodb/mongodb_git.bb
+++ b/meta-oe/recipes-support/mongodb/mongodb_git.bb
@@ -58,7 +58,7 @@ EXTRA_OESCONS = "--prefix=${D}${prefix} \
58 --use-system-zlib \ 58 --use-system-zlib \
59 --js-engine=none \ 59 --js-engine=none \
60 --nostrip \ 60 --nostrip \
61 --endian=${@base_conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ 61 --endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
62 ${PACKAGECONFIG_CONFARGS} \ 62 ${PACKAGECONFIG_CONFARGS} \
63 mongod mongos" 63 mongod mongos"
64 64
diff --git a/meta-oe/recipes-support/opencv/opencv_3.3.bb b/meta-oe/recipes-support/opencv/opencv_3.3.bb
index 3663d30e9..ca62de7c8 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.3.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.3.bb
@@ -82,8 +82,8 @@ EXTRA_OECMAKE = "-DOPENCV_EXTRA_MODULES_PATH=${WORKDIR}/contrib/modules \
82 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \ 82 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
83 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \ 83 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.1", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1", "", d)} \
84 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \ 84 ${@bb.utils.contains("TARGET_CC_ARCH", "-msse4.2", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1 -DENABLE_SSE41=1 -DENABLE_SSE42=1", "", d)} \
85 ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \ 85 ${@oe.utils.conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
86 ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \ 86 ${@oe.utils.conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
87" 87"
88EXTRA_OECMAKE_append_x86 = " -DX86=ON" 88EXTRA_OECMAKE_append_x86 = " -DX86=ON"
89 89
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index f1bf9b06f..771cdb196 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -41,7 +41,7 @@ EXTRA_OECONF = " \
41" 41"
42 42
43CONFIG_TLS = "--enable-thread-tls" 43CONFIG_TLS = "--enable-thread-tls"
44CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}" 44CONFIG_TLS_arm = "${@oe.utils.conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
45 45
46PACKAGECONFIG ??= " \ 46PACKAGECONFIG ??= " \
47 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} \ 47 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6 systemd', d)} \
@@ -101,7 +101,7 @@ CONFFILES_${PN} = "${sysconfdir}/${BPN}.conf ${sysconfdir}/scl.conf"
101 101
102# syslog initscript is handled explicitly because order of 102# syslog initscript is handled explicitly because order of
103# update-rc.d and update-alternatives is important 103# update-rc.d and update-alternatives is important
104RDEPENDS_${PN} += " ${@base_conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "update-rc.d", d)}" 104RDEPENDS_${PN} += " ${@oe.utils.conditional("ONLINE_PACKAGE_MANAGEMENT", "none", "", "update-rc.d", d)}"
105 105
106RCONFLICTS_${PN} = "busybox-syslog sysklogd rsyslog" 106RCONFLICTS_${PN} = "busybox-syslog sysklogd rsyslog"
107 107
diff --git a/meta-webserver/recipes-httpd/nginx/nginx.inc b/meta-webserver/recipes-httpd/nginx/nginx.inc
index 51523b606..e6ae52a09 100644
--- a/meta-webserver/recipes-httpd/nginx/nginx.inc
+++ b/meta-webserver/recipes-httpd/nginx/nginx.inc
@@ -51,7 +51,7 @@ do_configure () {
51 51
52 ./configure \ 52 ./configure \
53 --crossbuild=Linux:${TUNE_ARCH} \ 53 --crossbuild=Linux:${TUNE_ARCH} \
54 --with-endian=${@base_conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ 54 --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \
55 --with-int=4 \ 55 --with-int=4 \
56 --with-long=${PTRSIZE} \ 56 --with-long=${PTRSIZE} \
57 --with-long-long=8 \ 57 --with-long-long=8 \