summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-26 11:58:12 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:40 +0200
commit523fa42dd4904068dd8d9edced02155bd48d3278 (patch)
treea330cfbdf16ac6c264ea2670ab8d72d86d978f3a
parentc155bd03fd4d4fd7f73202ef70833e17d3adf43b (diff)
downloadmeta-openembedded-523fa42dd4904068dd8d9edced02155bd48d3278.tar.gz
usermode: Link with libm for powl() API
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch26
-rw-r--r--meta-gnome/recipes-support/usermode/usermode_1.111.bb6
2 files changed, 29 insertions, 3 deletions
diff --git a/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch b/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch
new file mode 100644
index 000000000..76640b0a1
--- /dev/null
+++ b/meta-gnome/recipes-support/usermode/usermode/0001-Makefile.am-Link-with-libm-for-powl-API.patch
@@ -0,0 +1,26 @@
1From fda0ff49968aebc7b27f9711cf6eb7f6c560adc1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Jul 2017 18:28:15 -0700
4Subject: [PATCH] Makefile.am: Link with libm for powl() API
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 Makefile.am | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/Makefile.am b/Makefile.am
12index 4219f28..2a5ceac 100644
13--- a/Makefile.am
14+++ b/Makefile.am
15@@ -69,7 +69,7 @@ dist_pkgdata_DATA = usermode.ui
16 userhelper_SOURCES = userhelper.c userhelper.h shvar.c shvar.h
17 userhelper_CPPFLAGS = $(AM_CPPFLAGS) -DSYSCONFDIR='"$(sysconfdir)"'
18 userhelper_LDADD = liblib.a $(LIBUSER_LIBS) $(GLIB_LIBS) $(PAM_LIBS) \
19- $(SELINUX_LIBS) $(EFENCE_LIBS)
20+ $(SELINUX_LIBS) $(EFENCE_LIBS) -lm
21
22 userinfo_SOURCES = userinfo.c
23 userinfo_CPPFLAGS = $(AM_CPPFLAGS) $(PIXMAPDIR_CPPFLAGS) $(SBINDIR_CPPFLAGS) \
24--
252.13.3
26
diff --git a/meta-gnome/recipes-support/usermode/usermode_1.111.bb b/meta-gnome/recipes-support/usermode/usermode_1.111.bb
index 06e400e52..c2d73289e 100644
--- a/meta-gnome/recipes-support/usermode/usermode_1.111.bb
+++ b/meta-gnome/recipes-support/usermode/usermode_1.111.bb
@@ -15,12 +15,12 @@ DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '',
15 15
16SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \ 16SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \
17 file://0001-formatting-issues.patch \ 17 file://0001-formatting-issues.patch \
18" 18 file://0001-fix-compile-failure-against-musl-C-library.patch \
19 file://0001-Makefile.am-Link-with-libm-for-powl-API.patch \
20 "
19SRC_URI[md5sum] = "28ba510fbd8da9f4e86e57d6c31cff29" 21SRC_URI[md5sum] = "28ba510fbd8da9f4e86e57d6c31cff29"
20SRC_URI[sha256sum] = "3dd0b9639b5bd396b7ea5fada6aaa694dbfdaa3ad06eb95a6eabcdfd02f875c6" 22SRC_URI[sha256sum] = "3dd0b9639b5bd396b7ea5fada6aaa694dbfdaa3ad06eb95a6eabcdfd02f875c6"
21 23
22SRC_URI_append_libc-musl = " file://0001-fix-compile-failure-against-musl-C-library.patch"
23
24LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 24LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
25 25
26inherit autotools gettext pkgconfig 26inherit autotools gettext pkgconfig