summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 15:50:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:33:24 +0100
commit37a841321dca1314c9844d8d4665b5ff1e28a40f (patch)
treefa18605b97edc9ae7517f0e06489e88e661f5b1e
parent20a624928c030fa13d8b7d45b4f4d7e1ac624f60 (diff)
downloadmeta-openembedded-37a841321dca1314c9844d8d4665b5ff1e28a40f.tar.gz
recipes: add x11 to required DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc.inc4
-rw-r--r--meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb4
-rw-r--r--meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb4
-rw-r--r--meta-oe/recipes-extended/dlm/dlm_4.0.2.bb2
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot.inc4
-rw-r--r--meta-oe/recipes-extended/sip/sip_4.16.4.bb4
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb4
-rw-r--r--meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb4
-rw-r--r--meta-oe/recipes-graphics/lxdm/lxdm_git.bb4
-rw-r--r--meta-oe/recipes-graphics/mesa/mesa-glut_8.0.1.bb4
-rw-r--r--meta-oe/recipes-graphics/numlockx/numlockx_1.2.bb4
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb4
-rw-r--r--meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-adobe-100dpi_1.0.3.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-adobe-utopia-100dpi_1.0.4.bb5
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-bh-100dpi_1.0.3.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-bh-lucidatypewriter-100dpi_1.0.3.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-bitstream-100dpi_1.0.3.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-cursor-misc_1.0.3.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/font-misc-misc_1.1.2.bb4
-rw-r--r--meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb4
-rw-r--r--meta-oe/recipes-multimedia/xpext/xpext_1.0-5.bb4
-rw-r--r--meta-oe/recipes-multimedia/xsp/xsp_1.0.0-8.bb4
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.7.bb4
-rw-r--r--meta-oe/recipes-support/synergy/synergy_1.3.8.bb6
-rw-r--r--meta-oe/recipes-support/utouch/utouch-mtview_git.bb4
26 files changed, 86 insertions, 19 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
index 1b6f02a6e..0362f3919 100644
--- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc
@@ -15,7 +15,9 @@ DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \
15 15
16SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" 16SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz"
17 17
18inherit autotools gettext pkgconfig 18inherit autotools gettext pkgconfig distro_features_check
19# depends on libxinerama libxpm xcb-util-keysyms
20REQUIRED_DISTRO_FEATURES = "x11"
19 21
20ARM_INSTRUCTION_SET = "arm" 22ARM_INSTRUCTION_SET = "arm"
21 23
diff --git a/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb b/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb
index 140456e17..989f2cf51 100644
--- a/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb
+++ b/meta-oe/recipes-devtools/python/python-pyqt_4.11.3.bb
@@ -22,7 +22,9 @@ S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
22 22
23PARALLEL_MAKE = "" 23PARALLEL_MAKE = ""
24 24
25inherit qmake2 pythonnative python-dir 25inherit qmake2 pythonnative python-dir distro_features_check
26# depends on qt4-x11-free
27REQUIRED_DISTRO_FEATURES = "x11"
26 28
27DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager" 29DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
28 30
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
index 1177d0368..14c6ce54c 100644
--- a/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.0.bb
@@ -35,7 +35,9 @@ S = "${WORKDIR}/${BPN}${PV}/unix"
35VER = "${@os.path.splitext(d.getVar('PV', True))[0]}" 35VER = "${@os.path.splitext(d.getVar('PV', True))[0]}"
36 36
37LDFLAGS += "-Wl,-rpath,${libdir}/tcltk/${PV}/lib" 37LDFLAGS += "-Wl,-rpath,${libdir}/tcltk/${PV}/lib"
38inherit autotools 38inherit autotools distro_features_check
39# depends on virtual/libx11
40REQUIRED_DISTRO_FEATURES = "x11"
39 41
40EXTRA_OECONF = "\ 42EXTRA_OECONF = "\
41 --enable-threads \ 43 --enable-threads \
diff --git a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
index 0de707eba..560630c74 100644
--- a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
+++ b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://README.license;md5=8f0bbcdd678df1bce9863492b6c8832d"
15 15
16DEPENDS = "corosync systemd" 16DEPENDS = "corosync systemd"
17 17
18inherit pkgconfig systemd 18inherit pkgconfig systemd distro_features_check
19 19
20SYSTEMD_SERVICE_${PN} = "dlm.service" 20SYSTEMD_SERVICE_${PN} = "dlm.service"
21SYSTEMD_AUTO_ENABLE = "enable" 21SYSTEMD_AUTO_ENABLE = "enable"
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot.inc b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
index 6c27e6d8a..69bc74b04 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot.inc
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
@@ -6,7 +6,9 @@ LICENSE = "gnuplot"
6LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f" 6LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
7DEPENDS = "virtual/libx11 gd readline" 7DEPENDS = "virtual/libx11 gd readline"
8 8
9inherit autotools 9inherit autotools distro_features_check
10# depends on virtual/libx11
11REQUIRED_DISTRO_FEATURES = "x11"
10 12
11acpaths = "" 13acpaths = ""
12 14
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
index 2a2674f91..607ace69f 100644
--- a/meta-oe/recipes-extended/sip/sip_4.16.4.bb
+++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
@@ -14,7 +14,9 @@ SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f219
14 14
15BBCLASSEXTEND = "native" 15BBCLASSEXTEND = "native"
16 16
17inherit qmake2 python-dir pythonnative 17inherit qmake2 python-dir pythonnative distro_features_check
18# depends on qt4-x11-free
19REQUIRED_DISTRO_FEATURES = "x11"
18 20
19EXTRA_QMAKEVARS_POST += "CONFIG=console" 21EXTRA_QMAKEVARS_POST += "CONFIG=console"
20 22
diff --git a/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
index 90a0290e0..1d670a7d7 100644
--- a/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
+++ b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
@@ -13,7 +13,9 @@ SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
13SRC_URI[md5sum] = "a5629b56b93134377718009df1435f3c" 13SRC_URI[md5sum] = "a5629b56b93134377718009df1435f3c"
14SRC_URI[sha256sum] = "821328b5054f7890a0d0cd2f52825270705df3641dbd476d58d17e56ed957b59" 14SRC_URI[sha256sum] = "821328b5054f7890a0d0cd2f52825270705df3641dbd476d58d17e56ed957b59"
15 15
16inherit autotools-brokensep 16inherit autotools-brokensep distro_features_check
17# depends on virtual/libx11
18REQUIRED_DISTRO_FEATURES = "x11"
17 19
18# Fix GNU_HASH problem 20# Fix GNU_HASH problem
19TARGET_CC_ARCH += "${LDFLAGS}" 21TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
index 51f57b934..d0f449438 100644
--- a/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
+++ b/meta-oe/recipes-graphics/glcompbench/glcompbench_2012.08.bb
@@ -11,4 +11,6 @@ SRC_URI = "https://launchpad.net/glcompbench/trunk/${PV}/+download/${BPN}-${PV}.
11SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827" 11SRC_URI[md5sum] = "c939d9156fe940960098f38707fea827"
12SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee" 12SRC_URI[sha256sum] = "b04b738cec06c6786ceafa86e4735fd8b971c078265754854ef356b0379542ee"
13 13
14inherit pkgconfig waf 14inherit pkgconfig waf distro_features_check
15# depends on virtual/libx11
16REQUIRED_DISTRO_FEATURES = "x11"
diff --git a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
index a3dcc1bd2..a05e533bd 100644
--- a/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
+++ b/meta-oe/recipes-graphics/lxdm/lxdm_git.bb
@@ -20,7 +20,9 @@ DEPENDS += "${@base_contains("DISTRO_FEATURES", "systemd", "", "consolekit", d)}
20# combine oe-core way with angstrom DISTRO_TYPE 20# combine oe-core way with angstrom DISTRO_TYPE
21DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}" 21DISTRO_TYPE ?= "${@base_contains("IMAGE_FEATURES", "debug-tweaks", "debug", "",d)}"
22 22
23inherit autotools pkgconfig gettext systemd 23inherit autotools pkgconfig gettext systemd distro_features_check
24# depends on virtual/libx11
25REQUIRED_DISTRO_FEATURES = "x11"
24 26
25S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
26 28
diff --git a/meta-oe/recipes-graphics/mesa/mesa-glut_8.0.1.bb b/meta-oe/recipes-graphics/mesa/mesa-glut_8.0.1.bb
index f23621d9c..404ee5331 100644
--- a/meta-oe/recipes-graphics/mesa/mesa-glut_8.0.1.bb
+++ b/meta-oe/recipes-graphics/mesa/mesa-glut_8.0.1.bb
@@ -9,6 +9,8 @@ PV = "8.0.0+git${SRCPV}"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12inherit autotools-brokensep pkgconfig 12inherit autotools-brokensep pkgconfig distro_features_check
13# depends on virtual/libx11
14REQUIRED_DISTRO_FEATURES = "x11"
13 15
14DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu" 16DEPENDS = "virtual/libx11 libxmu libxi virtual/libgl libglu"
diff --git a/meta-oe/recipes-graphics/numlockx/numlockx_1.2.bb b/meta-oe/recipes-graphics/numlockx/numlockx_1.2.bb
index 47ec50447..08d7f5b52 100644
--- a/meta-oe/recipes-graphics/numlockx/numlockx_1.2.bb
+++ b/meta-oe/recipes-graphics/numlockx/numlockx_1.2.bb
@@ -10,7 +10,9 @@ SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/numlockx/numlockx-${PV}.tar.g
10SRC_URI[md5sum] = "be9109370447eae23f6f3f8527bb1a67" 10SRC_URI[md5sum] = "be9109370447eae23f6f3f8527bb1a67"
11SRC_URI[sha256sum] = "e468eb9121c94c9089dc6a287eeb347e900ce04a14be37da29d7696cbce772e4" 11SRC_URI[sha256sum] = "e468eb9121c94c9089dc6a287eeb347e900ce04a14be37da29d7696cbce772e4"
12 12
13inherit autotools 13inherit autotools distro_features_check
14# depends on virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
14 16
15EXTRA_OECONF = "--x-includes=${STAGING_INCDIR} \ 17EXTRA_OECONF = "--x-includes=${STAGING_INCDIR} \
16 --x-libraries=${STAGING_LIBDIR}" 18 --x-libraries=${STAGING_LIBDIR}"
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
index 7c1d4a012..d9e58f1af 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -11,7 +11,9 @@ SRC_URI[sha256sum] = "6fa90016530b3aa6102e254079461977439398531fb23e7ec076ff2c14
11 11
12PR = "r2" 12PR = "r2"
13 13
14inherit autotools gettext update-alternatives pkgconfig 14inherit autotools gettext update-alternatives pkgconfig distro_features_check
15# depends on virtual/libx11
16REQUIRED_DISTRO_FEATURES = "x11"
15 17
16ALTERNATIVE_${PN}-core = "x-window-manager" 18ALTERNATIVE_${PN}-core = "x-window-manager"
17ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox" 19ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
diff --git a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
index e71846509..43e6fda6a 100644
--- a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
+++ b/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
@@ -7,6 +7,10 @@ DEPENDS = "virtual/libx11 libxtst"
7 7
8PR = "r1" 8PR = "r1"
9 9
10inherit distro_features_check
11# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
13
10SRC_URI = "http://semicomplete.googlecode.com/files/xdotool-${PV}.tar.gz" 14SRC_URI = "http://semicomplete.googlecode.com/files/xdotool-${PV}.tar.gz"
11SRC_URI[md5sum] = "1d5be641e512c343abfe5f78b39e6f19" 15SRC_URI[md5sum] = "1d5be641e512c343abfe5f78b39e6f19"
12SRC_URI[sha256sum] = "42d7271fbc796e53db71bb221f311b9ff3c51d90a71c9487a9bd3101ca39894f" 16SRC_URI[sha256sum] = "42d7271fbc796e53db71bb221f311b9ff3c51d90a71c9487a9bd3101ca39894f"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-adobe-100dpi_1.0.3.bb b/meta-oe/recipes-graphics/xorg-font/font-adobe-100dpi_1.0.3.bb
index 04d3efa15..85a44660e 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-adobe-100dpi_1.0.3.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-adobe-100dpi_1.0.3.bb
@@ -10,5 +10,9 @@ DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11RDEPENDS_${PN}_class-native = "font-util-native" 11RDEPENDS_${PN}_class-native = "font-util-native"
12 12
13inherit distro_features_check
14# depends on bdftopcf-native -> virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
13SRC_URI[md5sum] = "1347c3031b74c9e91dc4dfa53b12f143" 17SRC_URI[md5sum] = "1347c3031b74c9e91dc4dfa53b12f143"
14SRC_URI[sha256sum] = "b2c08433eab5cb202470aa9f779efefce8d9cab2534f34f3aa4a31d05671c054" 18SRC_URI[sha256sum] = "b2c08433eab5cb202470aa9f779efefce8d9cab2534f34f3aa4a31d05671c054"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-adobe-utopia-100dpi_1.0.4.bb b/meta-oe/recipes-graphics/xorg-font/font-adobe-utopia-100dpi_1.0.4.bb
index f3d2815f9..16e3d2cec 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-adobe-utopia-100dpi_1.0.4.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-adobe-utopia-100dpi_1.0.4.bb
@@ -10,6 +10,9 @@ DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11RDEPENDS_${PN}_class-native = "font-util-native" 11RDEPENDS_${PN}_class-native = "font-util-native"
12 12
13inherit distro_features_check
14# depends on bdftopcf-native -> virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
13SRC_URI[md5sum] = "66fb6de561648a6dce2755621d6aea17" 17SRC_URI[md5sum] = "66fb6de561648a6dce2755621d6aea17"
14SRC_URI[sha256sum] = "d16f5e3f227cc6dd07a160a71f443559682dbc35f1c056a5385085aaec4fada5" 18SRC_URI[sha256sum] = "d16f5e3f227cc6dd07a160a71f443559682dbc35f1c056a5385085aaec4fada5"
15
diff --git a/meta-oe/recipes-graphics/xorg-font/font-bh-100dpi_1.0.3.bb b/meta-oe/recipes-graphics/xorg-font/font-bh-100dpi_1.0.3.bb
index 3ee91cef4..08ed6b616 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-bh-100dpi_1.0.3.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-bh-100dpi_1.0.3.bb
@@ -10,5 +10,9 @@ DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11RDEPENDS_${PN}_class-native = "font-util-native" 11RDEPENDS_${PN}_class-native = "font-util-native"
12 12
13inherit distro_features_check
14# depends on bdftopcf-native -> virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
13SRC_URI[md5sum] = "9f11ade089d689b9d59e0f47d26f39cd" 17SRC_URI[md5sum] = "9f11ade089d689b9d59e0f47d26f39cd"
14SRC_URI[sha256sum] = "23c07162708e4b79eb33095c8bfa62c783717a9431254bbf44863734ea239481" 18SRC_URI[sha256sum] = "23c07162708e4b79eb33095c8bfa62c783717a9431254bbf44863734ea239481"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-bh-lucidatypewriter-100dpi_1.0.3.bb b/meta-oe/recipes-graphics/xorg-font/font-bh-lucidatypewriter-100dpi_1.0.3.bb
index c83137b18..5ded41aeb 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-bh-lucidatypewriter-100dpi_1.0.3.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-bh-lucidatypewriter-100dpi_1.0.3.bb
@@ -10,5 +10,9 @@ DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11RDEPENDS_${PN}_class-native = "font-util-native" 11RDEPENDS_${PN}_class-native = "font-util-native"
12 12
13inherit distro_features_check
14# depends on bdftopcf-native -> virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
13SRC_URI[md5sum] = "c8b73a53dcefe3e8d3907d3500e484a9" 17SRC_URI[md5sum] = "c8b73a53dcefe3e8d3907d3500e484a9"
14SRC_URI[sha256sum] = "62a83363c2536095fda49d260d21e0847675676e4e3415054064cbdffa641fbb" 18SRC_URI[sha256sum] = "62a83363c2536095fda49d260d21e0847675676e4e3415054064cbdffa641fbb"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-bitstream-100dpi_1.0.3.bb b/meta-oe/recipes-graphics/xorg-font/font-bitstream-100dpi_1.0.3.bb
index 9a83ac1e2..e8cfb615a 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-bitstream-100dpi_1.0.3.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-bitstream-100dpi_1.0.3.bb
@@ -10,5 +10,9 @@ DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11RDEPENDS_${PN}_class-native = "font-util-native" 11RDEPENDS_${PN}_class-native = "font-util-native"
12 12
13inherit distro_features_check
14# depends on bdftopcf-native -> virtual/libx11
15REQUIRED_DISTRO_FEATURES = "x11"
16
13SRC_URI[md5sum] = "6b223a54b15ecbd5a1bc52312ad790d8" 17SRC_URI[md5sum] = "6b223a54b15ecbd5a1bc52312ad790d8"
14SRC_URI[sha256sum] = "ebe0d7444e3d7c8da7642055ac2206f0190ee060700d99cd876f8fc9964cb6ce" 18SRC_URI[sha256sum] = "ebe0d7444e3d7c8da7642055ac2206f0190ee060700d99cd876f8fc9964cb6ce"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-cursor-misc_1.0.3.bb b/meta-oe/recipes-graphics/xorg-font/font-cursor-misc_1.0.3.bb
index 7db03eb96..d425ce515 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-cursor-misc_1.0.3.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-cursor-misc_1.0.3.bb
@@ -9,5 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=8b32ccac3ad25e75e68478deb7780265"
9DEPENDS = "util-macros-native font-util-native bdftopcf-native" 9DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11 11
12inherit distro_features_check
13# depends on bdftopcf-native -> virtual/libx11
14REQUIRED_DISTRO_FEATURES = "x11"
15
12SRC_URI[md5sum] = "3e0069d4f178a399cffe56daa95c2b63" 16SRC_URI[md5sum] = "3e0069d4f178a399cffe56daa95c2b63"
13SRC_URI[sha256sum] = "17363eb35eece2e08144da5f060c70103b59d0972b4f4d77fd84c9a7a2dba635" 17SRC_URI[sha256sum] = "17363eb35eece2e08144da5f060c70103b59d0972b4f4d77fd84c9a7a2dba635"
diff --git a/meta-oe/recipes-graphics/xorg-font/font-misc-misc_1.1.2.bb b/meta-oe/recipes-graphics/xorg-font/font-misc-misc_1.1.2.bb
index 685d647db..a7c284a2f 100644
--- a/meta-oe/recipes-graphics/xorg-font/font-misc-misc_1.1.2.bb
+++ b/meta-oe/recipes-graphics/xorg-font/font-misc-misc_1.1.2.bb
@@ -9,5 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=200c507f595ee97008c7c5c3e94ab9a8"
9DEPENDS = "util-macros-native font-util-native bdftopcf-native" 9DEPENDS = "util-macros-native font-util-native bdftopcf-native"
10RDEPENDS_${PN} = "encodings font-util" 10RDEPENDS_${PN} = "encodings font-util"
11 11
12inherit distro_features_check
13# depends on bdftopcf-native -> virtual/libx11
14REQUIRED_DISTRO_FEATURES = "x11"
15
12SRC_URI[md5sum] = "c88eb44b3b903d79fb44b860a213e623" 16SRC_URI[md5sum] = "c88eb44b3b903d79fb44b860a213e623"
13SRC_URI[sha256sum] = "b8e77940e4e1769dc47ef1805918d8c9be37c708735832a07204258bacc11794" 17SRC_URI[sha256sum] = "b8e77940e4e1769dc47ef1805918d8c9be37c708735832a07204258bacc11794"
diff --git a/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb b/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
index fd6c992dc..158416b08 100644
--- a/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
+++ b/meta-oe/recipes-graphics/xorg-font/xorg-fonts-100dpi.bb
@@ -1,7 +1,9 @@
1SUMMARY = "Xorg 100 DPI font set" 1SUMMARY = "Xorg 100 DPI font set"
2LICENSE = "Custom" 2LICENSE = "Custom"
3 3
4inherit packagegroup 4inherit packagegroup distro_features_check
5# rdepends on font recipes with this restriction
6REQUIRED_DISTRO_FEATURES = "x11"
5 7
6RDEPENDS_${PN} = "\ 8RDEPENDS_${PN} = "\
7 font-adobe-100dpi \ 9 font-adobe-100dpi \
diff --git a/meta-oe/recipes-multimedia/xpext/xpext_1.0-5.bb b/meta-oe/recipes-multimedia/xpext/xpext_1.0-5.bb
index 1ca8b1ff7..d65546d0b 100644
--- a/meta-oe/recipes-multimedia/xpext/xpext_1.0-5.bb
+++ b/meta-oe/recipes-multimedia/xpext/xpext_1.0-5.bb
@@ -9,7 +9,9 @@ SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/${BPN}/${BPN}_${
9 file://auxdir.patch;striplevel=0" 9 file://auxdir.patch;striplevel=0"
10S = "${WORKDIR}/xpext-1.0" 10S = "${WORKDIR}/xpext-1.0"
11 11
12inherit autotools pkgconfig 12inherit autotools pkgconfig distro_features_check
13# depends on virtual/libx11
14REQUIRED_DISTRO_FEATURES = "x11"
13 15
14SRC_URI[md5sum] = "1b0cb67b6f2bd7c4abef17648b062896" 16SRC_URI[md5sum] = "1b0cb67b6f2bd7c4abef17648b062896"
15SRC_URI[sha256sum] = "a3b06f5188fd9effd0799ae31352b3cd65cb913b964e2c1a923ffa9d3c08abbe" 17SRC_URI[sha256sum] = "a3b06f5188fd9effd0799ae31352b3cd65cb913b964e2c1a923ffa9d3c08abbe"
diff --git a/meta-oe/recipes-multimedia/xsp/xsp_1.0.0-8.bb b/meta-oe/recipes-multimedia/xsp/xsp_1.0.0-8.bb
index 968d342b1..c7a068df3 100644
--- a/meta-oe/recipes-multimedia/xsp/xsp_1.0.0-8.bb
+++ b/meta-oe/recipes-multimedia/xsp/xsp_1.0.0-8.bb
@@ -7,7 +7,9 @@ SRC_URI = "http://repository.maemo.org/pool/maemo/ossw/source/x/xsp/${BPN}_${PV}
7 file://xsp-fix-pc.patch" 7 file://xsp-fix-pc.patch"
8S = "${WORKDIR}/Xsp" 8S = "${WORKDIR}/Xsp"
9 9
10inherit autotools pkgconfig 10inherit autotools pkgconfig distro_features_check
11# depends on virtual/libx11
12REQUIRED_DISTRO_FEATURES = "x11"
11 13
12SRC_URI[md5sum] = "2a0d8d02228d4cbd28b6e07bb7c17cf5" 14SRC_URI[md5sum] = "2a0d8d02228d4cbd28b6e07bb7c17cf5"
13SRC_URI[sha256sum] = "8b722b952b64841d996c70c3278499886c81bb5012991beed5f66f4158418f59" 15SRC_URI[sha256sum] = "8b722b952b64841d996c70c3278499886c81bb5012991beed5f66f4158418f59"
diff --git a/meta-oe/recipes-support/links/links-x11_2.7.bb b/meta-oe/recipes-support/links/links-x11_2.7.bb
index 87666534e..2ae11ac97 100644
--- a/meta-oe/recipes-support/links/links-x11_2.7.bb
+++ b/meta-oe/recipes-support/links/links-x11_2.7.bb
@@ -3,6 +3,10 @@ require links.inc
3DEPENDS += "virtual/libx11" 3DEPENDS += "virtual/libx11"
4RCONFLICTS_${PN} = "links" 4RCONFLICTS_${PN} = "links"
5 5
6inherit distro_features_check
7# depends on virtual/libx11
8REQUIRED_DISTRO_FEATURES = "x11"
9
6SRC_URI += " file://links2.desktop \ 10SRC_URI += " file://links2.desktop \
7 http://www.xora.org.uk/oe/links2.png;name=icon" 11 http://www.xora.org.uk/oe/links2.png;name=icon"
8 12
diff --git a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
index 642845f96..45c0bc2f5 100644
--- a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
+++ b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9772a11e3569985855e2ce450e56f991"
4LICENSE = "GPL-2.0" 4LICENSE = "GPL-2.0"
5SECTION = "x11/utils" 5SECTION = "x11/utils"
6 6
7DEPENDS = "libx11 libxtst libxinerama" 7DEPENDS = "virtual/libx11 libxtst libxinerama"
8 8
9SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz" 9SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz"
10 10
@@ -13,7 +13,9 @@ SRC_URI[sha256sum] = "0afc83e4ed0b46ed497d4229b2b2854e8d3c581a112f4da05110943edb
13 13
14S = "${WORKDIR}/${PN}-${PV}-Source" 14S = "${WORKDIR}/${PN}-${PV}-Source"
15 15
16inherit cmake 16inherit cmake distro_features_check
17# depends on virtual/libx11
18REQUIRED_DISTRO_FEATURES = "x11"
17 19
18do_install() { 20do_install() {
19 install -d ${D}/usr/bin 21 install -d ${D}/usr/bin
diff --git a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
index bcf7e2384..8cb180dc8 100644
--- a/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
+++ b/meta-oe/recipes-support/utouch/utouch-mtview_git.bb
@@ -5,7 +5,9 @@ HOMEPAGE = "http://bitmath.org/code/mtview/"
5LICENSE = "GPLv3" 5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4c61b8950dc1aab4d2aa7c2ae6b1cfb3" 6LIC_FILES_CHKSUM = "file://COPYING;md5=4c61b8950dc1aab4d2aa7c2ae6b1cfb3"
7 7
8inherit autotools pkgconfig 8inherit autotools pkgconfig distro_features_check
9# depends on virtual/libx11
10REQUIRED_DISTRO_FEATURES = "x11"
9 11
10SRC_URI = "git://bitmath.org/git/mtview.git;protocol=http" 12SRC_URI = "git://bitmath.org/git/mtview.git;protocol=http"
11SRCREV = "ad437c38dc111cf3990a03abf14efe1b5d89604b" 13SRCREV = "ad437c38dc111cf3990a03abf14efe1b5d89604b"