summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-11-14 15:47:47 +0800
committerArmin Kuster <akuster808@gmail.com>2018-11-18 09:54:01 -0800
commit02a9767b3eab37642250aaeee5c17a10b38a759e (patch)
tree375103fbb3e73169b5e9589b4b0a01a0b8e22420
parent10127acafaf58cf044cc546a9d440091d494f931 (diff)
downloadmeta-openembedded-02a9767b3eab37642250aaeee5c17a10b38a759e.tar.gz
tk: export TK_LIBRARY='${libdir}/tk${VER}'
As there is below logic in configure.in [snip] test -z "$TK_LIBRARY" && TK_LIBRARY='$(prefix)/lib/tk$(VERSION)' [snip] It can make TK_LIBRARY to be $(prefix)/lib/tk$(VERSION) and then result in some files installed to /usr/lib/tk8.6 even when ${libdir} actually extract as /usr/lib64 and there is also a commit as below adding hack to workaround this. 1ca29d1cd tk: make multilib build compatible and fix library install Export TK_LIBRARY='${libdir}/tk${VER}' to guarantee the files installed to the expected places and also remove the workaround in the previous commit 1ca29d1cd. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb
index d0f6fe064..4e38525cb 100644
--- a/meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.8.bb
@@ -45,19 +45,11 @@ EXTRA_OECONF = "\
45 --with-tcl=${STAGING_BINDIR}/crossscripts \ 45 --with-tcl=${STAGING_BINDIR}/crossscripts \
46 --libdir=${libdir} \ 46 --libdir=${libdir} \
47" 47"
48 48export TK_LIBRARY='${libdir}/tk${VER}'
49do_install_append() { 49do_install_append() {
50 ln -sf libtk${VER}.so ${D}${libdir}/libtk${VER}.so.0 50 ln -sf libtk${VER}.so ${D}${libdir}/libtk${VER}.so.0
51 oe_libinstall -so libtk${VER} ${D}${libdir} 51 oe_libinstall -so libtk${VER} ${D}${libdir}
52 ln -sf wish${VER} ${D}${bindir}/wish 52 ln -sf wish${VER} ${D}${bindir}/wish
53
54 # Even after passing libdir=${libdir} at config, some incorrect dirs are still generated for the multilib build
55 if [ "$libdir" != "/usr/lib" ]; then
56 # Move files to correct library directory
57 mv ${D}/usr/lib/tk${VER}/* ${D}/${libdir}/tk${VER}/
58 # Remove unneeded/incorrect dir ('usr/lib/')
59 rm -rf ${D}/usr/lib
60 fi
61} 53}
62 54
63PACKAGECONFIG ??= "xft" 55PACKAGECONFIG ??= "xft"