diff options
author | douglas.royds <douglas.royds@taitradio.com> | 2018-11-13 18:08:34 +1300 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-11-15 13:18:52 -0800 |
commit | 37e061519c9c5c26567de976ce82c0719fc3ce29 (patch) | |
tree | 1f86861226d33ec479dcfa69b69bf03f2e462fed | |
parent | fe75e6efdd3c1d0d89b5732974c92960ae6e0f07 (diff) | |
download | meta-openembedded-37e061519c9c5c26567de976ce82c0719fc3ce29.tar.gz |
ntp: Reproducible build: Respect SOURCE_DATE_EPOCH
If a SOURCE_DATE_EPOCH is set in the environment, use that date in the build
version string, otherwise use the current build date.
See https://reproducible-builds.org/docs/source-date-epoch/
Should GNU date options fail, try BSD date options as a fall-back.
This patch can potentially be pushed upstream for use on Mac OSX or OpenBSD,
though it has not been tested on OSX or any BSD platform.
Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3550
Signed-off-by: Douglas Royds <douglas.royds@taitradio.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp/reproducibility-respect-source-date-epoch.patch | 16 | ||||
-rw-r--r-- | meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb | 1 |
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp/reproducibility-respect-source-date-epoch.patch b/meta-networking/recipes-support/ntp/ntp/reproducibility-respect-source-date-epoch.patch new file mode 100644 index 0000000000..58e71c3b8b --- /dev/null +++ b/meta-networking/recipes-support/ntp/ntp/reproducibility-respect-source-date-epoch.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | --- ntp-4.2.8p12.original/scripts/build/mkver.in 2018-11-12 14:06:49.333020430 +1300 | ||
2 | +++ ntp-4.2.8p12/scripts/build/mkver.in 2018-11-12 14:15:04.947480167 +1300 | ||
3 | @@ -15,7 +15,12 @@ | ||
4 | *) ConfStr="${ConfStr}-@VER_SUFFIX@" ;; | ||
5 | esac | ||
6 | |||
7 | -ConfStr="$ConfStr `LC_TIME=C TZ=UTC date`" | ||
8 | +if [ -n "$SOURCE_DATE_EPOCH" ]; then | ||
9 | + ConfStr="$ConfStr `LC_TIME=C TZ=UTC date -d@$SOURCE_DATE_EPOCH 2>/dev/null`" || | ||
10 | + ConfStr="$ConfStr `LC_TIME=C TZ=UTC date -r $SOURCE_DATE_EPOCH`" | ||
11 | +else | ||
12 | + ConfStr="$ConfStr `LC_TIME=C TZ=UTC date`" | ||
13 | +fi | ||
14 | |||
15 | if [ ! -f .version ]; then | ||
16 | echo 0 > .version | ||
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb index 4254301153..536679f4d5 100644 --- a/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb +++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p12.bb | |||
@@ -12,6 +12,7 @@ DEPENDS = "libevent" | |||
12 | 12 | ||
13 | SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ | 13 | SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \ |
14 | file://ntp-4.2.4_p6-nano.patch \ | 14 | file://ntp-4.2.4_p6-nano.patch \ |
15 | file://reproducibility-respect-source-date-epoch.patch \ | ||
15 | file://ntpd \ | 16 | file://ntpd \ |
16 | file://ntp.conf \ | 17 | file://ntp.conf \ |
17 | file://ntpdate \ | 18 | file://ntpdate \ |