summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2023-10-07 14:06:23 +0800
committerArmin Kuster <akuster808@gmail.com>2023-10-17 08:52:32 -0400
commit1d0d7f6e776d93474759e4d28f7445646b9b8645 (patch)
tree98d10e69f82e3ebca89538c8dded1c46662731b4
parent8808a69b6c1563f8d41ad34352afb8d274e967aa (diff)
downloadmeta-openembedded-1d0d7f6e776d93474759e4d28f7445646b9b8645.tar.gz
mbedtls: set up /usr/bin/hello as alternative
As mbedtls installs this rather generically-named /usr/bin/hello binary, it conflicts with the one provided by lmbench, hence set it up as an alternative to avoid conflicts when both are installed to rootfs or SDK. Signed-off-by: Denys Dmytriyenko <denis@denix.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
index 5696f94b0..1553c7188 100644
--- a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.28.2.bb
@@ -26,7 +26,7 @@ S = "${WORKDIR}/git"
26SRCREV = "89f040a5c938985c5f30728baed21e49d0846a53" 26SRCREV = "89f040a5c938985c5f30728baed21e49d0846a53"
27SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=mbedtls-2.28" 27SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=mbedtls-2.28"
28 28
29inherit cmake 29inherit cmake update-alternatives
30 30
31PACKAGECONFIG ??= "shared-libs programs" 31PACKAGECONFIG ??= "shared-libs programs"
32PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF" 32PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
@@ -41,4 +41,7 @@ RPROVIDES:${PN} = "polarssl"
41PACKAGES =+ "${PN}-programs" 41PACKAGES =+ "${PN}-programs"
42FILES:${PN}-programs = "${bindir}/" 42FILES:${PN}-programs = "${bindir}/"
43 43
44ALTERNATIVE:${PN}-programs = "hello"
45ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
46
44BBCLASSEXTEND = "native nativesdk" 47BBCLASSEXTEND = "native nativesdk"