summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-08-09 17:23:19 +0800
committerArmin Kuster <akuster808@gmail.com>2021-08-14 13:44:12 -0700
commitc1a9fe85173bb01b156564dd5c90c93238a3b1f5 (patch)
treebc8743841abe0ce703ed00c24b1daac51b01250d
parent85f8047c71047d93cf79a954142157f85079968d (diff)
downloadmeta-openembedded-c1a9fe85173bb01b156564dd5c90c93238a3b1f5.tar.gz
libdbi-perl: fix CVE-2014-10402
Backport patch to fix CVE-2014-10402. CVE: CVE-2014-10402 Ref: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=972180#12 Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit c80b3757ffc762a1577bcf7d0da41ebf1954b3f1) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl/CVE-2014-10402.patch56
-rw-r--r--meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb4
2 files changed, 59 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl/CVE-2014-10402.patch b/meta-oe/recipes-devtools/perl/libdbi-perl/CVE-2014-10402.patch
new file mode 100644
index 000000000..b41bbe0a5
--- /dev/null
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl/CVE-2014-10402.patch
@@ -0,0 +1,56 @@
1Backport patch to fix CVE-2014-10402.
2
3CVE: CVE-2014-10402
4Upstream-Status: Backport [https://github.com/rehsack/dbi/commit/19d0fb1]
5
6Ref:
7https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=972180#12
8
9Signed-off-by: Kai Kang <kai.kang@windriver.com>
10
11
12From 19d0fb169eed475e1c053e99036b8668625cfa94 Mon Sep 17 00:00:00 2001
13From: Jens Rehsack <sno@netbsd.org>
14Date: Tue, 6 Oct 2020 10:22:17 +0200
15Subject: [PATCH] lib/DBD/File.pm: fix CVE-2014-10401
16
17Dig into the root cause of RT#99508 - which resulted in CVE-2014-10401 - and
18figure out that DBI->parse_dsn is the wrong helper to parse our attributes in
19DSN, since in DBD::dr::connect only the "dbname" remains from DSN which causes
20parse_dsn to bailout.
21
22Parsing on our own similar to parse_dsn shows the way out.
23
24Signed-off-by: Jens Rehsack <sno@netbsd.org>
25---
26 lib/DBD/File.pm | 7 +++++--
27 1 file changed, 5 insertions(+), 2 deletions(-)
28
29diff --git a/lib/DBD/File.pm b/lib/DBD/File.pm
30index fb14e9a..f55076f 100644
31--- a/lib/DBD/File.pm
32+++ b/lib/DBD/File.pm
33@@ -109,7 +109,11 @@ sub connect
34 # We do not (yet) care about conflicting attributes here
35 # my $dbh = DBI->connect ("dbi:CSV:f_dir=test", undef, undef, { f_dir => "text" });
36 # will test here that both test and text should exist
37- if (my $attr_hash = (DBI->parse_dsn ($dbname))[3]) {
38+ #
39+ # Parsing on our own similar to parse_dsn to find attributes in 'dbname' parameter.
40+ if ($dbname) {
41+ my @attrs = split /;/ => $dbname;
42+ my $attr_hash = { map { split /\s*=>?\s*|\s*,\s*/, $_} @attrs };
43 if (defined $attr_hash->{f_dir} && ! -d $attr_hash->{f_dir}) {
44 my $msg = "No such directory '$attr_hash->{f_dir}";
45 $drh->set_err (2, $msg);
46@@ -120,7 +124,6 @@ sub connect
47 if ($attr and defined $attr->{f_dir} && ! -d $attr->{f_dir}) {
48 my $msg = "No such directory '$attr->{f_dir}";
49 $drh->set_err (2, $msg);
50- $attr->{RaiseError} and croak $msg;
51 return;
52 }
53
54--
552.17.1
56
diff --git a/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb b/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
index 75fad46bf..c8abae628 100644
--- a/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
+++ b/meta-oe/recipes-devtools/perl/libdbi-perl_1.643.bb
@@ -9,7 +9,9 @@ SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+" 9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5" 10LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5"
11 11
12SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz" 12SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz \
13 file://CVE-2014-10402.patch \
14 "
13SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398" 15SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398"
14SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa" 16SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa"
15 17