summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2021-07-20 18:30:50 +0200
committerArmin Kuster <akuster808@gmail.com>2021-07-25 13:36:02 -0700
commit8bdc78483115e12943f0946c8e863d4a70ef7168 (patch)
tree488a1464ba4ac049a98c897aa9c773fed1690962
parentb6123048dba176d8792a22925f800157d6cea7e1 (diff)
downloadmeta-openembedded-8bdc78483115e12943f0946c8e863d4a70ef7168.tar.gz
python3-jinja2: remove recipe
It was moved to OE-core/dunfell in cc0f56a788c3 (python3-jinja2: Import from meta-oe/meta-python) However it was not removed from meta-oe, as such this recipe is now duplicated, for no good reason. Worse than that, the version in meta-oe and oe-core differ. OE-core has 2.11.3 and meta-oe is older with 2.11.2. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-jinja2/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-jinja2_2.11.2.bb43
2 files changed, 0 insertions, 46 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jinja2/run-ptest b/meta-python/recipes-devtools/python/python3-jinja2/run-ptest
deleted file mode 100644
index 5cec71169..000000000
--- a/meta-python/recipes-devtools/python/python3-jinja2/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest
diff --git a/meta-python/recipes-devtools/python/python3-jinja2_2.11.2.bb b/meta-python/recipes-devtools/python/python3-jinja2_2.11.2.bb
deleted file mode 100644
index 681acf8f1..000000000
--- a/meta-python/recipes-devtools/python/python3-jinja2_2.11.2.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
5
6SRC_URI[sha256sum] = "89aab215427ef59c34ad58735269eb58b1a5808103067f7bb9d5836c651b3bb0"
7
8PYPI_PACKAGE = "Jinja2"
9
10CLEANBROKEN = "1"
11
12inherit pypi setuptools3 ptest
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS_${PN}-ptest += " \
24 ${PYTHON_PN}-pytest \
25 ${PYTHON_PN}-unixadmin \
26"
27
28RDEPENDS_${PN} += " \
29 ${PYTHON_PN}-asyncio \
30 ${PYTHON_PN}-crypt \
31 ${PYTHON_PN}-io \
32 ${PYTHON_PN}-json \
33 ${PYTHON_PN}-markupsafe \
34 ${PYTHON_PN}-math \
35 ${PYTHON_PN}-netclient \
36 ${PYTHON_PN}-numbers\
37 ${PYTHON_PN}-pickle \
38 ${PYTHON_PN}-pprint \
39 ${PYTHON_PN}-shell \
40 ${PYTHON_PN}-threading \
41"
42
43BBCLASSEXTEND = "native nativesdk"