diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2014-08-19 05:16:16 -0400 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-08-21 21:35:08 +0200 |
commit | fca294b76eb2477fb23bf412b2188fdbffad6629 (patch) | |
tree | 1d14915edae041c847e1dc180ca452a9dbe3cc26 | |
parent | ff134012611bc9f93237e4a4372b87c3ceaaf1a3 (diff) | |
download | meta-openembedded-fca294b76eb2477fb23bf412b2188fdbffad6629.tar.gz |
lmbench: Fix "make html" graph failure
The html-list perl script cannot parse the first line of the result
files about the lmbench version.
Additional fixes are to make the result's html pages easier to understand.
Signed-off-by: Lin Yu <lin.yu@windriver.com>
Signed-off-by: Fupan Li <fupan.li@windriver.com>
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch | 61 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | 5 |
2 files changed, 64 insertions, 2 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch new file mode 100644 index 000000000..cda2f0c6d --- /dev/null +++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/lmbench_result_html_report.patch | |||
@@ -0,0 +1,61 @@ | |||
1 | lmbench: Fix "make html" graph failure | ||
2 | |||
3 | The html-list perl script cannot parse the first line of the result | ||
4 | files about the lmbench version. | ||
5 | |||
6 | Additional fixes are to make the result's html pages easier to understand. | ||
7 | |||
8 | Signed-off-by: Lin Yu <lin.yu@windriver.com> | ||
9 | Signed-off-by: Fupan Li <fupan.li@windriver.com> | ||
10 | |||
11 | Reworded patch description. | ||
12 | |||
13 | Upstream-status: inappropriate [ configuration ] | ||
14 | |||
15 | Signed-off-by: Mark Hatle <mark.hatle@windriver.com> | ||
16 | |||
17 | diff --git a/results/Makefile b/results/Makefile | ||
18 | index 0935376..1ef9a15 100644 | ||
19 | --- a/results/Makefile | ||
20 | +++ b/results/Makefile | ||
21 | @@ -186,6 +186,7 @@ paper: | ||
22 | # scratch makes you want a Ghz machine. | ||
23 | html: dirs | ||
24 | -make clean | ||
25 | + make ps | ||
26 | #$(SCRIPTS)bghtml $(BG) | ||
27 | $(SCRIPTS)html-list $(LIST) | ||
28 | $(MK) LIST="$(LIST)" summary > HTML/summary.out 2> HTML/summary.errs | ||
29 | diff --git a/scripts/html-list b/scripts/html-list | ||
30 | index 9850461..6383115 100755 | ||
31 | --- a/scripts/html-list | ||
32 | +++ b/scripts/html-list | ||
33 | @@ -14,7 +14,7 @@ open(H, ">HTML/specific.html"); | ||
34 | print H <<EOF; | ||
35 | <title>LMBENCH System Results</title> | ||
36 | <h1>LMBENCH System Results</h1> | ||
37 | -<h2><a href=summary>Summary of results</a></h2> | ||
38 | +<h2><a href=summary.out>Summary of results</a></h2> | ||
39 | <hr> | ||
40 | EOF | ||
41 | |||
42 | @@ -47,7 +47,7 @@ foreach $os (@os) { | ||
43 | open(F, $file); | ||
44 | $_ = <F>; | ||
45 | close(F); | ||
46 | - next unless /lmbench1.[01]/; | ||
47 | + next unless /lmbench[0-9]+.[01]/; | ||
48 | chop; | ||
49 | $title = $_; | ||
50 | #s/.lmbench1.? results for //; | ||
51 | @@ -103,10 +103,7 @@ EOF | ||
52 | if $i < $#os; | ||
53 | print S<<EOF; | ||
54 | <h4>$title</h4> | ||
55 | -<a href=../$doc{$what}>Information on this benchmark</a> (Not up to date) | ||
56 | <p><IMG SRC="${what}${scale}$N.gif">\n<p> | ||
57 | -<a href=../lmbench.html> | ||
58 | -<img align=middle src="../gifs/arrows/b_arrow.gif">LMBENCH table of contents</a> | ||
59 | <a href=specific.html> | ||
60 | <img align=middle src=\"../gifs/graph.gif\">System results table of contents</a> | ||
61 | <p> | ||
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb index 41db15000..d8238ae4b 100644 --- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb +++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | |||
@@ -14,8 +14,9 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \ | |||
14 | file://rename-line-binary.patch \ | 14 | file://rename-line-binary.patch \ |
15 | file://update-results-script.patch \ | 15 | file://update-results-script.patch \ |
16 | file://obey-ranlib.patch \ | 16 | file://obey-ranlib.patch \ |
17 | file://update-config-script.patch \ | 17 | file://update-config-script.patch \ |
18 | file://use-base_libdir-instead-of-hardcoded-lib.patch \ | 18 | file://use-base_libdir-instead-of-hardcoded-lib.patch \ |
19 | file://lmbench_result_html_report.patch \ | ||
19 | " | 20 | " |
20 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" | 21 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" |
21 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" | 22 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" |