summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-11-01 09:23:40 -0400
committerArmin Kuster <akuster808@gmail.com>2018-02-01 07:32:05 -0800
commite4c768c2e35f6242886c25f6d504d6ae5b9b2b50 (patch)
tree424e55df27bb3d57fe17b9f859fc08611e3d5ab1
parentf80ff75c448668f3c68166fd37ef4c4ebbcbc453 (diff)
downloadmeta-openembedded-e4c768c2e35f6242886c25f6d504d6ae5b9b2b50.tar.gz
net-snmp: support openssl without 3des
net-snmp enables 3des support by default and fails to build with distro feature openssl-no-weak-ciphers: | ../../net-snmp-5.7.3/snmplib/scapi.c:82:25: fatal error: openssl/des.h: No such file or directory | #include <openssl/des.h> To fix the issue: * add a patch to include des.h only if it's found in openssl * disable des when openssl-no-weak-ciphers is enabled Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> (cherry picked from commit d8e69bc9e9c183346a11eb31915c12558565f881) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-fix-for-disable-des.patch32
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-fix-for-disable-des.patch b/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-fix-for-disable-des.patch
new file mode 100644
index 000000000..25eb9c96f
--- /dev/null
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-fix-for-disable-des.patch
@@ -0,0 +1,32 @@
1From 270e952f58a7e5ddeabe5a15e3ddaaadf40017d0 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Thu, 22 Jun 2017 10:25:08 +0800
4Subject: [PATCH] net-snmp: fix for --disable-des
5
6Include des.h only if it's found in openssl so that
7the --disable-des works correctly.
8
9Upstream-Status: Submitted [net-snmp-coders@lists.sourceforge.net]
10
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12---
13 snmplib/scapi.c | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/snmplib/scapi.c b/snmplib/scapi.c
17index 16ac829..271684b 100644
18--- a/snmplib/scapi.c
19+++ b/snmplib/scapi.c
20@@ -79,7 +79,9 @@ netsnmp_feature_child_of(usm_scapi, usm_support)
21 #include <openssl/hmac.h>
22 #include <openssl/evp.h>
23 #include <openssl/rand.h>
24+#ifdef HAVE_OPENSSL_DES_H
25 #include <openssl/des.h>
26+#endif
27 #ifdef HAVE_AES
28 #include <openssl/aes.h>
29 #endif
30--
312.11.0
32
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
index af6fd1b1f..849ae0763 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.3.bb
@@ -31,6 +31,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.zip \
31 file://0003-CHANGES-BUG-2712-Fix-Perl-module-compilation.patch \ 31 file://0003-CHANGES-BUG-2712-Fix-Perl-module-compilation.patch \
32 file://0004-configure-fix-incorrect-variable.patch \ 32 file://0004-configure-fix-incorrect-variable.patch \
33 file://net-snmp-5.7.2-fix-engineBoots-value-on-SIGHUP.patch \ 33 file://net-snmp-5.7.2-fix-engineBoots-value-on-SIGHUP.patch \
34 file://net-snmp-fix-for-disable-des.patch \
34 " 35 "
35SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee" 36SRC_URI[md5sum] = "9f682bd70c717efdd9f15b686d07baee"
36SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e" 37SRC_URI[sha256sum] = "e8dfc79b6539b71a6ff335746ce63d2da2239062ad41872fff4354cafed07a3e"
@@ -59,7 +60,8 @@ EXTRA_OECONF = "--enable-shared \
59 --with-defaults \ 60 --with-defaults \
60 --with-install-prefix=${D} \ 61 --with-install-prefix=${D} \
61 --with-persistent-directory=${localstatedir}/lib/net-snmp \ 62 --with-persistent-directory=${localstatedir}/lib/net-snmp \
62 ${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)}" 63 ${@base_conditional('SITEINFO_ENDIANNESS', 'le', '--with-endianness=little', '--with-endianness=big', d)} \
64"
63 65
64# net-snmp needs to have mib-modules=smux enabled to enable quagga to support snmp 66# net-snmp needs to have mib-modules=smux enabled to enable quagga to support snmp
65EXTRA_OECONF += "--with-mib-modules=smux" 67EXTRA_OECONF += "--with-mib-modules=smux"