summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-26 09:19:11 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:43:28 -0700
commitdacfa2b1920e285531bec55cd2f08743390aaf57 (patch)
tree7bf3ebccfdfafd5c8dca913268aa8521e47df6da
parent187f959fbd220678595c2aa1fe1e17b00a0b2d92 (diff)
downloadmeta-openembedded-dacfa2b1920e285531bec55cd2f08743390aaf57.tar.gz
python-automat: fix build dependencies to avoid download during do_compile
Add the correct version of python{3}-setuptools-scm-native Remove the dependency on m2r Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-automat.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch52
2 files changed, 60 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat.inc b/meta-python/recipes-devtools/python/python-automat.inc
index 1ac5d3b32..43b9ce9e3 100644
--- a/meta-python/recipes-devtools/python/python-automat.inc
+++ b/meta-python/recipes-devtools/python/python-automat.inc
@@ -3,6 +3,8 @@ HOMEPAGE = "https://github.com/glyph/Automat"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=4ad213bcca81688e94593e5f60c87477"
5 5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-automat:"
7
6SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d" 8SRC_URI[md5sum] = "ad7bba58d262d8956d732330cb5ef53d"
7SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8" 9SRC_URI[sha256sum] = "3c1fd04ecf08ac87b4dd3feae409542e9bf7827257097b2b6ed5692f69d6f6a8"
8 10
@@ -10,6 +12,12 @@ PYPI_PACKAGE = "Automat"
10 12
11inherit pypi 13inherit pypi
12 14
15SRC_URI_append = " \
16 file://0001-setup.py-remove-the-dependency-on-m2r.patch \
17"
18
19DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
20
13RDEPENDS_${PN} += "\ 21RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-attrs \ 22 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-six \ 23 ${PYTHON_PN}-six \
diff --git a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch
new file mode 100644
index 000000000..0ebb22075
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch
@@ -0,0 +1,52 @@
1From d5ebe479fc8fe11c5c75e7f35484849320349222 Mon Sep 17 00:00:00 2001
2From: Derek Straka <derek@asterius.io>
3Date: Fri, 22 Dec 2017 09:07:00 -0500
4Subject: [PATCH] setup.py: remove the dependency on m2r
5
6The dependency on m2r is removed here as it only provides the
7long_description value that is optional. This item is just the
8text that would be present on PyPi, so it doesn't provide much
9value in this case
10
11Upstream-Status: Inappropriate (OE specific)
12
13Signed-off-by: Derek Straka <derek@asterius.io>
14---
15 setup.py | 10 ----------
16 1 file changed, 10 deletions(-)
17
18diff --git a/setup.py b/setup.py
19index d360c64..7b4180a 100644
20--- a/setup.py
21+++ b/setup.py
22@@ -4,14 +4,6 @@ Setup file for automat
23
24 from setuptools import setup, find_packages
25
26-try:
27- from m2r import parse_from_file
28- long_description = parse_from_file('README.md')
29-except(IOError, ImportError):
30- print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n")
31- import io
32- long_description = io.open('README.md', encoding="utf-8").read()
33-
34 setup(
35 name='Automat',
36 use_scm_version=True,
37@@ -19,12 +11,10 @@ setup(
38 description="""
39 Self-service finite-state machines for the programmer on the go.
40 """.strip(),
41- long_description=long_description,
42 packages=find_packages(exclude=[]),
43 package_dir={'automat': 'automat'},
44 setup_requires=[
45 'setuptools-scm',
46- 'm2r',
47 ],
48 install_requires=[
49 "attrs>=16.1.0",
50--
512.7.4
52