diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-08 11:26:55 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-04-08 21:49:05 +0200 |
commit | da0fb166a41bdbcfd6c902389c919a278ba31477 (patch) | |
tree | 66abc26a3b7b09edb92ef6aa02313f2feb3f7b23 | |
parent | 05203855acb5c484af45e3abdae6a2cc3e9ddfd7 (diff) | |
download | meta-openembedded-da0fb166a41bdbcfd6c902389c919a278ba31477.tar.gz |
cloud9 0.5.1: use nodejs4 instead of nodejs
This allows using nodejs 0.6.x for apps, but running cloud9 using node4
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service | 2 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb | 6 |
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service index 027d03a86..714b465cc 100644 --- a/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service +++ b/meta-oe/recipes-devtools/cloud9/cloud9/cloud9.service | |||
@@ -3,7 +3,7 @@ Description=Cloud9 IDE | |||
3 | ConditionPathExists=|/var/lib/cloud9 | 3 | ConditionPathExists=|/var/lib/cloud9 |
4 | 4 | ||
5 | [Service] | 5 | [Service] |
6 | ExecStart=/usr/bin/node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000 | 6 | ExecStart=/usr/bin/node4 /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000 |
7 | 7 | ||
8 | [Install] | 8 | [Install] |
9 | WantedBy=multi-user.target | 9 | WantedBy=multi-user.target |
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb index 8a3f2060d..4f74edbc8 100644 --- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb +++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" | |||
5 | 5 | ||
6 | DEPENDS = "libxml2 nodejs-native" | 6 | DEPENDS = "libxml2 nodejs-native" |
7 | 7 | ||
8 | PR = "r15" | 8 | PR = "r16" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ | 10 | SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ |
11 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ | 11 | git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \ |
@@ -90,7 +90,7 @@ do_install () { | |||
90 | 90 | ||
91 | touch ${D}${bindir}/cloud9 | 91 | touch ${D}${bindir}/cloud9 |
92 | echo "#!/bin/sh" > ${D}${bindir}/cloud9 | 92 | echo "#!/bin/sh" > ${D}${bindir}/cloud9 |
93 | echo "node ${datadir}/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9 | 93 | echo "node4 ${datadir}/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9 |
94 | chmod 0755 ${D}${bindir}/cloud9 | 94 | chmod 0755 ${D}${bindir}/cloud9 |
95 | 95 | ||
96 | install -m 0755 -d ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml | 96 | install -m 0755 -d ${D}${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml |
@@ -106,7 +106,7 @@ FILES_${PN}-dbg += "${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o | |||
106 | ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \ | 106 | ${datadir}/cloud9/support/jsdav/support/node-o3-xml-v4/lib/.debug \ |
107 | " | 107 | " |
108 | 108 | ||
109 | RDEPENDS_${PN} = "nodejs gzip" | 109 | RDEPENDS_${PN} = "nodejs4 gzip" |
110 | 110 | ||
111 | inherit systemd | 111 | inherit systemd |
112 | 112 | ||