summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-05-21 11:17:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-21 13:58:27 +0200
commit9d49c83415d5233ac17d68d21fb5fd6a91085593 (patch)
treeb5407f9b4c6be284846dfa39583a90a0009ef03e
parent02995f82e63ef1aab25b03404102a22fe4d524e7 (diff)
downloadmeta-openembedded-9d49c83415d5233ac17d68d21fb5fd6a91085593.tar.gz
libwebp: add new recipe for version 0.4.0
This is the WebP image format designed by Google. WebM is already included in meta-openembedded. Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb b/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb
new file mode 100644
index 000000000..a5a91697b
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://PATENTS;md5=7ec8a34de2073ea13ea2991006246d20"
14
15SRC_URI = "https://webp.googlecode.com/files/${BP}.tar.gz"
16SRC_URI[md5sum] = "c8dd1d26eb9566833aba269b86d97e68"
17SRC_URI[sha256sum] = "31913577e96386556855b41d210736449445fe96cfbe9289014e9b8afa944d69"
18
19EXTRA_OECONF = " \
20 --disable-experimental \
21 --disable-wic \
22 --enable-libwebpmux \
23 --enable-libwebpdemux \
24 --enable-threading \
25"
26
27inherit autotools lib_package
28
29PACKAGECONFIG ??= ""
30
31# libwebpdecoder is a subset of libwebp, don't build it unless requested
32PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
33
34# Apply for examples programs: cwebp and dwebp
35PACKAGECONFIG[jpeg] = ",ac_cv_header_jpeglib_h=no,jpeg"
36PACKAGECONFIG[png] = ",ac_cv_header_png_h=no,libpng"
37PACKAGECONFIG[tiff] = ",ac_cv_header_tiffio_h=no,tiff"
38
39# Apply only for example program vwebp
40PACKAGECONFIG[gl] = ",,mesa-glut"
41
42PACKAGES =+ "${PN}-gif2webp"
43
44DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
45FILES_${PN}-gif2webp = "${bindir}/gif2webp"
46DEPENDS_${PN}-gif2webp += "giflib"