diff options
author | Qi.Chen@windriver.com <Qi.Chen@windriver.com> | 2016-05-05 16:04:03 +0800 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-05-12 11:53:29 -0400 |
commit | 8b5662be65fccd26d241cdc2b561032e13c1e63f (patch) | |
tree | 9ff864509598469b0b97e9be5100fe6bdb0823f5 | |
parent | 2f3a4997c70cf7c1e28ccf33a31ce1437fe1db27 (diff) | |
download | meta-openembedded-8b5662be65fccd26d241cdc2b561032e13c1e63f.tar.gz |
curlpp: fix recipe
Fix curlpp recipe to make it succeed to build.
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb | 60 |
1 files changed, 0 insertions, 60 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb index b3231fbc8..5663f0e91 100644 --- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb +++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb | |||
@@ -16,63 +16,6 @@ SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a | |||
16 | 16 | ||
17 | inherit autotools-brokensep pkgconfig binconfig | 17 | inherit autotools-brokensep pkgconfig binconfig |
18 | 18 | ||
19 | EXTRA_OECONF = "--prefix=${STAGING_DIR} \ | ||
20 | --with-boost=${STAGING_DIR} \ | ||
21 | " | ||
22 | |||
23 | do_install() { | ||
24 | install -d ${D}/${includedir}/curlpp | ||
25 | cp -r include/curlpp/* ${D}${includedir}/curlpp | ||
26 | |||
27 | install -d ${D}${includedir}/utilspp | ||
28 | cp -r include/utilspp/* ${D}${includedir}/utilspp | ||
29 | |||
30 | install -d ${D}/${libdir} | ||
31 | install -m 664 src/curlpp/.libs/libcurlpp.a ${D}/${libdir} | ||
32 | install -m 664 src/curlpp/.libs/libcurlpp.lai ${D}/${libdir}/libcurlpp.la | ||
33 | |||
34 | install -m 775 src/curlpp/.libs/libcurlpp.so.0.0.2 ${D}/${libdir} | ||
35 | |||
36 | install -m 664 src/utilspp/.libs/libutilspp.a ${D}/${libdir} | ||
37 | install -m 664 src/utilspp/.libs/libutilspp.lai ${D}/${libdir}/libutilspp.la | ||
38 | |||
39 | install -m 664 src/utilspp/.libs/libutilspp.so.0.0.0 ${D}/${libdir} | ||
40 | |||
41 | install -d ${D}/${libdir}/pkgconfig | ||
42 | install -m 664 curlpp.pc ${D}/${libdir}/pkgconfig | ||
43 | |||
44 | install -d ${D}/${bindir} | ||
45 | install -m 755 curlpp-config ${D}/${bindir} | ||
46 | |||
47 | install -d ${D}/${includedir}/curlpp | ||
48 | install -d ${D}/${includedir}/curlpp/internal | ||
49 | install -d ${D}/${includedir}/utilspp | ||
50 | install -d ${D}/${includedir}/utilspp/functor | ||
51 | install -d ${D}/${includedir}/utilspp/singleton | ||
52 | |||
53 | install -m 664 include/curlpp/config* ${D}/${includedir}/curlpp | ||
54 | install -m 664 include/curlpp/*.h* ${D}/${includedir}/curlpp | ||
55 | install -m 664 include/curlpp/*.inl ${D}/${includedir}/curlpp | ||
56 | |||
57 | install -m 664 include/curlpp/internal/*.h* ${D}/${includedir}/curlpp/internal | ||
58 | install -m 664 include/curlpp/internal/*.inl ${D}/${includedir}/curlpp/internal | ||
59 | |||
60 | install -m 664 include/utilspp/*.h* ${D}/${includedir}/utilspp | ||
61 | install -m 664 include/utilspp/*.inl ${D}/${includedir}/utilspp | ||
62 | |||
63 | install -m 664 include/utilspp/functor/*.h* ${D}/${includedir}/utilspp/functor | ||
64 | install -m 664 include/utilspp/singleton/*.h* ${D}/${includedir}/utilspp/singleton | ||
65 | install -m 664 include/utilspp/singleton/*.inl ${D}/${includedir}/utilspp/singleton | ||
66 | install -m 755 curlpp-config ${D}/${bindir} | ||
67 | } | ||
68 | |||
69 | pkg_postinst_${PN}() { | ||
70 | ln -sf libcurlpp.so.0.0.2 /usr/lib/libcurlpp.so.0 | ||
71 | ln -sf libcurlpp.so.0.0.2 /usr/lib/libcurlpp.so | ||
72 | ln -sf libutilspp.so.0.0.0 /usr/lib/libutilspp.so.0 | ||
73 | ln -sf libutilspp.so.0.0.0 /usr/lib/libutilspp.so | ||
74 | } | ||
75 | |||
76 | PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev" | 19 | PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev" |
77 | 20 | ||
78 | FILES_lib${BPN} = "${libdir}/lib*.so.* \ | 21 | FILES_lib${BPN} = "${libdir}/lib*.so.* \ |
@@ -86,6 +29,3 @@ FILES_lib${BPN}-dev = "${includedir} \ | |||
86 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" | 29 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" |
87 | 30 | ||
88 | BBCLASSEXTEND = "native nativesdk" | 31 | BBCLASSEXTEND = "native nativesdk" |
89 | |||
90 | # http://errors.yoctoproject.org/Errors/Details/35129/ | ||
91 | PNBLACKLIST[curlpp] ?= "BROKEN: QA Issue: curlpp.pc failed sanity test (tmpdir)" | ||