diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-25 22:34:45 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:25 +0200 |
commit | 81a3addfe5b74bd5779ab9cd8fe047d348ab8c25 (patch) | |
tree | 46496f45113b7c7c1635cde80c17f2e4f8173fb7 | |
parent | bd66426dc33b66d9b551c48a8091b939126ce8b4 (diff) | |
download | meta-openembedded-81a3addfe5b74bd5779ab9cd8fe047d348ab8c25.tar.gz |
ssiapi: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/ssiapi/ssiapi/configure-cflags.patch | 21 | ||||
-rw-r--r-- | meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb | 2 |
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ssiapi/ssiapi/configure-cflags.patch b/meta-oe/recipes-support/ssiapi/ssiapi/configure-cflags.patch new file mode 100644 index 0000000000..d45be590c7 --- /dev/null +++ b/meta-oe/recipes-support/ssiapi/ssiapi/configure-cflags.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | Do not override flags thereby respect the flags coming from environment, | ||
2 | e.g. we need some optimization level turned on when security flags are enabled | ||
3 | without this change, the build would fail | ||
4 | |||
5 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
6 | Index: ssiapi.1.0.1/configure.ac | ||
7 | =================================================================== | ||
8 | --- ssiapi.1.0.1.orig/configure.ac | ||
9 | +++ ssiapi.1.0.1/configure.ac | ||
10 | @@ -15,11 +15,6 @@ AC_SUBST(VERSION) | ||
11 | AM_INIT_AUTOMAKE(ssi, ${VERSION}) | ||
12 | AM_CONFIG_HEADER(config.h) | ||
13 | |||
14 | -dnl Set the language we use | ||
15 | -CPPFLAGS="-g3 -gdwarf-2 -Wall -Werror -D_GNU_SOURCE" | ||
16 | -CFLAGS="-std=gnu99" | ||
17 | -CXXFLAGS="-std=gnu++98" | ||
18 | - | ||
19 | dnl Automake 1.11 - silent build rules | ||
20 | m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])]) | ||
21 | |||
diff --git a/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb b/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb index f3c1fc43ab..3396370873 100644 --- a/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb +++ b/meta-oe/recipes-support/ssiapi/ssiapi_1.0.1.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "http://sourceforge.net/projects/irstessi/files/${BPN}.${PV}.tgz \ | |||
17 | file://0004-engine-Fix-indentation-and-missing-semi-colon.patch \ | 17 | file://0004-engine-Fix-indentation-and-missing-semi-colon.patch \ |
18 | file://0005-engine-Define-SENTINEL.patch \ | 18 | file://0005-engine-Define-SENTINEL.patch \ |
19 | file://0006-tools-Add-missing-includes-and-use-realpath-instead-.patch \ | 19 | file://0006-tools-Add-missing-includes-and-use-realpath-instead-.patch \ |
20 | file://configure-cflags.patch \ | ||
20 | " | 21 | " |
21 | SRC_URI[md5sum] = "02f16d7cbd30d28034093212906591f5" | 22 | SRC_URI[md5sum] = "02f16d7cbd30d28034093212906591f5" |
22 | SRC_URI[sha256sum] = "e10d283b0f211afb8ebd0bde87c097769613d30a052cdf164753e35e803264c7" | 23 | SRC_URI[sha256sum] = "e10d283b0f211afb8ebd0bde87c097769613d30a052cdf164753e35e803264c7" |
@@ -24,6 +25,7 @@ SRC_URI[sha256sum] = "e10d283b0f211afb8ebd0bde87c097769613d30a052cdf164753e35e80 | |||
24 | S ="${WORKDIR}/${BPN}.${PV}" | 25 | S ="${WORKDIR}/${BPN}.${PV}" |
25 | 26 | ||
26 | inherit autotools-brokensep | 27 | inherit autotools-brokensep |
28 | CXXFLAGS="-std=gnu++98 -D_GNU_SOURCE" | ||
27 | 29 | ||
28 | do_configure_prepend(){ | 30 | do_configure_prepend(){ |
29 | ./autogen.sh | 31 | ./autogen.sh |