summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-09 22:08:13 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-11 11:33:38 +0200
commit79b8431f61235f9b00005919d3033a8adef102b0 (patch)
tree2f426955e354000190cfb40bf24c42834ccf42b0
parentae72ce9aebaac49215caab1d41eed0f3e37d46e6 (diff)
downloadmeta-openembedded-79b8431f61235f9b00005919d3033a8adef102b0.tar.gz
nodejs: remove older 0.6.21
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch22
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb65
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
deleted file mode 100644
index 36e8bf1c9..000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1Fix hardfloat detection
2
3gcc has a builtin define to denote hard abi when in use, e.g. when
4using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore
5we should check that to determine which calling convention is in use
6and not __VFP_FP__ which merely indicates presence of VFP unit
7
8The fix has been provided by Khem Raj <raj.khem@gmail.com>
9
10Upstream-Status: Forwarded
11
12--- a/deps/v8/src/platform-linux.cc 2012-05-17 12:52:59.329519921 -0700
13+++ b/deps/v8/src/platform-linux.cc 2012-05-17 12:54:02.037521511 -0700
14@@ -212,7 +212,7 @@
15 // calling this will return 1.0 and otherwise 0.0.
16 static void ArmUsingHardFloatHelper() {
17 asm("mov r0, #0");
18-#if defined(__VFP_FP__) && !defined(__SOFTFP__)
19+#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__)
20 // Load 0x3ff00000 into r1 using instructions available in both ARM
21 // and Thumb mode.
22 asm("mov r1, #3");
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
deleted file mode 100644
index 3d034f2fc..000000000
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.21.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=914812f2875eef849b5c509cc25dcb4f"
5
6DEPENDS = "openssl"
7
8SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \
9 file://fix-hardfloat-detection.patch"
10SRC_URI[md5sum] = "0da985a0bf820400af92363b9f453fe4"
11SRC_URI[sha256sum] = "22265fd07e09c22f1d058156d548e7398c9740210f534e2f848eeab5b9772117"
12
13S = "${WORKDIR}/node-v${PV}"
14
15# v8 errors out if you have set CCACHE
16CCACHE = ""
17
18do_configure_virtclass-native () {
19 sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript
20 sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript
21
22 ./configure --prefix=${prefix} --without-snapshot
23}
24
25# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround waf+scons
26do_configure () {
27 echo '#!/bin/sh' > ${WORKDIR}/gcc
28 echo '${CC} $@' >> ${WORKDIR}/gcc
29
30 echo '#!/bin/sh' > ${WORKDIR}/g++
31 echo '${CXX} $@'>> ${WORKDIR}/g++
32
33 chmod +x ${WORKDIR}/gcc ${WORKDIR}/g++
34
35 sed -i -e s:\'/usr/lib:\'${STAGING_LIBDIR}:g wscript
36 sed -i -e s:\'/usr/local/lib:\'${STAGING_LIBDIR}:g wscript
37
38 export PATH=${WORKDIR}:${PATH}
39 export CC=gcc
40 export CXX=g++
41
42 ./configure --prefix=${prefix} --without-snapshot
43}
44
45do_compile_virtclass-native () {
46 make BUILDTYPE=Release
47}
48
49do_compile () {
50 export PATH=${WORKDIR}:${PATH}
51 export CC=gcc
52 export CXX=g++
53 make BUILDTYPE=Release
54}
55
56do_install () {
57 export DESTDIR=${D}
58 oe_runmake install
59}
60
61RDEPENDS_${PN} = "curl python-shell python-datetime python-subprocess python-crypt python-textutils python-netclient "
62RDEPENDS_${PN}_virtclass-native = "curl-native python-native"
63
64FILES_${PN} += "${libdir}/node/wafadmin ${libdir}/node_modules"
65BBCLASSEXTEND = "native"