summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-01 08:53:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-06 13:00:29 +0200
commit6c4caeee6f737e069c871a25110938b7a1e2332e (patch)
tree358e342f4406ddeebbedcab5c7dbd6811ee4490c
parent401fbd9e50e06e8253135ca783adebebbdad44b1 (diff)
downloadmeta-openembedded-6c4caeee6f737e069c871a25110938b7a1e2332e.tar.gz
libnih: Drop SIGCLD
Its not portable, especially musl does not support it Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch28
-rw-r--r--meta-oe/recipes-support/libnih/libnih_1.0.3.bb5
2 files changed, 31 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch b/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch
new file mode 100644
index 000000000..a43b4b176
--- /dev/null
+++ b/meta-oe/recipes-support/libnih/libnih-1.0.3/0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch
@@ -0,0 +1,28 @@
1From f1b9992caf9910f9f7afae401045e42572cc84ff Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 1 Apr 2017 08:50:35 -0700
4Subject: [PATCH] signal.c: SIGCLD and SIGCHILD are same on sytem V systems
5
6Musl drops the SIGCLD legacy
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 nih/signal.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/nih/signal.c b/nih/signal.c
14index a241df9..691c8e6 100644
15--- a/nih/signal.c
16+++ b/nih/signal.c
17@@ -87,7 +87,7 @@ static const SignalName signal_names[] = {
18 { SIGSTKFLT, "STKFLT" },
19 #endif
20 { SIGCHLD, "CHLD" },
21- { SIGCLD, "CLD" },
22+ { SIGCHLD, "CLD" },
23 { SIGCONT, "CONT" },
24 { SIGSTOP, "STOP" },
25 { SIGTSTP, "TSTP" },
26--
272.12.1
28
diff --git a/meta-oe/recipes-support/libnih/libnih_1.0.3.bb b/meta-oe/recipes-support/libnih/libnih_1.0.3.bb
index 40aa8964e..02fe805fc 100644
--- a/meta-oe/recipes-support/libnih/libnih_1.0.3.bb
+++ b/meta-oe/recipes-support/libnih/libnih_1.0.3.bb
@@ -23,8 +23,9 @@ DEPENDS = "dbus libnih-native"
23DEPENDS_class-native = "dbus-native" 23DEPENDS_class-native = "dbus-native"
24 24
25SRC_URI = "https://launchpad.net/${BPN}/1.0/${PV}/+download/${BP}.tar.gz \ 25SRC_URI = "https://launchpad.net/${BPN}/1.0/${PV}/+download/${BP}.tar.gz \
26 file://libnih_1.0.3-4ubuntu16.patch \ 26 file://libnih_1.0.3-4ubuntu16.patch \
27" 27 file://0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch \
28 "
28 29
29SRC_URI[md5sum] = "db7990ce55e01daffe19006524a1ccb0" 30SRC_URI[md5sum] = "db7990ce55e01daffe19006524a1ccb0"
30SRC_URI[sha256sum] = "897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405" 31SRC_URI[sha256sum] = "897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405"