diff options
author | Tim Orling <ticotimo@gmail.com> | 2014-07-19 21:07:37 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 00:01:58 +0200 |
commit | 60d945867efb496fd2030a69d0c04572939d23b3 (patch) | |
tree | a537625d1a1667935570f28873c8807272b649f1 | |
parent | f647f319fcf1ca4844039a83fbc38acbd4ac762e (diff) | |
download | meta-openembedded-60d945867efb496fd2030a69d0c04572939d23b3.tar.gz |
vlc.inc: cleanup configure, inherit pkgconfig
* Upstream is now much more pkg-config friendly
* Clean up configure baggage, no longer needed
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-multimedia/recipes-multimedia/vlc/vlc.inc | 33 |
1 files changed, 15 insertions, 18 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc.inc b/meta-multimedia/recipes-multimedia/vlc/vlc.inc index 58f564821..c18877173 100644 --- a/meta-multimedia/recipes-multimedia/vlc/vlc.inc +++ b/meta-multimedia/recipes-multimedia/vlc/vlc.inc | |||
@@ -5,17 +5,17 @@ SECTION = "multimedia" | |||
5 | LICENSE = "GPL-2.0" | 5 | LICENSE = "GPL-2.0" |
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
7 | 7 | ||
8 | DEPENDS = "libfribidi libtool libgcrypt gst-plugins-bad virtual/libsdl \ | 8 | DEPENDS = "libfribidi libtool libgcrypt libgcrypt-native gst-plugins-bad \ |
9 | libsdl-image qt4-x11-free dbus dbus-glib libxml2 gnutls tremor \ | 9 | virtual/libsdl libsdl-image qt4-x11-free dbus dbus-glib libxml2 gnutls \ |
10 | faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib libdvdcss \ | 10 | tremor faad2 ffmpeg flac libxpm libxinerama fluidsynth alsa-lib \ |
11 | libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs libdc1394 \ | 11 | libdvdcss libdvdread lua-native lua libidn libnotify gtk+ gnome-vfs \ |
12 | libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \ | 12 | libdc1394 libraw1394 avahi libjpeg-turbo xz libmodplug mpeg2dec \ |
13 | libmtp opencv libopus orc libusb1 schroedinger taglib \ | 13 | libmtp opencv libopus orc libusb1 schroedinger taglib \ |
14 | tiff xcb-util-keysyms samba" | 14 | tiff xcb-util-keysyms samba" |
15 | 15 | ||
16 | SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" | 16 | SRC_URI = "http://download.videolan.org/pub/videolan/${BPN}/${PV}/${BP}.tar.xz" |
17 | 17 | ||
18 | inherit autotools gettext | 18 | inherit autotools gettext pkgconfig |
19 | 19 | ||
20 | ARM_INSTRUCTION_SET = "arm" | 20 | ARM_INSTRUCTION_SET = "arm" |
21 | 21 | ||
@@ -29,18 +29,20 @@ EXTRA_OECONF = "\ | |||
29 | --enable-freetype \ | 29 | --enable-freetype \ |
30 | --enable-sdl \ | 30 | --enable-sdl \ |
31 | --enable-png \ | 31 | --enable-png \ |
32 | --enable-live555 --enable-tremor \ | 32 | --enable-tremor \ |
33 | --enable-v4l2 --disable-aa --disable-faad \ | 33 | --enable-v4l2 --disable-aa --disable-faad \ |
34 | --enable-dbus \ | 34 | --enable-dbus \ |
35 | --without-contrib \ | 35 | --without-contrib \ |
36 | --without-kde-solid \ | 36 | --without-kde-solid \ |
37 | --disable-glx \ | 37 | --disable-glx \ |
38 | --enable-realrtsp \ | 38 | --enable-realrtsp \ |
39 | --disable-libtar \ | ||
39 | ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \ | 40 | ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \ |
40 | ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \ | 41 | ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \ |
41 | ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \ | 42 | ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \ |
42 | " | 43 | " |
43 | 44 | ||
45 | PACKAGECONFIG ?= " live555" | ||
44 | PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad" | 46 | PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad" |
45 | PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52" | 47 | PACKAGECONFIG[a52] = "--enable-a52,--disable-a52,liba52" |
46 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" | 48 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" |
@@ -48,18 +50,13 @@ PACKAGECONFIG[live555] = "--enable-live555,--disable-live555,live555" | |||
48 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" | 50 | PACKAGECONFIG[libass] = "--enable-libass,--disable-libass,libass" |
49 | PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml" | 51 | PACKAGECONFIG[mkv] = "--enable-mkv,--disable-mkv,libmatroska libebml" |
50 | 52 | ||
51 | do_configure() { | 53 | do_configure_prepend() { |
52 | cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/ | ||
53 | ./bootstrap | ||
54 | gnu-configize --force | ||
55 | libtoolize --force | ||
56 | #autoreconf --force -i | ||
57 | cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true | 54 | cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true |
58 | oe_runconf | 55 | } |
59 | rm config.log | 56 | |
60 | #sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g ${S}/vlc-config | 57 | do_configure_append() { |
61 | sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile | 58 | sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${B}/include\ -DSYS_LINUX:g ${B}/modules/gui/qt4/Makefile |
62 | sed -i -e s:'${top_builddir_slash}libtool':${TARGET_SYS}-libtool:g ${S}/doltlibtool | 59 | sed -i -e s:'${top_builddir_slash}libtool':${TARGET_SYS}-libtool:g ${B}/doltlibtool |
63 | } | 60 | } |
64 | 61 | ||
65 | # This recipe packages vlc as a library as well, so qt4 dependencies | 62 | # This recipe packages vlc as a library as well, so qt4 dependencies |