summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-10-04 14:03:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-15 17:29:30 +0000
commit36f873f8d59bd8b2afa962fce51b546f281c866f (patch)
treef8642e27a72c5ea95edbeebab4382cc4670f45d1
parent328156b2b070b411e4ce7ad45a3e9c43b54dfc28 (diff)
downloadmeta-openembedded-36f873f8d59bd8b2afa962fce51b546f281c866f.tar.gz
python3-ujson: support Python 3
Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-ujson.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-ujson_1.35.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-ujson_1.35.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-ujson.inc b/meta-python/recipes-devtools/python/python-ujson.inc
new file mode 100644
index 000000000..9654d5ad3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-ujson.inc
@@ -0,0 +1,15 @@
1SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab"
6
7SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24"
8SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86"
9
10inherit pypi
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-numbers \
15 "
diff --git a/meta-python/recipes-devtools/python/python-ujson_1.35.bb b/meta-python/recipes-devtools/python/python-ujson_1.35.bb
index 238dc9286..b3c6ae66f 100644
--- a/meta-python/recipes-devtools/python/python-ujson_1.35.bb
+++ b/meta-python/recipes-devtools/python/python-ujson_1.35.bb
@@ -1,15 +1,2 @@
1SUMMARY = "Ultra fast JSON encoder and decoder for Python" 1inherit setuptools
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3." 2require python-ujson.inc
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;startline=8;endline=9;md5=4f369b3c3c290b4aede8796a4065e5ab"
6
7SRC_URI[md5sum] = "42f77b0cce686dfa4da2e68480b1dd24"
8SRC_URI[sha256sum] = "f66073e5506e91d204ab0c614a148d5aa938bdbf104751be66f8ad7a222f5f86"
9
10inherit pypi setuptools
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-numbers \
15 "
diff --git a/meta-python/recipes-devtools/python/python3-ujson_1.35.bb b/meta-python/recipes-devtools/python/python3-ujson_1.35.bb
new file mode 100644
index 000000000..ae4cc0a81
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ujson_1.35.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-ujson.inc