summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-06-12 18:13:44 +0000
committerArmin Kuster <akuster808@gmail.com>2018-09-04 07:33:51 -0700
commit280157bc380ff98d24ac89674e332c48802574b1 (patch)
tree5d027957071543e2f764bd7de83a14ad0ad8a6e9
parentd1824f5572faa9d7cc8eb14dd83d61faa8c35988 (diff)
downloadmeta-openembedded-280157bc380ff98d24ac89674e332c48802574b1.tar.gz
rarpd, sblim-sfcb, openct: inherit systemd unconditionally
* the inherit was controlled by VIRTUAL-RUNTIME_init_manager and the installation of .service files by DISTRO_FEATURES and systemd was in DISTRO_FEATURES but not in VIRTUAL-RUNTIME_init_manager it was causing QA issues about unpackaged .service files ERROR: rarpd-ss981107-r0 do_package: QA Issue: rarpd: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/rarpd.service ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/sblim-sfcb.service ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/sblim-sfcb.service * systemd.bbclass will take care of removing /lib/systemd when systemd isn't in DISTRO_FEATURES, so we can remove both conditions Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb8
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb8
-rw-r--r--meta-oe/recipes-support/openct/openct_0.6.20.bb8
3 files changed, 9 insertions, 15 deletions
diff --git a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
index 4025b8087..7c9f2df9d 100644
--- a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
+++ b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
@@ -38,13 +38,11 @@ do_install() {
38 install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8 38 install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8
39 install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers 39 install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers
40 40
41 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 41 install -d ${D}${systemd_unitdir}/system
42 install -d ${D}${systemd_unitdir}/system 42 install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
43 install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
44 fi
45} 43}
46 44
47inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} 45inherit systemd
48 46
49SYSTEMD_PACKAGES = "${PN}" 47SYSTEMD_PACKAGES = "${PN}"
50SYSTEMD_SERVICE_${PN} = "rarpd.service" 48SYSTEMD_SERVICE_${PN} = "rarpd.service"
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index c6b9f1019..3db8c1484 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -28,7 +28,7 @@ SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
28SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" 28SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"
29 29
30inherit autotools 30inherit autotools
31inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} 31inherit systemd
32 32
33SYSTEMD_PACKAGES = "${PN}" 33SYSTEMD_PACKAGES = "${PN}"
34SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" 34SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service"
@@ -53,10 +53,8 @@ do_install() {
53 53
54 oe_runmake DESTDIR=${D} install 54 oe_runmake DESTDIR=${D} install
55 55
56 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 56 install -d ${D}${systemd_unitdir}/system
57 install -d ${D}${systemd_unitdir}/system 57 install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
58 install -m 0644 ${WORKDIR}/sfcb.service ${D}${systemd_unitdir}/system/sblim-sfcb.service
59 fi
60 58
61 install -d ${D}${sysconfdir}/init.d 59 install -d ${D}${sysconfdir}/init.d
62 mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb 60 mv ${D}${sysconfdir}/init.d/sfcb ${D}${sysconfdir}/init.d/sblim-sfcb
diff --git a/meta-oe/recipes-support/openct/openct_0.6.20.bb b/meta-oe/recipes-support/openct/openct_0.6.20.bb
index c7d7203ed..913290cd9 100644
--- a/meta-oe/recipes-support/openct/openct_0.6.20.bb
+++ b/meta-oe/recipes-support/openct/openct_0.6.20.bb
@@ -25,7 +25,7 @@ SRC_URI[sha256sum] = "6cd3e2933d29eb1f875c838ee58b8071fd61f0ec8ed5922a86c01c805d
25LICENSE = "LGPLv2+" 25LICENSE = "LGPLv2+"
26LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" 26LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
27 27
28inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)} 28inherit systemd
29SYSTEMD_SERVICE_${PN} += "openct.service " 29SYSTEMD_SERVICE_${PN} += "openct.service "
30SYSTEMD_AUTO_ENABLE = "enable" 30SYSTEMD_AUTO_ENABLE = "enable"
31 31
@@ -77,10 +77,8 @@ do_install () {
77 install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct 77 install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct
78 install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct 78 install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct
79 79
80 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 80 install -d ${D}/${systemd_unitdir}/system
81 install -d ${D}/${systemd_unitdir}/system 81 install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system
82 install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system
83 fi
84 82
85 so=$(find ${D} -name \*.so | sed "s|^${D}||") 83 so=$(find ${D} -name \*.so | sed "s|^${D}||")
86 sed -i -e 's|\\(LIBPATH\\s*\\).*|\\1$so|' etc/reader.conf 84 sed -i -e 's|\\(LIBPATH\\s*\\).*|\\1$so|' etc/reader.conf