summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:12:51 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:08:45 +0200
commit16b6e71213b84e8e516735b2711a5194407039f1 (patch)
treeed93a9017857db5e527884b2cee111d7939fe342
parent1d6b6944597876b92bb93a2ff064252439001527 (diff)
downloadmeta-openembedded-16b6e71213b84e8e516735b2711a5194407039f1.tar.gz
openlmi-tools: Only build if the necessary python pieces are available
Since this isn't a python library it doesn't really belong to meta-python. But I couldn't figure out where else to move it to. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
index b23869d76..13e67cba1 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -21,3 +21,8 @@ do_compile_prepend() {
21do_install_prepend() { 21do_install_prepend() {
22 cd cli 22 cd cli
23} 23}
24
25python() {
26 if 'meta-python' not in d.getVar('BBFILE_COLLECTIONS').split():
27 raise bb.parse.SkipRecipe('Requires meta-python to be present.')
28}