summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Balister <philip@opensdr.com>2012-04-11 23:11:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-04-12 09:01:11 +0200
commit12deef7ad4b2c84db0e2c1b6686994929824c244 (patch)
tree81d008039ba2255454d43dec333364b84d6f6f8f
parent8ddf0dc41aade09aeaec02268cf70cc72bc7b43a (diff)
downloadmeta-openembedded-12deef7ad4b2c84db0e2c1b6686994929824c244.tar.gz
gnuradio : Update to version 3.5.3.
Signed-off-by: Philip Balister <philip@opensdr.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb79
1 files changed, 71 insertions, 8 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index d5e297d1b..ae8ebca8c 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -1,18 +1,81 @@
1require gnuradio.inc 1DESCRIPTION = "GNU Radio"
2URL = "http://gnuradio.org"
3SECTION = "apps"
4PRIORITY = "optional"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
2 7
3PR = "${INC_PR}.0" 8PR = "r0"
4PV = "3.4.0-${PR}+gitr${SRCREV}"
5 9
6SRCREV = "62768eedf8f68680ef3a672a27025227e22ccbb0" 10DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \
11 swig-native python-numpy python-pygtk orc qt4-x11-free qwt"
12
13inherit distutils-base cmake pkgconfig
14
15export BUILD_SYS
16export HOST_SYS="${MULTIMACH_TARGET_SYS}"
17
18RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
19 python-lang python-textutils python-shell python-pickle \
20 python-compiler python-pkgutil python-pydoc python-mmap \
21 python-netclient python-difflib \
22 python-pprint python-numpy python-pygtk python-lxml \
23 "
24
25C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
26
27#do_configure_append() {
28# find ${S} -name Makefile | xargs sed -i s:'-I${STAGING_INCDIR_NATIVE'::g
29# find ${S} -name Makefile | xargs sed -i s:'-L${STAGING_LIBDIR_NATIVE'::g
30#}
31
32do_configure_prepend() {
33 ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
34 echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
35 echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt
36 echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt
37}
38
39do_compile_prepend() {
40 cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
41}
42
43PACKAGES =+ "\
44 ${PN}-examples \
45 ${PN}-grc \
46"
47
48FILES_${PN}-grc = "${datadir}/gnuradio/grc"
49
50FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/*"
51FILES_${PN} += "${datadir}/gnuradio/*"
52# The following needs fixing upstream
53FILES_${PN} += "${prefix}/etc/gnuradio/*"
54
55FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \
56 ${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \
57 "
58FILES_${PN}-examples = "${datadir}/gnuradio/examples"
59
60PV = "3.5.3"
61
62FILESPATHPKG_prepend = "gnuradio-git:"
63
64SRCREV = "f621a52f779381cfe550b4278b83e701a747944c"
7 65
8# Make it easy to test against developer repos and branches 66# Make it easy to test against developer repos and branches
9GIT_REPO = "gnuradio.git" 67GIT_REPO = "gnuradio.git"
10GIT_BRANCH = "next" 68GIT_BRANCH = "master"
11 69
12SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \ 70SRC_URI = "git://gnuradio.org/git/${GIT_REPO};branch=${GIT_BRANCH};protocol=http \
13 file://0001-volk-Remove-all-traces-of-volk-from-configure-for-OE.patch \ 71"
14 file://0001-buildsys-don-t-add-usr-include-and-usr-lib-to-config.patch \
15 "
16 72
17S="${WORKDIR}/git" 73S="${WORKDIR}/git"
18 74
75OECMAKE_BUILDPATH = "${S}/build"
76OECMAKE_SOURCEPATH = "${S}"
77
78EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE -DENABLE_GR_QTGUI=ON -DENABLE_GR_WXGUI=OFF -DENABLE_GR_VIDEO_SDL=OFF -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore -DQT_LIBRARY_DIR=${STAGING_LIBDIR} -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so -DENABLE_GR_FCD=OFF -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt"
79
80EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
81