summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:54 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-11 13:26:25 -0800
commit0f1dff98a4d4a5c863ca5f4b1fd6c52c2efbe709 (patch)
tree0a9a45a7d3b1473bdcf2149bd70a868d8587dbf0
parent9132eef66b8f82ef1005a9e76e750d18a6f431f7 (diff)
downloadmeta-openembedded-0f1dff98a4d4a5c863ca5f4b1fd6c52c2efbe709.tar.gz
python-twisted: clean-up the dependencies
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-twisted.inc4
-rw-r--r--meta-python/recipes-devtools/python/python-twisted_17.9.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb2
3 files changed, 4 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python-twisted.inc b/meta-python/recipes-devtools/python/python-twisted.inc
index 4bd478867..0dd584f9f 100644
--- a/meta-python/recipes-devtools/python/python-twisted.inc
+++ b/meta-python/recipes-devtools/python/python-twisted.inc
@@ -41,16 +41,16 @@ PACKAGES =+ "\
41 41
42RDEPENDS_${PN} = "\ 42RDEPENDS_${PN} = "\
43 ${PN}-bin \ 43 ${PN}-bin \
44 ${PN}-core \
44 ${PN}-conch \ 45 ${PN}-conch \
45 ${PN}-mail \ 46 ${PN}-mail \
46 ${PN}-names \ 47 ${PN}-names \
47 ${PN}-news \
48 ${PN}-runner \ 48 ${PN}-runner \
49 ${PN}-web \ 49 ${PN}-web \
50 ${PN}-words \ 50 ${PN}-words \
51" 51"
52 52
53RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib" 53RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat"
54RDEPENDS_${PN}-test = "${PN}" 54RDEPENDS_${PN}-test = "${PN}"
55RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols" 55RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
56RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols" 56RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
diff --git a/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
index 3b4511077..2be1709d0 100644
--- a/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python-twisted_17.9.0.bb
@@ -1,4 +1,4 @@
1inherit pypi setuptools 1inherit pypi setuptools
2require python-twisted.inc 2require python-twisted.inc
3 3
4RDEPENDS_${PN}-core = "python-core python-zopeinterface python-contextlib" 4RDEPENDS_${PN}-core += "${PYTHON_PN}-contextlib"
diff --git a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
index 98016cca3..d7533d8e7 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_17.9.0.bb
@@ -1,7 +1,7 @@
1inherit pypi setuptools3 1inherit pypi setuptools3
2require python-twisted.inc 2require python-twisted.inc
3 3
4RDEPENDS_${PN}-core = "python3-core python3-zopeinterface python3-lang" 4RDEPENDS_${PN}-core += "python3-lang"
5 5
6FILES_${PN}-core_append += " \ 6FILES_${PN}-core_append += " \
7 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \ 7 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__pycache__ \