summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2016-03-06 14:56:42 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:23 +0100
commit08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5 (patch)
treef23730a5c9126fe9d99b14285ee3a9bff25886a3
parent7c43e026b1151e3c468fe8432dc1c35cd0122421 (diff)
downloadmeta-openembedded-08b0d3967ec5c2a5427ebdd19fee42ebbe20bec5.tar.gz
python-m2crypt: update package to 0.23.0
this happens to fix the cdra build issue related to the openssl 1.0.2g update. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch35
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb44
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb30
3 files changed, 46 insertions, 63 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index bcbdf24bb..819c8e569 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -10,30 +10,27 @@ Upstream-status: Unknown
10 setup.py | 6 +++--- 10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-) 11 1 file changed, 3 insertions(+), 3 deletions(-)
12 12
13diff --git a/setup.py b/setup.py 13Index: M2Crypto-0.23.0/setup.py
14index e7c49eb..8deaa34 100644 14===================================================================
15--- a/setup.py 15--- M2Crypto-0.23.0.orig/setup.py
16+++ b/setup.py 16+++ M2Crypto-0.23.0/setup.py
17@@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext): 17@@ -62,7 +62,7 @@ class _M2CryptoBuildExt(build_ext.build_
18 self.openssl = 'c:\\pkg' 18 self.openssl = 'c:\\pkg'
19 else: 19 else:
20 self.libraries = ['ssl', 'crypto'] 20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr' 21- self.openssl = '/usr'
22+ self.openssl = os.environ.get( "STAGING_DIR" ) 22+ self.openssl = os.environ.get( "STAGING_DIR" )
23 23
24
25 def finalize_options(self): 24 def finalize_options(self):
26@@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext): 25 '''Overloaded build_ext implementation to append custom openssl
26@@ -75,8 +75,8 @@ class _M2CryptoBuildExt(build_ext.build_
27 if _openssl and os.path.isdir(_openssl):
28 self.openssl = _openssl
27 29
28 build_ext.build_ext.finalize_options(self) 30- self.include_dirs.append(os.path.join(self.openssl, 'include'))
31- openssl_library_dir = os.path.join(self.openssl, 'lib')
32+ self.include_dirs.append(os.environ.get( "STAGING_INCDIR" ))
33+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
29 34
30- opensslIncludeDir = os.path.join(self.openssl, 'include') 35 if platform.system() == "Linux":
31- opensslLibraryDir = os.path.join(self.openssl, 'lib') 36 if _multiarch: # on Fedora/RHEL it is an empty string
32+ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
33+ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
34
35 self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
36 [opensslIncludeDir]]
37--
381.8.1.4
39
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
deleted file mode 100644
index a3f9a09c6..000000000
--- a/meta-python/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
3
4DEPENDS = "openssl swig-native python"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
8
9SRC_URI = " \
10 file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
11 file://0001-M2Crypto-Error-fix.patch"
12
13SRC_URI[md5sum] = "f93d8462ff7646397a9f77a2fe602d17"
14SRC_URI[sha256sum] = "25b94498505c2d800ee465db0cc1aff097b1615adc3ac042a1c85ceca264fc0a"
15
16PYPI_PACKAGE = "M2Crypto"
17inherit pypi setuptools
18
19SWIG_FEATURES_x86-64 = "-D__x86_64__"
20SWIG_FEATURES ?= ""
21export SWIG_FEATURES
22
23# Get around a problem with swig, but only if the
24# multilib header file exists.
25#
26do_compile_prepend() {
27 if [ "${SITEINFO_BITS}" = "64" ];then
28 bit="64"
29 else
30 bit="32"
31 fi
32
33 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
34 for i in SWIG/_ec.i SWIG/_evp.i; do
35 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
36 done
37 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
38 for i in SWIG/_ec.i SWIG/_evp.i; do
39 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
40 done
41 fi
42}
43
44BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
new file mode 100644
index 000000000..af8ca0954
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto_0.23.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=68f7880de949412b2ea248932d97ed54"
6
7SRCNAME = "M2Crypto"
8SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/M2Crypto-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "89557730e245294a6cab06de8ad4fb42"
11SRC_URI[sha256sum] = "1ac3b6eafa5ff7e2a0796675316d7569b28aada45a7ab74042ad089d15a9567f"
12
13SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch "
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19DEPENDS += "openssl swig-native"
20
21DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_DIR_HOST} -I${STAGING_INCDIR}"
22DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_DIR_HOST}"
23
24inherit setuptools
25
26SWIG_FEATURES_x86-64 = "-D__x86_64__"
27SWIG_FEATURES ?= ""
28export SWIG_FEATURES
29
30BBCLASSEXTEND = "native"