diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-05 12:23:57 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-11 01:52:58 +0100 |
commit | d0d77c7ba4d8163f0125a9500e1752dea79fde7c (patch) | |
tree | 6987ef9945804bd8a6900a055675bb940be40bab | |
parent | 7540bc476778052b7435760a34f04803166f8490 (diff) | |
download | meta-openembedded-d0d77c7ba4d8163f0125a9500e1752dea79fde7c.tar.gz |
systemd: add target python to depends
* pythonnative adds only python-native to DEPENDS, but we need target python for working python-config
checking for python-config... /OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/python-native/python-config
Traceback (most recent call last):
File "/OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/python-native/python-config", line 24, in <module>
pyver = sysconfig.get_config_var('VERSION')
File "/OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib/python2.7/distutils/sysconfig.py", line 602, in get_config_var
return get_config_vars().get(name)
File "/OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib/python2.7/distutils/sysconfig.py", line 518, in get_config_vars
func()
File "/OE/jansa-test/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/lib/python2.7/distutils/sysconfig.py", line 416, in _init_posix
raise DistutilsPlatformError(my_msg)
distutils.errors.DistutilsPlatformError: invalid Python installation: unable to open /OE/jansa-test/shr-core/tmp-eglibc/sysroots/om-gta02/usr/lib/python2.7/config/Makefile (No such file or directory)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-systemd/recipes-core/systemd/systemd_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb index 341e85d0c..9005abddc 100644 --- a/meta-systemd/recipes-core/systemd/systemd_git.bb +++ b/meta-systemd/recipes-core/systemd/systemd_git.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe \ | |||
8 | 8 | ||
9 | PROVIDES = "udev" | 9 | PROVIDES = "udev" |
10 | 10 | ||
11 | DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers usbutils glib-2.0 libgcrypt" | 11 | DEPENDS = "xz kmod docbook-sgml-dtd-4.1-native intltool-native gperf-native acl readline dbus libcap libcgroup tcp-wrappers usbutils glib-2.0 libgcrypt python" |
12 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | 12 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
13 | 13 | ||
14 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" | 14 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" |
@@ -19,7 +19,7 @@ inherit gitpkgv | |||
19 | PKGV = "v${GITPKGVTAG}" | 19 | PKGV = "v${GITPKGVTAG}" |
20 | 20 | ||
21 | PV = "git" | 21 | PV = "git" |
22 | PR = "r11" | 22 | PR = "r12" |
23 | 23 | ||
24 | # need to export these variables for python-config to work | 24 | # need to export these variables for python-config to work |
25 | export BUILD_SYS | 25 | export BUILD_SYS |